Connection ERROR



  • Hello everybody
    I have the following problem:
    The transmitter RFID + repeater does not connect. After several attempts he does.

    Now I have the next problem:
    I get an error displayed even though the gateway receives the sender.

    I ask for help because I am desperate

    Starting repeater (RNNRA-, 2.0.0)
    TSM:INIT
    TSM:RADIO:OK
    TSP:ASSIGNID:OK (ID=12)
    TSM:FPAR
    TSP:MSG:SEND 12-12-255-255 s=255,c=3,t=7,pt=0,l=0,sg=0,ft=0,st=bc:
    TSM:FPAR
    TSP:MSG:SEND 12-12-255-255 s=255,c=3,t=7,pt=0,l=0,sg=0,ft=0,st=bc:
    TSM:FPAR
    TSP:MSG:SEND 12-12-255-255 s=255,c=3,t=7,pt=0,l=0,sg=0,ft=0,st=bc:
    TSM:FPAR
    TSP:MSG:SEND 12-12-255-255 s=255,c=3,t=7,pt=0,l=0,sg=0,ft=0,st=bc:
    !TSM:FPAR:FAIL
    !TSM:FAILURE
    TSM:PDT
    

    After 100 try it connects but I get errors displayed

    Starting repeater (RNNRA-, 2.0.0)
    TSM:INIT
    TSM:RADIO:OK
    TSP:ASSIGNID:OK (ID=12)
    TSM:FPAR
    TSP:MSG:SEND 12-12-255-255 s=255,c=3,t=7,pt=0,l=0,sg=0,ft=0,st=bc:
    TSP:MSG:READ 0-0-12 s=255,c=3,t=8,pt=1,l=1,sg=0:0
    TSP:MSG:FPAR RES (ID=0, dist=0)
    TSP:MSG:PAR OK (ID=0, dist=1)
    TSP:MSG:READ 16-16-255 s=255,c=3,t=7,pt=0,l=0,sg=0:
    TSP:MSG:BC
    TSM:FPAR:OK
    TSM:ID
    TSM:CHKID:OK (ID=12)
    TSM:UPL
    TSP:PING:SEND (dest=0)
    TSP:MSG:SEND 12-12-0-0 s=255,c=3,t=24,pt=1,l=1,sg=0,ft=0,st=ok:1
    TSP:MSG:READ 0-0-12 s=255,c=3,t=25,pt=1,l=1,sg=0:1
    TSP:MSG:PONG RECV (hops=1)
    TSP:CHKUPL:OK
    TSM:UPL:OK
    TSM:READY
    Found NFC chip PN532
    Firmware ver. 1.6
    open lock
    NODE:!REG
    TSP:MSG:SEND 12-12-0-0 s=255,c=3,t=15,pt=6,l=2,sg=0,ft=0,st=ok:0100
    !TSP:MSG:SEND 12-12-0-0 s=255,c=0,t=18,pt=0,l=5,sg=0,ft=0,st=fail:2.0.0
    TSP:MSG:SEND 12-12-0-0 s=255,c=3,t=6,pt=1,l=1,sg=0,ft=1,st=ok:0
    TSP:MSG:READ 0-0-12 s=255,c=3,t=6,pt=0,l=1,sg=0:M
    TSP:MSG:SEND 12-12-0-0 s=255,c=3,t=11,pt=0,l=9,sg=0,ft=0,st=ok:RFID Lock
    TSP:MSG:SEND 12-12-0-0 s=255,c=3,t=12,pt=0,l=3,sg=0,ft=0,st=ok:1.0
    TSP:MSG:SEND 12-12-0-0 s=99,c=0,t=19,pt=0,l=0,sg=0,ft=0,st=ok:
    Request registration...
    TSP:MSG:SEND 12-12-0-0 s=255,c=3,t=26,pt=1,l=1,sg=0,ft=0,st=ok:2
    TSP:MSG:READ 0-0-12 s=255,c=3,t=27,pt=1,l=1,sg=0:1
    Node registration=1
    Init complete, id=12, parent=0, distance=1, registration=1
    Found tag id: 0xE2,0x97,0x6D,0xF3,0x00,0x00,0x00
    close lock
    !TSP:MSG:SEND 12-12-0-0 s=99,c=1,t=16,pt=1,l=1,sg=0,ft=0,st=fail:0
    

    same Problems with 2.1`

    0 MCO:BGN:INIT REPEATER,CP=RNNRA--,VER=2.1.0
    3 TSM:INIT
    4 TSF:WUR:MS=0
    11 TSM:INIT:TSP OK
    13 TSM:INIT:STATID=12
    15 TSF:SID:OK,ID=12
    17 TSM:FPAR
    53 TSF:MSG:SEND,12-12-255-255,s=255,c=3,t=7,pt=0,l=0,sg=0,ft=0,st=OK:
    2060 !TSM:FPAR:NO REPLY
    2062 TSM:FPAR
    2098 TSF:MSG:SEND,12-12-255-255,s=255,c=3,t=7,pt=0,l=0,sg=0,ft=0,st=OK:
    4106 !TSM:FPAR:NO REPLY
    4108 TSM:FPAR
    4144 TSF:MSG:SEND,12-12-255-255,s=255,c=3,t=7,pt=0,l=0,sg=0,ft=0,st=OK:
    6152 !TSM:FPAR:NO REPLY
    6154 TSM:FPAR
    6190 TSF:MSG:SEND,12-12-255-255,s=255,c=3,t=7,pt=0,l=0,sg=0,ft=0,st=OK:
    8198 !TSM:FPAR:FAIL
    8199 TSM:FAIL:CNT=1
    8201 TSM:FAIL:PDT
    18204 TSM:FAIL:RE-INIT
    18206 TSM:INIT
    18213 TSM:INIT:TSP OK
    18215 TSM:INIT:STATID=12
    18217 TSF:SID:OK,ID=12
    18220 TSM:FPAR
    18256 TSF:MSG:SEND,12-12-255-255,s=255,c=3,t=7,pt=0,l=0,sg=0,ft=0,st=OK:
    20264 !TSM:FPAR:NO REPLY
    20267 TSM:FPAR
    20303 TSF:MSG:SEND,12-12-255-255,s=255,c=3,t=7,pt=0,l=0,sg=0,ft=0,st=OK:
    22311 !TSM:FPAR:NO REPLY
    22313 TSM:FPAR
    22350 TSF:MSG:SEND,12-12-255-255,s=255,c=3,t=7,pt=0,l=0,sg=0,ft=0,st=OK:
    24357 !TSM:FPAR:NO REPLY
    24359 TSM:FPAR
    24396 TSF:MSG:SEND,12-12-255-255,s=255,c=3,t=7,pt=0,l=0,sg=0,ft=0,st=OK:
    26403 !TSM:FPAR:FAIL
    26404 TSM:FAIL:CNT=2
    26406 TSM:FAIL:PDT
    36409 TSM:FAIL:RE-INIT
    36411 TSM:INIT
    36418 TSM:INIT:TSP OK
    36420 TSM:INIT:STATID=12
    36422 TSF:SID:OK,ID=12
    36424 TSM:FPAR
    36461 TSF:MSG:SEND,12-12-255-255,s=255,c=3,t=7,pt=0,l=0,sg=0,ft=0,st=OK:
    38468 !TSM:FPAR:NO REPLY
    38470 TSM:FPAR
    38507 TSF:MSG:SEND,12-12-255-255,s=255,c=3,t=7,pt=0,l=0,sg=0,ft=0,st=OK:
    40514 !TSM:FPAR:NO REPLY
    40516 TSM:FPAR
    40553 TSF:MSG:SEND,12-12-255-255,s=255,c=3,t=7,pt=0,l=0,sg=0,ft=0,st=OK:
    42560 !TSM:FPAR:NO REPLY
    42562 TSM:FPAR
    42599 TSF:MSG:SEND,12-12-255-255,s=255,c=3,t=7,pt=0,l=0,sg=0,ft=0,st=OK:
    44606 !TSM:FPAR:FAIL
    44607 TSM:FAIL:CNT=3
    44609 TSM:FAIL:PDT
    54612 TSM:FAIL:RE-INIT
    54615 TSM:INIT
    54622 TSM:INIT:TSP OK
    54624 TSM:INIT:STATID=12
    54626 TSF:SID:OK,ID=12
    54628 TSM:FPAR
    54665 TSF:MSG:SEND,12-12-255-255,s=255,c=3,t=7,pt=0,l=0,sg=0,ft=0,st=OK:
    56672 !TSM:FPAR:NO REPLY
    56674 TSM:FPAR
    56711 TSF:MSG:SEND,12-12-255-255,s=255,c=3,t=7,pt=0,l=0,sg=0,ft=0,st=OK:
    58718 !TSM:FPAR:NO REPLY
    58720 TSM:FPAR
    58757 TSF:MSG:SEND,12-12-255-255,s=255,c=3,t=7,pt=0,l=0,sg=0,ft=0,st=OK:
    60764 !TSM:FPAR:NO REPLY
    60766 TSM:FPAR
    60803 TSF:MSG:SEND,12-12-255-255,s=255,c=3,t=7,pt=0,l=0,sg=0,ft=0,st=OK:
    62810 !TSM:FPAR:FAIL
    62811 TSM:FAIL:CNT=4
    62813 TSM:FAIL:PDT
    72816 TSM:FAIL:RE-INIT
    72818 TSM:INIT
    72825 TSM:INIT:TSP OK
    72827 TSM:INIT:STATID=12
    72829 TSF:SID:OK,ID=12
    72832 TSM:FPAR
    72868 TSF:MSG:SEND,12-12-255-255,s=255,c=3,t=7,pt=0,l=0,sg=0,ft=0,st=OK:
    74876 !TSM:FPAR:NO REPLY
    74878 TSM:FPAR
    74915 TSF:MSG:SEND,12-12-255-255,s=255,c=3,t=7,pt=0,l=0,sg=0,ft=0,st=OK:
    
    
    
    
    

    gateway:

    0;255;3;0;9;Starting gateway (RNNGA-, 2.0.0)
    0;255;3;0;9;TSM:INIT
    0;255;3;0;9;TSM:RADIO:OK
    0;255;3;0;9;TSM:GW MODE
    0;255;3;0;9;TSM:READY
    0;255;3;0;14;Gateway startup complete.
    0;255;0;0;18;2.0.0
    0;255;3;0;9;No registration required
    0;255;3;0;9;Init complete, id=0, parent=0, distance=0, registration=1
    0;255;3;0;9;TSP:MSG:READ 3-3-0 s=2,c=1,t=16,pt=0,l=1,sg=0:1
    3;2;1;0;16;1
    0;255;3;0;9;TSP:MSG:READ 16-16-255 s=255,c=3,t=7,pt=0,l=0,sg=0:
    0;255;3;0;9;TSP:MSG:BC
    0;255;3;0;9;TSP:MSG:FPAR REQ (sender=16)
    0;255;3;0;9;TSP:CHKUPL:OK
    0;255;3;0;9;TSP:MSG:GWL OK
    0;255;3;0;9;!TSP:MSG:SEND 0-0-16-16 s=255,c=3,t=8,pt=1,l=1,sg=0,ft=0,st=fail:0
    0;255;3;0;9;TSP:MSG:READ 3-3-0 s=11,c=1,t=11,pt=7,l=5,sg=0:18.0
    3;11;1;0;11;18.0
    0;255;3;0;9;TSP:MSG:READ 3-3-0 s=10,c=1,t=11,pt=7,l=5,sg=0:22.0
    3;10;1;0;11;22.0
    0;255;3;0;9;TSP:MSG:READ 3-3-0 s=2,c=1,t=16,pt=0,l=1,sg=0:0
    3;2;1;0;16;0
    0;255;3;0;9;TSP:MSG:READ 16-16-255 s=255,c=3,t=7,pt=0,l=0,sg=0:
    0;255;3;0;9;TSP:MSG:BC
    0;255;3;0;9;TSP:MSG:FPAR REQ (sender=16)
    0;255;3;0;9;TSP:CHKUPL:OK (FLDCTRL)
    0;255;3;0;9;TSP:MSG:GWL OK
    0;255;3;0;9;!TSP:MSG:SEND 0-0-16-16 s=255,c=3,t=8,pt=1,l=1,sg=0,ft=0,st=fail:0
    0;255;3;0;9;TSP:MSG:READ 16-16-255 s=255,c=3,t=7,pt=0,l=0,sg=0:
    0;255;3;0;9;TSP:MSG:BC
    0;255;3;0;9;TSP:MSG:FPAR REQ (sender=16)
    0;255;3;0;9;TSP:CHKUPL:OK (FLDCTRL)
    0;255;3;0;9;TSP:MSG:GWL OK
    0;255;3;0;9;!TSP:MSG:SEND 0-0-16-16 s=255,c=3,t=8,pt=1,l=1,sg=0,ft=0,st=fail:0

  • Admin

    @t1m0 Sounds to me like a power / bad radio issue: try adding a larger cap and/or replace the radio



  • @tekka
    i have same problem . and i see some topic about this issue recently (similar errors). i used lib 1.5 before with some hardware (4.7u capacitor , nrf24 , power supply and etc) and now i use lib 2.1.1 and use same hardwares. but i have errors including:

    !TSM:FPAR:FAIL
    !TSM:FAILURE
    TSM:PDT
    
    and
    NACK
    
    and
    !TSM:FPAR:NO REPLY
    
    

    i think this is related to lib 2.1.because i test very module but dont solve problem.
    i use 3 type of radio with/without antena . use capacitor 4.7 - 100 - 470 . use power 5v 10A . use radio adapter (reglator 5 to 3.3)

    also i test several state for pa_level (min - low - high - max) for gateway and nodes. i tested all states (software and hardware)



  • I have the sensor placed directly next to the gateway and it works.
    Now I have set between the wanted stretch and a repeater and it seems to work.
    I find the error message very gaps.


Log in to reply
 

Looks like your connection to MySensors Forum was lost, please wait while we try to reconnect.