Vera - Ethernet Gateway - Node Issues



  • I was originally having issues adding a Dallas Temp Sensor node. Though I appear to have multiple problems. I deleted and reloaded the MySensors plugin from Vera, reuploaded the LUUP files from Vera-Master. Readded sensors, after clearing eeprom with "EEPROM.write(i, 0xff);". It added my 2 nodes, however, for one it did not add the actual sensors, for the second it did not add the node info. I added the nodes separately, not at the same time.

    Also, the third node I tried adding did not load at all. It is a dallas temp sensor on an Arduino Pro 5v. Issues adding this node are what kicked off reloading MySensors plugin.

    Node 0 is a test node on an Uno, Humidity sketch right now. Vera shows node info, but no data. Watching on serial monitor, the sensor is reporting humidity and temp(in Imperial as I want).

    sensor started, id 0
    send: 0-0-0-0 s=255,c=0,t=17,pt=0,l=5,st=fail:1.4.1
    send: 0-0-0-0 s=255,c=3,t=6,pt=1,l=1,st=fail:0
    send: 0-0-0-0 s=255,c=3,t=11,pt=0,l=8,st=fail:Humidity
    send: 0-0-0-0 s=255,c=3,t=12,pt=0,l=3,st=fail:1.0
    send: 0-0-0-0 s=0,c=0,t=7,pt=0,l=5,st=fail:1.4.1
    send: 0-0-0-0 s=1,c=0,t=6,pt=0,l=5,st=fail:1.4.1
    send: 0-0-0-0 s=1,c=1,t=0,pt=7,l=5,st=fail:68.0
    send: 0-0-255-255 s=255,c=3,t=7,pt=0,l=0,st=fail:
    T: 68.00
    send: 0-0-0-0 s=0,c=1,t=1,pt=7,l=5,st=ok:43.0
    H: 43.00
    

    Node 1 is a Dallas node on a Nano. Vera shows sensor data(2 dallas sensors), but not the node info, also the info shown is Metric, and the sketch is set for Imperial.
    I have 6 other temp sensor nodes on Pro 5v's which I have yet to gather and reload.

    sensor started, id 1
    send: 1-1-0-0 s=255,c=0,t=17,pt=0,l=5,st=fail:1.4.1
    send: 1-1-0-0 s=255,c=3,t=6,pt=1,l=1,st=ok:0
    send: 1-1-0-0 s=255,c=3,t=11,pt=0,l=18,st=fail:Temperature Sensor
    send: 1-1-0-0 s=255,c=3,t=12,pt=0,l=3,st=fail:1.0
    send: 1-1-0-0 s=0,c=0,t=6,pt=0,l=5,st=ok:1.4.1
    send: 1-1-0-0 s=1,c=0,t=6,pt=0,l=5,st=ok:1.4.1
    send: 1-1-0-0 s=0,c=1,t=0,pt=7,l=5,st=fail:17.8
    send: 1-1-0-0 s=1,c=1,t=0,pt=7,l=5,st=fail:18.5
    

    Anyone have any suggestions? Sketches used are unedited(except changing metric) from MySensors library.

    Capture.PNG



  • You shouldn't use node 0.
    The gateway is using adress 0.



  • @JeJ

    It was assigned Node 0.... I did not manually specify it


  • Hardware Contributor

    I have similar inclusion-mode issues when using my enc28j60 (uip-)Ethernet gateway with my VeraLiteUI5. I haven't yet tried the w5100 Ethernet gateway.
    Try using a serial gateway for inlcusion and then change to a Ethernet-gw. Once sensors are inlcuded the Ethernet gateway is much more stable with Vera..



  • @m26872 I am using the 5100, thanks for the info. An unfortunately extensive solution.

    Is there somewhere to make a bug report? Or to try to help start debugging this issue?

    EDIT: I suppose waiting on MySensors 2.0 will actually be the preferred method, why put time in to a 1.0 issue when something new is coming shortly.


  • Admin

    @NotYetRated

    It's a mystery how you managed to get a node with id 0. And you seem to get an awful lot of failed transmissions (acks). Power issue/busy radio channel?



  • @hek Rebooted my ethernet gateway, cleared eeprom on the node which was assigned 0, and reloaded the sketch and it was found and identified, given a proper node number, and it semi-working.

    Still will only display/transmit in Metric.

    As for the failed transmissions, I had not really paid attention to/noticed that. My home network is one of two total visible in my house. Home network, 2.4GHz is on channel 10, 2.457 GHz. Cannot find info for what frequency RF24 channel 76 is. Perhaps I should try changing this?

    My gateway is using the NRF24L01+PA+LNA Antenna version. Currently, all sensors are through 2 walls, 10 feet from gateway.

    Thoughts on things to trial?

    EDIT: Also, I monitored the device on node 1, and as it sends temperature updates, it noted st=fail, though vera shows the proper updated temps.


  • Admin

    Try lowering the transmission power on the gateway (MyConfig.h) or power radio separately. Also try adding a capacitor if it's missing.

    Your gateway is clearly having problems sending back acks to the sensors.



  • @hek Thanks for the reply.

    MyConfig.h, "define RF24_PA_LEVEL_GW" from "RF24_PA_LOW" to "RF24_PA_MIN"?

    Will then trial the capacitor, and power it separately if necessary. Gateway is a Nano, powered via USB to a wall wort.


  • Hardware Contributor

    @NotYetRated
    Today I had real good progress with inclusion mode on my enc28J60-ethernet-gateway by adding "delay(100)" before every(!) send-message call in the sensor node code.
    For the record; I made the inclusion (both before and after the fix) through a repaeter node which I usually don't. I'm also not sure wether or not this was my first node with lib 1.4.1.



  • @m26872

    Thanks for the update! Will give it a try sometime later this week!


  • Hardware Contributor

    @NotYetRated I got a comment to the method by @BulldogLowell here.


Log in to reply
 

Looks like your connection to MySensors Forum was lost, please wait while we try to reconnect.