.mystools error



  • I'm new to mySensors so i've been trying various applications while I've been waiting for part to come.

    I'm using an Raspberry Pi3 for my workbench computer and it's been working out very well.

    I downloaded the ARM version of the Arduino IDE v1.8.1 and tried to various examples of Arduino .ino sketches and they all works fine.

    I downloaded the the latest version of mySonsor 2.1.1 and tried some of the example sketches and I get an error stating ".mystools" error on compiling the sketch.

    I've reverted to mySensors 2.0.0 with no compile errors.

    Is there a fix out there?

    Thanks - Mike


  • Mod

    @Mike37922 if you mean this message

    WARNING: Spurious .mystools folder in 'MySensors' library
    

    it is clearly not an error, it is a warning.

    It is a stupid warning though, with a long story. The Arduino people are a bit hard to work with unfortunately. https://github.com/arduino/arduino-builder/pull/198 has some details.



  • Thank you very much for a quick answer to my question!

    My next question is, can I just load the latest mySonsor (2.1.1) to my Arduino IDE or what?

    Sorry for being such a NOOBIE!!!!

    Thanks - Mike


  • Mod

    @Mike37922 you're welcome. Great to have a new member of the MySensors community :-)

    Yes, 2.1.1 is available for install through the library manager. Instructions at https://www.mysensors.org/about/arduino#installing-the-sensor-libraries in case you need them.


Log in to reply
 

Looks like your connection to MySensors Forum was lost, please wait while we try to reconnect.