[SOLVED] OH2 - Mosquito - Raspi Mysensors Gateway



  • Hello!
    While i'm waiting for my hardware (ordered a couple Sensebender Micro) i tried to set up Controller and Gateway.
    I followed the instructions from here here and configured with

    ./configure --my-gateway=mqtt --my-controller-ip-address=192.168.178.160 --my-mqtt-publish-topic-prefix=mysensors-out --my-mqtt-subscribe-topic-prefix=mysensors-in --my-mqtt-client-id=mygateway1
    

    But the Gateway doesn't connect to the controller:

    pi@raspgateway:~/MySensors $ sudo mysgw -d
    mysgw: Starting gateway...
    mysgw: Protocol version - 2.1.1
    mysgw: MCO:BGN:INIT GW,CP=RNNG---,VER=2.1.1
    mysgw: TSF:LRT:OK
    mysgw: TSM:INIT
    mysgw: TSF:WUR:MS=0
    mysgw: TSM:INIT:TSP OK
    mysgw: TSM:INIT:GW MODE
    mysgw: TSM:READY:ID=0,PAR=0,DIS=0
    mysgw: MCO:REG:NOT NEEDED
    mysgw: Listening for connections on 0.0.0.0:5003
    mysgw: MCO:BGN:STP
    mysgw: MCO:BGN:INIT OK,TSP=1
    ...
    

    Then nothing more follows...

    On openhabian (Raspberry) i installed the MQTT Binding (via OH2 paperUI) and Mosquitto (via openhabian config tool).
    What am i missing? :/

    Thanks in advance!
    Narf!



  • anybody? :(


  • Mod

    @narf said in OH2 - Mosquito - Raspi Mysensors Gateway:

    mysgw: Listening for connections on 0.0.0.0:5003

    That doesn't seem to be right...
    It seems it switches to listening (server) mode, while you are trying to configure an mqtt client connection. Myabe @marceloaqno has a clue?


  • Mod

    Did you try to recompile the gateway?



  • no - but i can try!
    i'll just have to run

    make
    

    and

    sudo make install
    

    again, right?



  • recompiling did the trick:

    pi@raspgateway:~/MySensors $ sudo ./bin/mysgw -d
    mysgw: Starting gateway...
    mysgw: Protocol version - 2.1.1
    mysgw: MCO:BGN:INIT GW,CP=RNNG---,VER=2.1.1
    mysgw: TSF:LRT:OK
    mysgw: TSM:INIT
    mysgw: TSF:WUR:MS=0
    mysgw: TSM:INIT:TSP OK
    mysgw: TSM:INIT:GW MODE
    mysgw: TSM:READY:ID=0,PAR=0,DIS=0
    mysgw: MCO:REG:NOT NEEDED
    mysgw: MCO:BGN:STP
    mysgw: MCO:BGN:INIT OK,TSP=1
    mysgw: Attempting MQTT connection...
    mysgw: connected to 192.168.178.160
    mysgw: MQTT connected
    mysgw: Sending message on topic: mysensors-out/0/255/0/0/18
    

  • Mod

    You probably compiled it before setting some parameters and with last build they were used. I'm glad you solved it.



  • i'm a simple man, i do what the tutorials says =)
    Thank you very much!


Log in to reply
 

Looks like your connection to MySensors Forum was lost, please wait while we try to reconnect.