new controller with ethernet Gateway on UI7 - unable to enter inclusion mode



  • After moving all my devices from my Vera light UI5 to a Vera Plus with UI7 today I flashed my controller that was working fine on ui5 with the latest mysensors software 2.1.
    I created a MySensor plugin device but seem to be unable to enter inclusion mode. A simple light level node is not included.
    Could you please advise me as to how I could get this going again?
    This is in the log

    ![0_1492806723766_upload-ef244203-7a28-411a-8d39-fb7e4892dea8](/assets/uploads/files/1492806697033-upload-ef244203-7a28-411a-8d39-fb7e4892dea8-resized.png) Insert Code Here
    ```JobHandler_LuaUPnP::HandleActionRequest device: 202 service: urn:upnp-arduino-cc:serviceId:arduino1 action: StartInclusion <0x7057a520>
    JobHandler_LuaUPnP::HandleActionRequest argument DeviceNum=202 <0x7057a520>
    JobHandler_LuaUPnP::HandleActionRequest argument serviceId=urn:upnp-arduino-cc:serviceId:arduino1 <0x7057a520>
    JobHandler_LuaUPnP::HandleActionRequest argument action=StartInclusion <0x7057a520>
    luup_log:202: Arduino: Sending: 0;0;3;0;5;1 <0x77270320>
    <Job ID="19" Name="" Device="202" Created="2017-04-21 22:18:22" Started="2017-04-21 22:18:22" Completed="2017-04-21 22:18:22" Duration="0.1657000" Runtime="0.1329000" Status="Successful" LastNote=""/> <0x77270320>
    IOPort::Run RecvFailed 131 close 23 <0x6fff7520>
    

    Edit:
    I built a completely new gw module (uno with 5100 shield) with a diferent IP address and mac address.
    Changed ip settings in the vera plugin.
    reloaded luup engine.
    No errors in lua startup, but still the same problem with inclusion mode.

    I then did some testing on the gw side.
    The debug output from gw seems to be fine:

    output on startup of the gw:

    0;255;3;0;9;MCO:BGN:INIT GW,CP=RNNGA--,VER=2.1.0
    0;255;3;0;9;TSM:INIT
    0;255;3;0;9;TSF:WUR:MS=0
    0;255;3;0;9;TSM:INIT:TSP OK
    0;255;3;0;9;TSM:INIT:GW MODE
    0;255;3;0;9;TSM:READY:ID=0,PAR=0,DIS=0
    0;255;3;0;9;MCO:REG:NOT NEEDED
    IP: 192.168.2.155
    0;255;3;0;9;MCO:BGN:STP
    0;255;3;0;9;MCO:BGN:INIT OK,TSP=1
    
    

    output when I start inclusion mode from vera ui

    0;255;3;0;9;MCO:BGN:STP
    0;255;3;0;9;MCO:BGN:INIT OK,TSP=1
    0;255;3;0;9;Eth: connect
    0;255;3;0;9;MCO:BGN:INIT GW,CP=RNNGA--,VER=2.1.0
    0;255;3;0;9;TSM:INIT
    0;255;3;0;9;TSF:WUR:MS=0
    0;255;3;0;9;TSM:INIT:TSP OK
    0;255;3;0;9;TSM:INIT:GW MODE
    0;255;3;0;9;TSM:READY:ID=0,PAR=0,DIS=0
    0;255;3;0;9;MCO:REG:NOT NEEDED
    IP: 192.168.2.155
    0;255;3;0;9;MCO:BGN:STP
    0;255;3;0;9;MCO:BGN:INIT OK,TSP=1
    

    output when I stop inclusion from vera ui

    0;255;3;0;9;Eth: connect
    0;255;3;0;9;MCO:BGN:INIT GW,CP=RNNGA--,VER=2.1.0
    0;255;3;0;9;TSM:INIT
    0;255;3;0;9;TSF:WUR:MS=0
    0;255;3;0;9;TSM:INIT:TSP OK
    0;255;3;0;9;TSM:INIT:GW MODE
    0;255;3;0;9;TSM:READY:ID=0,PAR=0,DIS=0
    0;255;3;0;9;MCO:REG:NOT NEEDED
    IP: 192.168.2.155
    0;255;3;0;9;MCO:BGN:STP
    0;255;3;0;9;MCO:BGN:INIT OK,TSP=1
    

    so vera IS communicating with the gw.

    this is the output after starting inclusion mode from vera gui and powering up a new node (measuring light level).

    0;255;3;0;9;MCO:BGN:STP
    0;255;3;0;9;MCO:BGN:INIT OK,TSP=1
    0;255;3;0;9;TSF:MSG:READ,1-1-255,s=255,c=3,t=7,pt=0,l=0,sg=0:
    0;255;3;0;9;TSF:MSG:BC
    0;255;3;0;9;TSF:MSG:FPAR REQ,ID=1
    0;255;3;0;9;TSF:CKU:OK,FCTRL
    0;255;3;0;9;TSF:MSG:GWL OK
    0;255;3;0;9;!TSF:MSG:SEND,0-0-1-1,s=255,c=3,t=8,pt=1,l=1,sg=0,ft=0,st=NACK:0
    0;255;3;0;9;MCO:BGN:INIT GW,CP=RNNGA--,VER=2.1.0
    0;255;3;0;9;TSM:INIT
    0;255;3;0;9;TSF:WUR:MS=0
    0;255;3;0;9;TSM:INIT:TSP OK
    0;255;3;0;9;TSM:INIT:GW MODE
    0;255;3;0;9;TSM:READY:ID=0,PAR=0,DIS=0
    0;255;3;0;9;MCO:REG:NOT NEEDED
    IP: 192.168.2.155
    0;255;3;0;9;MCO:BGN:STP
    0;255;3;0;9;MCO:BGN:INIT OK,TSP=1
    

    So the light level node is also talking to the gw.
    I assume the problem is on the vera/ plugin side.
    The mysensors plugin device on Vera UI7 shows only the plugin version, the line for lib is empty.

    0_1492945271550_mysensors_plugin_ui7.PNG

    Any pointers are highly appreciated!


  • Admin

    Did you enable the inclusion mode feature in the gateway sketch?



  • I think it is enabled by default.

    This is how I compiled it

    // Enable inclusion mode
    #define MY_INCLUSION_MODE_FEATURE
    // Enable Inclusion mode button on gateway
    //#define MY_INCLUSION_BUTTON_FEATURE
    // Set inclusion mode duration (in seconds)
    #define MY_INCLUSION_MODE_DURATION 60
    // Digital pin used for inclusion mode button
    //#define MY_INCLUSION_MODE_BUTTON_PIN  3
    

    So only inclusion by button press on the gw is disabled?



  • I realized there is a new version 2.1.1, I had used 2.1.0
    I flashed both gw and sensor node with the new version.
    Now on vera gui in the Mysensor plugin both plugin version and lib version are shown correctly.
    Debug output from gw shows communication to the node is ok.
    Still, no inclusion mode.


  • Admin

    Sorry I can't help you more. I still run UI5 on my Vera... making the upgrade with all other plugin dependencies is just too fragile (without risking distress in the family) ;)



  • Na, I would't mess with my system either :blush:
    I had mysensors running nicely on ui5, too.
    That changed when Vera Plus moved in.;-)
    Tried building a pi gw, but face the problem. No chance to enter inclusion mode.


  • Hero Member

    @pls90 I have a few Ethernet GWs working on UI7 so I think it should work also for you.

    Maybe you could try rebooting your Vera, then after that also do a few Lua Engine restarts and then finally you do a Ctrl + F5 to get a browser refresh.

    Then try the inclusion again.

    Maybe you could also post your complete GW sketch so I can compare with some of the once I'm using.
    Please also check your Arduino IDE version and AVR Boards Version.


Log in to reply
 

Looks like your connection to MySensors Forum was lost, please wait while we try to reconnect.