SensebenderGatewaySerial Compile errors



  • Hello!

    I'm totally new to this stuff and really exited to explore this more.
    I've have purchased an Sensebender Gateway 1.0 and trying to program the default sketch into it.
    When I try to compile the default example code i'm getting a lot of 'was not declared in this section' errors.

    Running this on Mac OS Sierra 10.12.6

    Steps what I've done.

    1. Install Arduino 1.8.3
    2. Install MySensors 2.1.1 library through the Manage Libraries in Arduino.
    3. Install Arduino SAMD Boards 1.6.15 through Board Manager in Arduino.
    4. Restarted the software
    5. Selected "Arduino/Genuino Zero (Native USB Board)" as Board and the correct COM port.
    6. Opened the default example sketch SensebenderGatewaySerial
    7. Try to compile

    Am I missing something?

    Cheers!

    Errors:

    ensebenderGatewaySerial:93: error: 'LED_BLUE' was not declared in this scope
    static uint8_t leds[] = {LED_BLUE, LED_RED, LED_GREEN, LED_YELLOW, LED_ORANGE};
    ^
    SensebenderGatewaySerial:93: error: 'LED_RED' was not declared in this scope
    static uint8_t leds[] = {LED_BLUE, LED_RED, LED_GREEN, LED_YELLOW, LED_ORANGE};
    ^
    SensebenderGatewaySerial:93: error: 'LED_GREEN' was not declared in this scope
    static uint8_t leds[] = {LED_BLUE, LED_RED, LED_GREEN, LED_YELLOW, LED_ORANGE};
    ^
    SensebenderGatewaySerial:93: error: 'LED_YELLOW' was not declared in this scope
    static uint8_t leds[] = {LED_BLUE, LED_RED, LED_GREEN, LED_YELLOW, LED_ORANGE};
    ^
    SensebenderGatewaySerial:93: error: 'LED_ORANGE' was not declared in this scope
    static uint8_t leds[] = {LED_BLUE, LED_RED, LED_GREEN, LED_YELLOW, LED_ORANGE};
    ^
    /Users/rayzilt/Documents/Arduino/SensebenderGatewaySerial/SensebenderGatewaySerial.ino: In function 'void preHwInit()':
    SensebenderGatewaySerial:114: error: 'MY_SWC1' was not declared in this scope
    pinMode(MY_SWC1, INPUT_PULLUP);
    ^
    SensebenderGatewaySerial:115: error: 'MY_SWC2' was not declared in this scope
    pinMode(MY_SWC2, INPUT_PULLUP);
    ^
    SensebenderGatewaySerial:128: error: 'LED_BLUE' was not declared in this scope
    digitalWrite(LED_BLUE, led_state);
    ^
    SensebenderGatewaySerial:133: error: 'LED_BLUE' was not declared in this scope
    digitalWrite(LED_BLUE, LOW);
    ^
    SensebenderGatewaySerial:144: error: 'LED_GREEN' was not declared in this scope
    digitalWrite(LED_GREEN, HIGH);
    ^
    SensebenderGatewaySerial:148: error: 'LED_YELLOW' was not declared in this scope
    digitalWrite(LED_YELLOW, HIGH);
    ^
    SensebenderGatewaySerial:153: error: 'LED_ORANGE' was not declared in this scope
    digitalWrite(LED_ORANGE, HIGH);
    ^
    SensebenderGatewaySerial:170: error: 'LED_RED' was not declared in this scope
    digitalWrite(LED_RED, HIGH);
    ^
    /Users/rayzilt/Documents/Arduino/SensebenderGatewaySerial/SensebenderGatewaySerial.ino: In function 'bool testSDCard()':
    SensebenderGatewaySerial:222: error: 'MY_SDCARD_CS' was not declared in this scope
    if (!card.init(SPI_HALF_SPEED, MY_SDCARD_CS)) {
    ^
    /Users/rayzilt/Documents/Arduino/SensebenderGatewaySerial/SensebenderGatewaySerial.ino: In function 'bool testAnalog()':
    SensebenderGatewaySerial:271: error: 'MY_BAT_DETECT' was not declared in this scope
    int bat_detect = analogRead(MY_BAT_DETECT);
    ^
    exit status 1
    'LED_BLUE' was not declared in this scope


  • Admin

    @Rayzilt

    Have you installed board support package for the gateway?

    https://github.com/mysensors/ArduinoBoards

    Then choose the Sensebender Gateway as target



  • No sir! Exactly what I was missing!

    Thank you for the information


Log in to reply
 

Looks like your connection to MySensors Forum was lost, please wait while we try to reconnect.