Flashed mysensors dev branch to my sensors - not showing up in home assistant



  • Hi,

    I wounding how I can do static configuration in home assistant?



  • If possible I would avoid to rip all apart and refash...


  • Mod

    What exactly did you do? And what is your current setup?



  • I'm trying both the raspi mqtt and the esp8266 mqtt gateway. I have flashed the dev 2.1.1 branch towards a set of arduino pro mini led light, communication seems to work - I can see the sensors publishing towards mqtt.

    My config in configuration.yaml:

    ...
    mysensors:
    gateways:
    - device: mqtt
    persistence_file: '/home/homeassistant/.homeassistant/mysensors.json'
    topic_in_prefix: 'mysensors-out'
    topic_out_prefix: 'mysensors-in'
    optimistic: false
    persistence: true
    retain: true
    version: '2.0'
    ...

    When I switch on the lights, I see messages appear on the mqtt:

    mysensors-out/1/255/0/0/17 2.2.0-beta
    mysensors-out/1/255/3/0/6 0
    mysensors-in/1/255/3/0/6 M
    mysensors-out/1/255/3/0/11 WallLight1
    mysensors-out/1/255/3/0/12 1.0
    mysensors-out/1/1/0/0/4 (null)
    mysensors-out/1/1/1/0/3 100
    mysensors-out/6/255/0/0/17 2.2.0-beta
    mysensors-out/6/255/3/0/6 0
    mysensors-out/5/255/0/0/17 2.2.0-beta
    mysensors-out/5/255/3/0/6 0
    mysensors-in/6/255/3/0/6 M
    mysensors-in/5/255/3/0/6 M
    mysensors-out/6/255/3/0/11 WallLight6
    mysensors-out/6/255/3/0/12 1.0
    mysensors-out/6/1/0/0/4 (null)
    mysensors-out/5/255/3/0/12 1.0
    mysensors-out/5/1/0/0/4 (null)
    mysensors-out/5/1/1/0/3 100
    mysensors-out/6/255/0/0/17 2.2.0-beta
    mysensors-out/5/1/1/0/3 100
    mysensors-out/6/1/1/0/3 100
    mysensors-out/6/1/1/0/3 100
    mysensors-out/3/255/3/0/6 0
    mysensors-in/3/255/3/0/6 M
    mysensors-out/3/1/0/0/4 (null)
    mysensors-out/3/1/1/0/3 100
    mysensors-out/3/255/3/0/6 0
    mysensors-in/3/255/3/0/6 M
    mysensors-out/3/255/3/0/11 WallLight3
    mysensors-out/3/255/3/0/12 1.0
    mysensors-out/4/255/0/0/17 2.2.0-beta
    mysensors-out/4/255/3/0/6 0
    mysensors-in/4/255/3/0/6 M
    mysensors-out/4/1/0/0/4 (null)
    mysensors-out/4/1/1/0/3 100
    mysensors-out/4/255/0/0/17 2.2.0-beta
    mysensors-out/4/255/3/0/6 0
    mysensors-in/4/255/3/0/6 M
    mysensors-out/4/255/3/0/11 WallLight4
    mysensors-out/4/255/3/0/12 1.0

    However - they do not show up ... home assistant log shows like this...💯

    Jan 22 18:03:57 pi hass[744]: 2018-01-22 18:03:57 DEBUG (Thread-6) [mysensors.gateway_mqtt] Receiving 4;255;3;0;27;WallLight4
    Jan 22 18:03:57 pi hass[744]: 2018-01-22 18:03:57 DEBUG (Thread-13) [homeassistant.components.mysensors] Node update: node 4 child 255
    Jan 22 18:03:57 pi hass[744]: 2018-01-22 18:03:57 DEBUG (Thread-13) [homeassistant.components.mysensors] Not a child update for node 4
    Jan 22 18:03:58 pi hass[744]: 2018-01-22 18:03:58 DEBUG (Thread-4) [mysensors.gateway_mqtt] Receiving 4;255;3;0;11;WallLight4
    Jan 22 18:03:58 pi hass[744]: 2018-01-22 18:03:58 DEBUG (Thread-13) [homeassistant.components.mysensors] Node update: node 4 child 255
    Jan 22 18:03:58 pi hass[744]: 2018-01-22 18:03:58 DEBUG (Thread-13) [homeassistant.components.mysensors] Not a child update for node 4
    Jan 22 18:03:58 pi hass[744]: 2018-01-22 18:03:58 DEBUG (Thread-9) [mysensors.gateway_mqtt] Receiving 1;1;1;0;3;100
    Jan 22 18:03:58 pi hass[744]: 2018-01-22 18:03:58 DEBUG (Thread-13) [homeassistant.components.mysensors] Node update: node 1 child 1
    Jan 22 18:03:58 pi hass[744]: 2018-01-22 18:03:58 WARNING (Thread-13) [homeassistant.components.mysensors] Invalid values: {19: '356', 3: '100'}: light platform: node 1 child 1: S_DIMMER requires value_type V_STATUS @ data[2]
    Jan 22 18:03:59 pi hass[744]: 2018-01-22 18:03:59 DEBUG (Thread-7) [mysensors.gateway_mqtt] Receiving 1;1;1;0;3;100
    Jan 22 18:03:59 pi hass[744]: 2018-01-22 18:03:59 DEBUG (Thread-13) [homeassistant.components.mysensors] Node update: node 1 child 1
    Jan 22 18:03:59 pi hass[744]: 2018-01-22 18:03:59 WARNING (Thread-13) [homeassistant.components.mysensors] Invalid values: {19: '356', 3: '100'}: light platform: node 1 child 1: S_DIMMER requires value_type V_STATUS @ data[2]
    Jan 22 18:04:00 pi hass[744]: 2018-01-22 18:04:00 DEBUG (Thread-10) [mysensors.gateway_mqtt] Receiving 4;1;1;0;3;100
    Jan 22 18:04:00 pi hass[744]: 2018-01-22 18:04:00 DEBUG (Thread-13) [homeassistant.components.mysensors] Node update: node 4 child 1
    Jan 22 18:04:00 pi hass[744]: 2018-01-22 18:04:00 WARNING (Thread-13) [homeassistant.components.mysensors] Invalid values: {3: '100'}: light platform: node 4 child 1: S_DIMMER requires value_type V_STATUS @ data[2]
    Jan 22 18:04:00 pi hass[744]: 2018-01-22 18:04:00 DEBUG (Thread-8) [mysensors.gateway_mqtt] Receiving 4;1;1;0;3;100
    Jan 22 18:04:00 pi hass[744]: 2018-01-22 18:04:00 DEBUG (Thread-13) [homeassistant.components.mysensors] Node update: node 4 child 1
    Jan 22 18:04:00 pi hass[744]: 2018-01-22 18:04:00 WARNING (Thread-13) [homeassistant.components.mysensors] Invalid values: {3: '100'}: light platform: node 4 child 1: S_DIMMER requires value_type V_STATUS @ data[2]
    Jan 22 18:04:00 pi hass[744]: 2018-01-22 18:04:00 DEBUG (Thread-5) [mysensors.gateway_mqtt] Receiving 4;1;1;0;3;100
    Jan 22 18:04:00 pi hass[744]: 2018-01-22 18:04:00 DEBUG (Thread-13) [homeassistant.components.mysensors] Node update: node 4 child 1
    Jan 22 18:04:00 pi hass[744]: 2018-01-22 18:04:00 WARNING (Thread-13) [homeassistant.components.mysensors] Invalid values: {3: '100'}: light platform: node 4 child 1: S_DIMMER requires value_type V_STATUS @ data[2]
    Jan 22 18:04:03 pi hass[744]: 2018-01-22 18:04:03 INFO (MainThread) [homeassistant.components.http] Serving /description.xml to 192.168.10.211 (auth: True)
    Jan 22 18:04:04 pi hass[744]: 2018-01-22 18:04:04 DEBUG (Thread-11) [mysensors.gateway_mqtt] Receiving 6;255;0;0;17;2.2.0-beta
    Jan 22 18:04:04 pi hass[744]: 2018-01-22 18:04:04 DEBUG (Thread-3) [mysensors.gateway_mqtt] Receiving 6;255;3;0;6;0
    Jan 22 18:04:04 pi hass[744]: 2018-01-22 18:04:04 DEBUG (Thread-13) [mysensors.gateway_mqtt] Publishing 6;255;3;0;6;M
    Jan 22 18:04:04 pi hass[744]:
    Jan 22 18:04:04 pi hass[744]: 2018-01-22 18:04:04 INFO (MainThread) [homeassistant.core] Bus:Handling <Event call_service[L]: service_call_id=1972866000-41, domain=mqtt, service=publish, service_data=payload=M, topic=mysensors-in/6/255/3/0/6, qos=0, retain=True>
    Jan 22 18:04:04 pi hass[744]: 2018-01-22 18:04:04 INFO (MainThread) [homeassistant.core] Bus:Handling <Event service_executed[L]: service_call_id=1972866000-41>
    Jan 22 18:04:04 pi hass[744]: 2018-01-22 18:04:04 DEBUG (Thread-9) [mysensors.gateway_mqtt] Receiving 6;255;3;0;11;WallLight6
    Jan 22 18:04:04 pi hass[744]: 2018-01-22 18:04:04 DEBUG (Thread-2) [mysensors.gateway_mqtt] Receiving 6;255;3;0;12;1.0
    Jan 22 18:04:04 pi hass[744]: 2018-01-22 18:04:04 DEBUG (Thread-4) [mysensors.gateway_mqtt] Receiving 6;1;0;0;4;
    Jan 22 18:04:04 pi hass[744]: 2018-01-22 18:04:04 DEBUG (Thread-7) [mysensors.gateway_mqtt] Receiving 6;1;1;0;3;100
    Jan 22 18:04:04 pi hass[744]: 2018-01-22 18:04:04 DEBUG (Thread-13) [homeassistant.components.mysensors] Node update: node 6 child 255
    Jan 22 18:04:04 pi hass[744]: 2018-01-22 18:04:04 DEBUG (Thread-13) [homeassistant.components.mysensors] Not a child update for node 6
    Jan 22 18:04:04 pi hass[744]: 2018-01-22 18:04:04 DEBUG (Thread-13) [homeassistant.components.mysensors] Node update: node 6 child 255
    Jan 22 18:04:04 pi hass[744]: 2018-01-22 18:04:04 DEBUG (Thread-13) [homeassistant.components.mysensors] Not a child update for node 6
    Jan 22 18:04:04 pi hass[744]: 2018-01-22 18:04:04 WARNING (Thread-13) [mysensors] child_id 1 already exists in children of node 6, cannot add child
    Jan 22 18:04:04 pi hass[744]: 2018-01-22 18:04:04 DEBUG (Thread-13) [homeassistant.components.mysensors] Node update: node 6 child 1
    Jan 22 18:04:04 pi hass[744]: 2018-01-22 18:04:04 WARNING (Thread-13) [homeassistant.components.mysensors] Invalid values: {3: '100'}: light platform: node 6 child 1: S_DIMMER requires value_type V_STATUS @ data[2]
    Jan 22 18:04:04 pi hass[744]: 2018-01-22 18:04:04 DEBUG (Thread-10) [mysensors.gateway_mqtt] Receiving 6;255;0;0;17;2.2.0-beta
    Jan 22 18:04:04 pi hass[744]: 2018-01-22 18:04:04 DEBUG (Thread-8) [mysensors.gateway_mqtt] Receiving 6;255;3;0;6;0
    Jan 22 18:04:04 pi hass[744]: 2018-01-22 18:04:04 DEBUG (Thread-13) [mysensors.gateway_mqtt] Publishing 6;255;3;0;6;M
    Jan 22 18:04:04 pi hass[744]:
    Jan 22 18:04:04 pi hass[744]: 2018-01-22 18:04:04 INFO (MainThread) [homeassistant.core] Bus:Handling <Event call_service[L]: service_call_id=1972866000-42, domain=mqtt, service=publish, service_data=payload=M, topic=mysensors-in/6/255/3/0/6, qos=0, retain=True>
    Jan 22 18:04:04 pi hass[744]: 2018-01-22 18:04:04 INFO (MainThread) [homeassistant.core] Bus:Handling <Event service_executed[L]: service_call_id=1972866000-42>
    Jan 22 18:04:05 pi hass[744]: 2018-01-22 18:04:05 INFO (MainThread) [homeassistant.components.http] Serving /api/camera_proxy/camera.balcony to 192.168.10.6 (auth: True)
    Jan 22 18:04:05 pi hass[744]: 2018-01-22 18:04:05 INFO (MainThread) [homeassistant.components.http] Serving /api/camera_proxy/camera.cellar to 192.168.10.6 (auth: True)
    Jan 22 18:04:12 pi hass[744]: 2018-01-22 18:04:12 INFO (MainThread) [homeassistant.components.http] Serving /description.xml to 192.168.10.211 (auth: True)
    Jan 22 18:04:15 pi hass[744]: 2018-01-22 18:04:15 INFO (MainThread) [homeassistant.components.http] Serving /api/camera_proxy/camera.balcony to 192.168.10.6 (auth: True)
    Jan 22 18:04:15 pi hass[744]: 2018-01-22 18:04:15 INFO (MainThread) [homeassistant.components.http] Serving /api/camera_proxy/camera.cellar to 192.168.10.6 (auth: True)



  • WARNING (Thread-13) [homeassistant.components.mysensors] Invalid values: {3: '100'}: light platform: node 6 child 1: S_DIMMER requires value_type V_STATUS @ data[2]

    That one seems wrong - but if possible I simply want to switch on / off the lights, no dimmer needed if I can avoid flashing the sensors again.


  • Mod

    What code did you flash on the node? BTW, are you sure you used the development version? You wrote version 2.1.1 while it should be 2.2



  • Correct - I flashed it some time ago - actually I detect 1 min. ago if I remove some parts of the config ...

    customize:

    light.WallLight1_1_1:

    friendly_name: WallLight 1

    light.WallLight6_6_1:

    friendly_name: WallLight 2

    light.WallLight3_3_1:

    friendly_name: WallLight 3

    light.WallLight4_4_1:

    friendly_name: WallLight 4

    light.WallLight5_5_1:

    friendly_name: WallLight 5

    group.Wall_Lights:

    friendly_name: Wandleuchten

    the light appear ... I think I can get it working.


  • Plugin Developer

    A child device represented by S_DIMMER requires both V_PERCENTAGE and V_STATUS in home assistant. This is mentioned here:
    https://home-assistant.io/components/light.mysensors/

    So you need to send initial values of both V_PERCENTAGE and V_STATUS, and update those value types when state changes, to have an operating device.

    If you only need on/off you should present a S_BINARY child device with V_STATUS value type. This will be a switch in home assistant:
    https://home-assistant.io/components/switch.mysensors/



  • Thanks. I will do that...


 

378
Online

7.7k
Users

8.6k
Topics

92.3k
Posts