mysdb not finding node_sqlite3.node



  • Here is what I'm getting when I start node-red:

    
    Start Node-RED
    
    Once Node-RED has started, point a browser at http://192.168.1.168:1880
    On Pi Node-RED works better with the Firefox or Chrome browser
    
    Use   node-red-stop                          to stop Node-RED
    Use   node-red-start                         to start Node-RED again
    Use   node-red-log                           to view the recent log output
    Use   sudo systemctl enable nodered.service  to autostart Node-RED at every boot
    Use   sudo systemctl disable nodered.service to disable autostart on boot
    
    To find more nodes and example flows - go to http://flows.nodered.org
    
    Starting as a systemd service.
    Started Node-RED graphical event wiring tool.
    25 Jun 01:15:56 - [info]
    Welcome to Node-RED
    ===================
    25 Jun 01:15:56 - [info] Node-RED version: v0.18.7
    25 Jun 01:15:56 - [info] Node.js  version: v8.11.3
    25 Jun 01:15:56 - [info] Linux 4.14.50-v7+ arm LE
    25 Jun 01:15:57 - [info] Loading palette nodes
    25 Jun 01:16:03 - [info] Dashboard version 2.9.4 started at /ui
    25 Jun 01:16:06 - [warn] ------------------------------------------------------
    25 Jun 01:16:06 - [warn] [node-red-contrib-mysensors/mysdb] Error: Cannot find module '/home/pi/.node-red/node_modules/sqlite/node_modules/sqlite3/lib/binding/node-v57-linux-arm/node_sqlite3.node'
    25 Jun 01:16:06 - [warn] ------------------------------------------------------
    25 Jun 01:16:06 - [info] Settings file  : /home/pi/.node-red/settings.js
    25 Jun 01:16:06 - [info] User directory : /home/pi/.node-red
    25 Jun 01:16:06 - [warn] Projects disabled : editorTheme.projects.enabled=false
    25 Jun 01:16:06 - [info] Flows file     : /home/pi/.node-red/flows_HS-HomeAuto.json
    25 Jun 01:16:06 - [info] Server now running at http://127.0.0.1:1880/
    25 Jun 01:16:06 - [info] Starting flows
    25 Jun 01:16:06 - [info] Started flows
    25 Jun 01:16:06 - [info] [sqlitedb:d9370fe2.50bc5] opened /home/pi/dbFiles/ByronWorld.db ok
    

    If I was to guess it is not finding the sqlite database file. If this is the case I already had sqlite installed before I added node-red-contrib-mysensors, and have a folder I have an other database file in. Can I configure this to have the db files in the same directory?

    If I'm completely off on what I think is going on here, and somebody can guide me on getting this resolved, I would be great-full.

    Thanks Glenn


  • Admin

    @gbfromhb
    How did you install the mysensors nodered nodes? It seems that something might went wrong, and some dependencies is missing



  • @tbowmo thanks for the quick response. I had started with Raspian Stretch.
    To install node-red I used the following:

    bash <(curl -sL https://raw.githubusercontent.com/node-red/raspbian-deb-package/master/resources/update-nodejs-and-nodered)
    

    I then installed sqlite3, and phliteadmin, and finally mySensors.

    I just started over, and skipped the whole sqlite3 and phpliteAdmin, and it seems to be working great, thanks again for the response.



  • Hi. I'm having the same problem getting these extensions to install on my (original) Pi. Going back to a fresh version of stretch, then reinstalling the node-red extensions didn't help.

    It appears to be failing on sqlite3, which I can't add myself via npm either - as there are no pre-built binaries for sqlite3 (4.0.1) or node (8.11.3). Letting it build it itself with node-gyp (the standard fallback) just hangs. Grateful for any thoughts?


  • Admin

    @David-Barber

    Did you use npm to install the mysensors nodes in node-red? Or the node-red UI?

    I have experienced that you need to use the cli to install it, or else node-gyp is not working..

    I'm running my setup on an atom based machine, so running standard amd64 kernel, so haven't tried on a rPi.



  • Thanks @tbowmo. I used the cli. It seems to be a common problem with sqlite3 and the Pi, although the solutions elsewhere haven't worked for me yet. I'm using an old Pi as that is what I have lying around... Basically, the node-gyp is starting to build but then just hangs. I guess it could be a memory issue on my old pi...


  • Admin

    @David-Barber

    Could be an issue with low memory, is it a 256Mb or a 512Mb r-pi?



  • @tbowmo Just 256MB I was going to get a Pi3 anyway for something else, so I 'll see if that makes a difference. Thanks.

    Shame it was nice to use something just sitting around.



  • Just to update this thread. It worked on a pi3 so I assume it was a memory issue. All running as expected now.


  • Admin

    @david-barber

    Thanks for the update. I'll add a note to the documentation, about minimum requirements.


 

437
Online

7.9k
Users

8.8k
Topics

94.3k
Posts