help with serial gateway on raspberry pi



  • hi guys i just make a new controller with a raspberry pi and domoticz , now im trying to add the serial gateway to my domoticz , but in order to domoticz to open the port i need to open ssh connection and use

    sudo ./bin/mysgw
    
    

    for domoticz to read the port /dev/ttyUSB020 , if i dont use ./bin/mysgw the log just said
    2019-04-21 04:31:58.747 Status: MySensors: Using serial port: /dev/ttyUSB020
    2019-04-21 04:31:58.747 Error: MySensors: Error opening serial port!
    , what im missing here

    just do the standar installaton

    ./configure --my-gateway=serial --my-serial-is-pty --my-serial-pty=/dev/ttyMySensorsGateway
    make 
    sudo make install 
    sudo systemctl enable mysgw.service
    sudo ln -s /dev/ttyMySensorsGateway /dev/ttyUSB020
    

    i dont know what im missing here, thanks for the help



  • @fernando-alvarez-buylla
    I think you only need define your gateway in Domoticz.
    That Is all.
    0_1555825942664_Screenshot_2019-04-21-07-48-41-311_com.android.chrome.png


  • Mod

    @fernando-alvarez-buylla the link (created with the ln command) will be removed at reboot. Change my-serial-pty=/dev/ttyMySensorsGateway to my-serial-pty=/dev/ttyUSB020 and re-run all the commands.

    If you don't reboot the pi after enabling the mysgw service, you will need to start the gateway as per the instructions printed when make is finished.



  • thanks guys , the solution for me was to add

    ln -s /dev/ttyMySensorsGateway /dev/ttyUSB020
    

    to rc.local

    but i will try your idea @mfalkvidd thanks for the help


 

191
Online

8.7k
Users

9.5k
Topics

99.9k
Posts