Raspberry Pi gateway + hass.io + MQTT + MySensors



  • So I successfully installed hass.io and enabled MQTT on my raspberry Pi 3+ (64) but now I am struggling to get a gateway running on the raspberry while I have read on multiple places that it should be possible, acting as a gateway and controller. Overall I am a bit lost in which step is next. Should I enable MySensor in hass.io or ensure that the Raspberry Pi becomes a gateway first? Or is this exactly the same thing.

    I need some guidance in getting to the next step, any advise is welcome.

    For context:
    My first step is to create a sensor that measures humidity and temp. connected to an arduino which sends the data via NRF24L01 to my Raspberry.



  • To use RPi as a gateway you need install Home Assistant on a Raspbian install and compile a Mysensors binary on it. Hass.io won't work with this scenario. I suggest you follow the docker install guide.



  • Thanks @monte, I'm gonna try that first



  • @monte does docker allow complete functionality of hass.io? Here it's mentioned that docker will limit functionality, is that correct? For clarification, how would docker relate to a manual installation of hass.io



  • @sebex well, it appears that you can install hass.io manually on your raspbian installation via this script
    Also you can install plain Home Assistant docker image if you don't need any addons and additional functionality of hassio. That's the way I went.
    You need to understand that either way you can achieve the same things but a little different ways.
    The main point is that you need Raspbian setup in the first place if you want to use the same RPi as a gateway. You can't compile Mysensors gateway on a hassio image.



  • Unless there has been a recent change I’m unaware of - I don’t think you can have RPi function as gateway when it is running Hass.IO (via HassOS). There is not a way to load and run the mysensors executable.

    I’d suggest building a serial gateway with a nano (with NRF radio connected to nano). If you connect that via USB to your Pi, you should be able to use the homeassistant config for serial gateways to get everything working.



  • I think that you have concept problem. First I don't think that raspbian install have any sense at this stage. There's so much more you can do with hassos ( docker). And second why you doesn't connect gateway via USB an use serial connection. I use Arduino mega directly via USB and it is very stable. You have to add in configuration mysensors with path to USB (I recommend serial number identification).



  • @michał-szura here and there I do read the possibility of a Pi acting as a gateway and controller. But you mention that it is not possible whatsoever? Why not?

    @Dave-Myers I agree that it is not possible via HassOS, but it should be possible when run via a virtual enivroment as monte suggested.

    @monte hassio now shows up in docker as a container. But I am struggling to run it, what's the command to run hassio_supervisor? attach hassio_supervisor causes it to become unresponsive.



  • In this case I have question why? I Know that why not and because I can is good enough answer but...
    You can have best from home assistant (install Hass os) and mysensors (make gateway on separate Arduino). And this way when you want to upgrade to something more than RPi you can do it with minimal damage ( I did it this way and it was quite nice upgrade). But this is only myn2 cents



  • @michał-szura some may say that one integrated device is better than two. Also you can restart and debug mysensors gateway via ssh, try to achieve this with arduino. Anyway, even after you decide to move your controller installation to lets say dedicated server, NUC or VM you can still use your RPi as a network gateway without rebuilding anything.

    @Sebex what exactly did you do? Did you use install script, or followed some guide on mentioned forum thread.
    To see if supervisor is running execute sudo systemctl status hassio-supervisor.service
    Also you can use sudo docker ps command to list running docker containers, sudo docker ps -a will show every container even if it is stopped.



  • @monte said in Raspberry Pi gateway + hass.io + MQTT + MySensors:

    @Sebex what exactly did you do? Did you use install script, or followed some guide on mentioned forum thread.
    To see if supervisor is running execute sudo systemctl status hassio-supervisor.service
    Also you can use sudo docker ps command to list running docker containers, sudo docker ps -a will show every container even if it is stopped.

    I followed your github link, and used the cmd below to instal hassio.

    curl -sL https://raw.githubusercontent.com/home-assistant/hassio-installer/master/hassio_install.sh | bash -s -- -m MY_MACHINE
    

    When I run your suggested status cmd I indeed see that hassio is running:

    Dec 29 23:18:24 banana hassio-supervisor[1046]: 19-12-29 22:18:24 INFO (MainThread) [__main__] Run Hass.io
    Dec 29 23:18:24 banana hassio-supervisor[1046]: 19-12-29 22:18:24 INFO (MainThread) [hassio.api] Start API on 172.30.32.2
    Dec 29 23:18:24 banana hassio-supervisor[1046]: 19-12-29 22:18:24 INFO (MainThread) [hassio.addons] Phase 'initialize' start 0 add-ons
    Dec 29 23:18:24 banana hassio-supervisor[1046]: 19-12-29 22:18:24 INFO (MainThread) [hassio.addons] Phase 'system' start 0 add-ons
    Dec 29 23:18:24 banana hassio-supervisor[1046]: 19-12-29 22:18:24 INFO (MainThread) [hassio.addons] Phase 'services' start 0 add-ons
    Dec 29 23:18:24 banana hassio-supervisor[1046]: 19-12-29 22:18:24 INFO (SyncWorker_1) [hassio.docker.interface] Start homeassistant/raspberrypi3-64-homeassistant
    Dec 29 23:18:33 banana hassio-supervisor[1046]: 19-12-29 22:18:33 ERROR (MainThread) [hassio.homeassistant] Home Assistant has crashed!
    Dec 29 23:18:33 banana hassio-supervisor[1046]: 19-12-29 22:18:33 INFO (MainThread) [hassio.addons] Phase 'application' start 0 add-ons
    Dec 29 23:18:33 banana hassio-supervisor[1046]: 19-12-29 22:18:33 INFO (MainThread) [hassio.tasks] All core tasks are scheduled
    Dec 29 23:18:33 banana hassio-supervisor[1046]: 19-12-29 22:18:33 INFO (MainThread) [hassio.core] Hass.io is up and running
    

    But I tried accessing hassio multiple times via <raspberrypi local ipadres>:8123, which is unresponsive. Any suggestions? The Pi is connected via wifi, ip adres is not yet static but doubt that this is the cause.

    -- update

    Now that I am looking into it again after setting Pi's IP to static, the bottom 4th line shows an error. Home assistant has crashed. So something is going wrong...



  • @sebex well, that indicates that homeassistant docker container has crashed for some reason. That's why you can not access it via web.
    I assume you tried to restart RPi? No changes?
    Try sudo docker start homeassistant and sudo docker ps -a after this to see if it crashed or not.
    It will print something like this:

    CONTAINER ID   NAMES                      IMAGE                                            COMMAND                  CREATED             STATUS                  
    b8d101b1b04d   addon_core_configurator    homeassistant/amd64-addon-configurator:4.2       "/run.sh"                13 hours ago        Up 13 hours
    ee63787039a5   hassio_dns                 homeassistant/amd64-hassio-dns:1                 "coredns -conf /conf…"   14 hours ago        Up 14 hours
    18c68d86c0ae   homeassistant              homeassistant/qemux86-64-homeassistant:0.103.5   "/bin/entry.sh pytho…"   14 hours ago        Up 14 hours
    24f80b84279d   hassio_supervisor          homeassistant/amd64-hassio-supervisor            "/bin/entry.sh pytho…"   14 hours ago        Up 14 hours
    

    Status will show the status of the container. You can read the logs to see why it is crashing with command sudo docker logs homeassistant.
    Yesterday after I wrote a reply I tried that install script on my server and it just worked. I hope we will find problem with your setup 🙂



  • @monte yes tried rebooting it several times and also reinstalled but no changes so far, it still crashes.

    I tried your commands, after sudo docker start homeassistant it immediately crashes according to the logs below.

    CONTAINER ID        IMAGE                                                 COMMAND                  CREATED             STATUS                     PORTS               NAMES
    0b0ffff70832        homeassistant/armv7-hassio-dns:1                      "coredns -conf /conf…"   5 minutes ago       Up 5 minutes                                   hassio_dns
    3b83e6f9db07        homeassistant/raspberrypi3-64-homeassistant:0.103.5   "/bin/entry.sh pytho…"   2 hours ago         Exited (1) 2 seconds ago                       homeassistant
    9fd90364c61f        homeassistant/armv7-hassio-supervisor  
    
    sudo docker logs homeassistant
    [FATAL tini (6)] exec /bin/entry.sh failed: Exec format error
    [FATAL tini (6)] exec /bin/entry.sh failed: Exec format error
    

    Thanks for the help so far @monte hope we can fix it 😄



  • @sebex okay, that seems that for some reason script pulled out wrong HA container, I mean for wrong architecture. At least [FATAL tini (6)] exec /bin/entry.sh failed: Exec format error indicates that.
    What is your RPi version?
    You can try running the script without -m MY_MACHINE argument. It should autodetect the architecture and pull correct docker image.
    What does uname -m show?



  • @monte yea it made me wonder as well whether I should have selected the rpi 3 64bit version for docker image.
    I have a Raspberry pi 3 b+ (so 64bit).
    uname -m shows armv7l, when googling I got the answer that this can also be due to that Raspbian is running in 32 mode?

    I tried running the script without -m MY_MACHINE returns an error for setting the machine.

    root@banana:/home/pi# sudo curl -sL https://raw.githubusercontent.com/home-assistant/hassio-installer/master/hassio_install.sh | bash -s
    ModemManager.service enabled
    [Warning] ModemManager service is enabled. This might cause issue when using serial devices.
    [ERROR] Please set machine for armv7l
    

    I've just completely reflashed my Pi and used a different microsd card (couldn't format the original one anymore). Reinstalled raspbian, docker and hass.io. For the latter I selected raspberrpi3 (instead of rpi3-64). After accessing localip:8123 it seems that hass.io is accessible 😄 It's currently preparing so looking good!!



  • Ok so homeassistant is running and not crashing 🙂 Now building the gateway, @monte to eventually communicate with hass.io do I need to select the gateway as --my-gateway=ethernet or mqtt?



  • @sebex you can chose either. I prefer ethernet, so you don't rely on another piece of software - MQTT broker, no additional setup is required.
    Read this docs especially the "Presentation" paragraph. At first I had trouble registering my nodes in HA, because it require particular way of presentation. "Send at least one initial value per V_TYPE. In version 2.x of MySensors, this has to be done in the loop function."



  • @monte ok thanks, will take it into account.
    Out of curiousity, since MQTT takes additional setup what''s the benefit of using MQTT? Do you know?



  • @sebex I guess if you already have other mqtt services or devices in your system, or want to use a controller that is designed specifically around mqtt, nodered for example, or the one that doesn't have support for Mysensors specifically.
    Also you could use Mysensors with remote mqtt server, your own, or third party. I tried this once, when I needed one sensor exposed to internet without dedicated server hardware at place, so I've built an esp8266 gateway with mqtt connected to free online mqtt broker. The nodered controller was also hosted on a free cloud 🙂
    Not that it was particularly useful, or I would recommend it to someone, but it's a flexibility Mysensors has, and I guess it's the main reason so many people are using it for their projects.



  • @monte ok it seems to work. Temp/humidity sensor is recognised by HA and data is getting through so looks good! Only connection isnt stable which is most likely due to that I still need to get capacitors for the NRF24L01+ on both ends, and need to solder the cables to the sensor. So still some tweaks to do but happy that it works, thanks for the support @monte 😀

    Two general questions, any advice for which capacitor to select? Apart from 4.7 or 47uF, there's different types. Tanto, elco, bipolaire etc.
    Furthermore I wondered why the 64bit hassio software didn't work on my Arduino, while it is a 64bit RPi 3+. Does Raspbian (or dockers?) as default run in 32?



  • @sebex 4.7uF should be enough, I've never seen any problem with this value on my nodes. As for the type of the capacitor you probably will want to use ceramic or electrolytic (polarized) capacitor, but it doesn't do much difference for this application, if any. Those are just the most common types. Ceramic SMD capacitor of a size 0805 is the best choice IMO because it could be soldered directly to the VCC and GND pins on top of NRF24 module.
    You can google about why raspbian is running like RPi is 32 bits, but as I understood it's better for downward compatibility and the fact that RPi3 won't get much boost (if any) from switching to 64 bit architecture.



  • @monte ah smart makes sense and probably looks most neat as well. Thanks!



  • Ok so I am experiencing node loss. After a while my sensor node is not recognized anymore by the gateway/mothernode. It seems to be related to the persistence file that is not accessible although the user account should have the correct rights, not sure how to verify. See HA dev logs below.

    Developer Tools
    Permission denied when writing to /config/home/pi/.homeassistant/mysensors.json
    10:13 PM /usr/local/lib/python3.7/site-packages/mysensors/persistence.py (ERROR) - message first occurred at 10:06 PM and shows up 42 times
    Node 1 is unknown
    10:11 PM __main__.py (WARNING) - message first occurred at 10:06 PM and shows up 116 times
    Failed to load sensors from file: home/pi/.homeassistant/mysensors.json
    10:06 PM /usr/local/lib/python3.7/site-packages/mysensors/persistence.py (WARNING)
    File does not exist or is not readable: home/pi/.homeassistant/mysensors.json.bak
    10:06 PM /usr/local/lib/python3.7/site-packages/mysensors/persistence.py (WARNING)
    Trying backup file: home/pi/.homeassistant/mysensors.json.bak
    10:06 PM /usr/local/lib/python3.7/site-packages/mysensors/persistence.py (WARNING)
    File does not exist or is not readable: home/pi/.homeassistant/mysensors.json
    10:06 PM /usr/local/lib/python3.7/site-packages/mysensors/persistence.py (WARNING)```
    
    
    # MySensors gateway
    mysensors:
     gateways: 
      - device: '192.168.178.27'
        persistence_file: 'home/pi/.homeassistant/mysensors.json'
        tcp_port: 5003
     persistence: true  
    
    logger:
      default: info
      logs:
        homeassistant.components.mysensors: debug
        mysensors: debug
    

    @drock1985 saw your post in another thread related to this, do you have a suggestion?



  • @Sebex you are using Hassio, so there is no /home/pi folder. Try persistence_file: 'mysensors.json'



  • @monte seems to do the trick 😁 thanks again!!



  • @monte, I'm seeing that a HA update is available. Since I'm using HA via docker the following applies to update.
    $ sudo docker pull homeassistant/home-assistant:latest
    To be on the safe side I'd like to backup my HA and/or RPi first to prevent me from losing all my settings. In your experience what's the most convenient for doing this. I did make a clone from the sd card a few weeks ago but it's not the most labour efficient method, do you make regular backups?



  • @Sebex if you installed Hassio with provided script then you can find your Home Assistant config folder in /usr/share/hassio. You can also change this path to your liking in /etc/hassio.json config file.
    To backup all of your HA settings and setups you need to just copy this folder. That's why I like idea of using Docker. You can lose all your RPi setup, but if you fave backed up your config folder it only matter of half an hour to recover everything from scratch.



  • @monte can you copy this over ssh? tried using scp -r, which seemed to work but can't find the downloaded files somehow.
    And in regard of updating HA(within UI I see that and update is available). I can just stop the container and run a new updated version right, without it affecting config files?

    Furthermore I wondered about HA speed, if I want to look at the history of a sensors it takes quite a while to poll the data and create a graph. Is this subsequent to HA/rpi or can the performance be improved somehow?



  • @Sebex yes, you can copy config over ssh, like every other directory you have access to. It should be located from where you were running scp command. Do you use linux on your desktop/laptop?
    You can also create samba share on your raspberry with location of your config folder, and then access it from any pc on the network, it makes easy to config your HA.

    Yes you can pull newer version of a container and all your config files should be in place.

    Can't help you with UI speed, sorry. You can try to find anything on HA forum, maybe there is someone who made some performance tests.



  • @monte thanks it worked using Samba. I use ssh from my mac. I also found the copied folder that I tried to copy with scp 😆

    I tried pulling a new version but that didn't seem to work so easily. It seems to get stuck on initialising after which it shuts down and tries again. The logs show the error below, it's missing a file/directory. Not sure how to solve this.

    2020/01/23 17:13:08 [error] 7#7: *1 open() "/usr/share/www/api/websocket" failed (2: No such file or directory), client: ::ffff:192.168.178.16, server: , request: "GET /api/websocket HTTP/1.1", host: "192.168.178.27:8123"
    2020/01/23 17:13:15 [error] 7#7: *3 open() "/usr/share/www/api/websocket" failed (2: No such file or directory), client: ::ffff:192.168.178.16, server: , request: "GET /api/websocket HTTP/1.1", host: "192.168.178.27:8123"
    2020/01/23 17:13:21 [error] 7#7: *4 open() "/usr/share/www/api/websocket" failed (2: No such file or directory), client: ::ffff:192.168.178.16, server: , request: "GET /api/websocket HTTP/1.1", host: "192.168.178.27:8123"
    

    What I did to update the container is stop all running containers, and remove images, and re-execute the cmd for homeassistant again. Was this the way to go?

    Also is there a way to copy the RPi settings? I quite often get a broken pipe and not sure what's causing it. I am thinking about reflashing the SD and reinstating the settings.



  • @Sebex the best way to backup your Raspbian setup is to copy whole SD card to image file, apparently you can use mac's Disk Utility to do this.

    I'm not sure how home assistant supervisor pulls and runs docker container, but it seems that it have some trouble. You can run setup script once again, maybe it will help.

    For future, you should update via web ui. I've read that hassio images are updated later than standalone home assistant once. So you won't get update right away, when new version of HA is released. But when new version of hassio is released it will suggest you to update in Hass.io dashboard.
    ed425898-cb0d-430c-8768-a11dc95d585e-image.png



  • @monte I had tried that one before, but know that it's useful to restore the file doesn't seem to work and I get an error. Perhaps bad luck, will have to try again.

    In the meantime while reinstating HA I'm facing quite some difficulties in getting HA to install within docker via link. I'm facing a broken pipe quite often and have no idea how to fix this, tried different ssh settings but when installing HA it seems to get stuck at

    pi@raspberrypi:~ $ sudo su
    root@raspberrypi:/home/pi# curl -sL https://raw.githubusercontent.com/home-assistant/hassio-installer/master/hassio_install.sh | bash -s -- -m raspberrypi3
    [Warning] No NetworkManager support on host.
    [Info] Install supervisor Docker container
    packet_write_wait: Connection to fe80::233b:33dc:8d3e:eb75%en0 port 22: Broken pipe
    

    Yesterday it did pass but then hassio had troubles successfully launching. It got the below error in the logs, not sure what caused it.
    error /usr/share/www/manifest.json

    Now trying to install hassio again, any suggestions are welcome. I'm going to try a different SD card and wifi connection instead of ethernet.



  • @Sebex you could try connecting a monitor and keyboard directly to RPi and running install script. Broken pipe means something is braking connection to ssh host. I can't really say what it is for sure, maybe just excessive CPU usage, or running out of ram? But that would be strange.
    If you have backed up you HA setup, why not just flash clean Raspbian image and run install script on it. If it worked before, I don't see why it wouldn't work again.

    And that piece of output you wrote, suggests you are using IPv6 for ssh connection. Is there any reason for this?



  • @monte good idea I'll try that.

    Regarding IPv6, there's no particular reason and I haven't noticed actually. I have been using ssh pi@raspberrypi.local to login, I can also connect directly to the IPv4 address. You think that can resolve it?



  • @Sebex okay, I've googled for you, there are plenty reportings of similar issues. It may be caused by insufficient power supply. On intense CPU usage it may lack current. Try getting better power supply rated at 2.5A, 5V.



  • @monte man you're 100% right. Now that I have connected external screen/keyboard, it actually reports the low voltage quite regularly in cmd line... I've ordered one and should solve the issue 😁



  • This post is deleted!


  • Here I am again, I had a second node running and tried to make it battery powered but it doesn't seem to work on battery only. Anyway along the process of finding out what the problem is I encountered two other problems:

    • I'm getting a ERROR accept: Bad file descriptor in mysgw, only 1 instance seems to be running though:

    Any suggestions on this?

      PID TTY      STAT   TIME COMMAND
        1 ?        Ss     0:05 /sbin/init
        2 ?        S      0:00 [kthreadd]
        3 ?        I<     0:00 [rcu_gp]
        4 ?        I<     0:00 [rcu_par_gp]
        8 ?        I<     0:00 [mm_percpu_wq]
        9 ?        S      0:00 [ksoftirqd/0]
       10 ?        I      0:05 [rcu_sched]
       11 ?        I      0:00 [rcu_bh]
       12 ?        S      0:00 [migration/0]
       13 ?        S      0:00 [cpuhp/0]
       14 ?        S      0:00 [cpuhp/1]
       15 ?        S      0:00 [migration/1]
       16 ?        S      0:00 [ksoftirqd/1]
       17 ?        I      0:00 [kworker/1:0-mm_percpu_wq]
       19 ?        S      0:00 [cpuhp/2]
       20 ?        S      0:00 [migration/2]
       21 ?        S      0:00 [ksoftirqd/2]
       23 ?        I<     0:00 [kworker/2:0H-kblockd]
       24 ?        S      0:00 [cpuhp/3]
       25 ?        S      0:00 [migration/3]
       26 ?        S      0:00 [ksoftirqd/3]
       29 ?        S      0:00 [kdevtmpfs]
       30 ?        I<     0:00 [netns]
       33 ?        I      0:00 [kworker/2:1-mm_percpu_wq]
       34 ?        S      0:00 [khungtaskd]
       35 ?        S      0:00 [oom_reaper]
       36 ?        I<     0:00 [writeback]
       37 ?        S      0:00 [kcompactd0]
       38 ?        I<     0:00 [crypto]
       39 ?        I<     0:00 [kblockd]
       40 ?        S      0:00 [watchdogd]
       42 ?        I<     0:00 [rpciod]
       43 ?        I<     0:00 [kworker/u9:0-hci0]
       44 ?        I<     0:00 [xprtiod]
       47 ?        S      0:00 [kswapd0]
       48 ?        I<     0:00 [nfsiod]
       59 ?        I<     0:00 [kthrotld]
       60 ?        I<     0:00 [iscsi_eh]
       61 ?        I<     0:00 [dwc_otg]
       62 ?        I<     0:00 [DWC Notificatio]
       63 ?        S<     0:04 [vchiq-slot/0]
       64 ?        S<     0:01 [vchiq-recy/0]
       65 ?        S<     0:00 [vchiq-sync/0]
       66 ?        S      0:00 [vchiq-keep/0]
       67 ?        S<     0:00 [SMIO]
       69 ?        S      0:00 [irq/86-mmc1]
       71 ?        I<     0:00 [mmc_complete]
       74 ?        I<     0:01 [kworker/0:1H-mmc_complete]
       75 ?        I<     0:00 [kworker/1:1H-kblockd]
       76 ?        S      0:00 [jbd2/mmcblk0p2-]
       77 ?        I<     0:00 [ext4-rsv-conver]
       79 ?        I<     0:00 [ipv6_addrconf]
       96 ?        I<     0:00 [kworker/3:2H-kblockd]
      101 ?        S      0:00 [irq/166-usb-001]
      114 ?        Ss     0:01 /lib/systemd/systemd-journald
      144 ?        Ss     0:01 /lib/systemd/systemd-udevd
      159 ?        S<     0:00 [SMIO]
      181 ?        I<     0:00 [mmal-vchiq]
      183 ?        I<     0:00 [mmal-vchiq]
      185 ?        I<     0:00 [mmal-vchiq]
      198 ?        I<     0:00 [cfg80211]
      202 ?        I<     0:00 [brcmf_wq/mmc1:0]
      203 ?        S      0:00 [brcmf_wdog/mmc1]
      247 ?        Ssl    0:00 /lib/systemd/systemd-timesyncd
      290 ?        Ss     0:55 /usr/local/bin/mysgw -q
      295 ?        Ss     0:00 /usr/sbin/thd --triggers /etc/triggerhappy/triggers.d/ --socket /run/thd.socket --user nobody --deviceglob /dev/input/ev
      297 ?        Ss     0:00 /usr/sbin/cron -f
      298 ?        Ss     0:01 avahi-daemon: running [raspberrypi.local]
      299 ?        Ss     0:01 /usr/bin/dbus-daemon --system --address=systemd: --nofork --nopidfile --systemd-activation --syslog-only
      303 ?        Ssl    0:00 /usr/sbin/rsyslogd -n -iNONE
      311 ?        Ss     0:00 /lib/systemd/systemd-logind
      315 ?        SNs    0:00 /usr/sbin/alsactl -E HOME=/run/alsa -s -n 19 -c rdaemon
      319 ?        Ss     0:00 /sbin/wpa_supplicant -u -s -O /run/wpa_supplicant
      344 ?        SLsl   0:00 /usr/sbin/rngd -r /dev/hwrng
      356 ?        S      0:00 avahi-daemon: chroot helper
      395 ?        I      0:00 [kworker/2:3-mm_percpu_wq]
      456 ?        Ss     0:00 /sbin/dhcpcd -q -w
      461 ?        Ss     0:01 /usr/sbin/nmbd --foreground --no-process-group
      463 ?        Ssl    0:00 /usr/bin/python3 /usr/share/unattended-upgrades/unattended-upgrade-shutdown --wait-for-signal
      466 ?        Ssl    0:02 /usr/bin/containerd
      467 ?        Ssl    0:11 /usr/bin/dockerd -H fd:// --containerd=/run/containerd/containerd.sock
      468 tty1     Ss+    0:00 /sbin/agetty -o -p -- \u --noclear tty1 linux
      469 ?        Ss     0:00 /usr/sbin/sshd -D
      479 ?        S      0:00 /usr/bin/hciattach /dev/serial1 bcm43xx 3000000 flow - b8:27:eb:d7:7e:1b
      481 ?        I<     0:00 [kworker/u9:2-hci0]
      483 ?        Ss     0:00 /usr/lib/bluetooth/bluetoothd
      489 ?        Ss     0:00 sshd: pi [priv]
      511 ?        Ss     0:01 /lib/systemd/systemd --user
      514 ?        S      0:00 (sd-pam)
      525 ?        Ss     0:00 /usr/sbin/smbd --foreground --no-process-group
      536 ?        R      0:03 sshd: pi@pts/0
      539 pts/0    Ss     0:01 -bash
      542 ?        S      0:00 /usr/sbin/smbd --foreground --no-process-group
      543 ?        S      0:00 /usr/sbin/smbd --foreground --no-process-group
      552 ?        S      0:00 /usr/sbin/smbd --foreground --no-process-group
      794 ?        Ss     0:00 /bin/sh /usr/sbin/hassio-supervisor
      821 ?        Sl     0:01 docker start --attach hassio_supervisor
      873 ?        Sl     0:00 containerd-shim -namespace moby -workdir /var/lib/containerd/io.containerd.runtime.v1.linux/moby/af8bfda572398f9806ba54d
      890 ?        Ss     0:00 s6-svscan -t0 /var/run/s6/services
     1045 ?        S      0:00 s6-supervise s6-fdholderd
     1192 ?        Ss     0:00 udevd --daemon
     1267 ?        S      0:00 s6-supervise supervisor
     1271 ?        Ssl    0:17 python3 -m supervisor
     1354 ?        S      0:00 socat UDP-RECVFROM:53,fork UDP-SENDTO:172.30.32.3:53
     1398 ?        Sl     0:00 containerd-shim -namespace moby -workdir /var/lib/containerd/io.containerd.runtime.v1.linux/moby/21403e3385d0ce05418df7e
     1409 ?        Sl     0:00 containerd-shim -namespace moby -workdir /var/lib/containerd/io.containerd.runtime.v1.linux/moby/2b6193b6744b35b8d848671
     1433 ?        Ssl    0:01 coredns -conf /config/corefile
     1437 ?        Ss     0:00 s6-svscan -t0 /var/run/s6/services
     1625 ?        S      0:00 s6-supervise s6-fdholderd
     1919 ?        Ss     0:00 udevd --daemon
     1951 ?        S      0:00 s6-supervise bridge
     1952 ?        S      0:00 s6-supervise pulseaudio
     1955 ?        Ss     0:00 socat UNIX-LISTEN:/data/external/pulse.sock,fork,unlink-early,mode=777 UNIX-CONNECT:/data/internal/pulse.sock
     1956 ?        S<sl   0:05 pulseaudio --system -vvv
     2004 ?        Sl     0:00 containerd-shim -namespace moby -workdir /var/lib/containerd/io.containerd.runtime.v1.linux/moby/00ef0f54f7a780be3af62a1
     2019 ?        Ssl    2:07 /usr/local/bin/python3 -m homeassistant --config /config
     2036 ?        Ss     0:01 udevd --daemon
     2353 ?        Sl     0:00 containerd-shim -namespace moby -workdir /var/lib/containerd/io.containerd.runtime.v1.linux/moby/9ca754987ee52a3a48c5290
     2369 ?        Ss     0:00 /sbin/docker-init -- /init /run.sh
     2462 ?        S      0:00 s6-svscan -t0 /var/run/s6/services
     2487 ?        S      0:00 foreground  if   /etc/s6/init/init-stage2-redirfd   foreground    if     if      s6-echo      -n      --      [s6-init] 
     2488 ?        S      0:00 s6-supervise s6-fdholderd
     2499 ?        S      0:00 foreground  s6-setsid  -gq  --  with-contenv  backtick  -D  0  -n  S6_LOGGING   printcontenv   S6_LOGGING    importas  S
     2632 ?        S      0:02 /usr/local/bin/python /usr/local/bin/hass-configurator /etc/configurator.conf
     2677 ?        S      0:02 /usr/sbin/smbd --foreground --no-process-group
     2837 ?        I<     0:00 [kworker/1:2H]
     2854 pts/0    T      0:00 sudo nano mysensors.conf
     2859 pts/0    T      0:00 nano mysensors.conf
     2903 ?        I      0:00 [kworker/u8:2-events_unbound]
     2937 ?        I<     0:00 [kworker/3:0H]
     2939 ?        I      0:00 [kworker/3:2-mm_percpu_wq]
     2968 ?        I      0:00 [kworker/1:2-events]
     3008 ?        I      0:00 [kworker/u8:0-events_unbound]
     3021 ?        I<     0:00 [kworker/0:2H]
     3022 ?        I      0:00 [kworker/0:0-events]
     3036 ?        I      0:00 [kworker/3:0-events]
     3037 ?        I<     0:00 [kworker/2:2H]
     3043 ?        I      0:00 [kworker/0:1-events_power_efficient]
     3068 ?        I      0:00 [kworker/u8:1-events_unbound]
     3070 ?        I      0:00 [kworker/2:0-mm_percpu_wq]
     3071 ?        I<     0:00 [kworker/3:1H-kblockd]
     3074 ?        I<     0:00 [kworker/0:0H]
     3075 ?        I      0:00 [kworker/3:1-events]
     3076 pts/0    R+     0:00 ps -ax
    
    

Log in to reply
 

Suggested Topics

  • 4
  • 5
  • 3
  • 10
  • 13
  • 7
  • 4
  • 5

308
Online

9.2k
Users

9.9k
Topics

103.2k
Posts