Difficulties compiling Nodemcu 1.0 (ESP-12 module) as a 8266 Gateway.



  • Some time ago with an older Mysensors Library (I don't remember which) I had a working Gateway based on this board. Now i want to give this gateway a new live, but I have compile problems I cannot solve. I miss the knowledge to get it solved. I tried some things, however without success!

    My environment is completely standard so:

    • Arduino ide: 1.8.12

    • Mysensors Library: 2.3.2

    • Board ESP8266: version 2.6.3

    • Sketch: ESP8286 wifi example completely standard; only ssid and password changed

    1. Compiling gave this error:
      fork/exec /Users/robertus/Library/Arduino15/packages/esp8266/tools/python3/3.7.2-post1/python3: no such file or directory
      Error compiling for board NodeMCU 1.0 (ESP-12E Module).

    Then I red somewhere to use board ESP8266 version: 2.5.2, so I loaded this version of ESP8266 board also, then:

    1. Compiling gave now this error:
      Arduino: 1.8.12 (Mac OS X), Board: "NodeMCU 1.0 (ESP-12E Module), 80 MHz, Flash, Disabled, All SSL ciphers (most compatible), 4M (no SPIFFS), v2 Lower Memory, Disabled, None, Only Sketch, 115200"

    In file included from /Users/robertus/Documents/Arduino/libraries/MySensors/MySensors.h:441:0,
    from /Users/robertus/Documents/Arduino/GatewayESP8266-New/GatewayESP8266-New.ino:114:
    /Users/robertus/Documents/Arduino/libraries/MySensors/hal/architecture/ESP8266/MyMainESP8266.cpp: In function 'void esp_yield_within_cont()':
    /Users/robertus/Documents/Arduino/libraries/MySensors/hal/architecture/ESP8266/MyMainESP8266.cpp:102:36: error: 'run_scheduled_recurrent_functions' was not declared in this scope
    run_scheduled_recurrent_functions();
    ^
    /Users/robertus/Documents/Arduino/libraries/MySensors/hal/architecture/ESP8266/MyMainESP8266.cpp: At global scope:
    /Users/robertus/Documents/Arduino/libraries/MySensors/hal/architecture/ESP8266/MyMainESP8266.cpp:140:27: error: expected initializer before 'ets_intr_lock'
    extern "C" void IRAM_ATTR ets_intr_lock()
    ^
    exit status 1
    Error compiling for board NodeMCU 1.0 (ESP-12E Module).

    This report would have more information with
    "Show verbose output during compilation"
    option enabled in File -> Preferences.

    Can somebody shed some light on this and hopefully has a solution, because I am stuck.

    Questions:

    1. Can error 1 be solved? Probably not a my sensors thing!
    2. Why is the board version 2.5.2 of ESP giving these errors?
    3. Is there a combination of software versions, that work?

    I appreciate any help. Thanks



  • For the third, could you try 2.4.2 ESP library?


  • Mod

    @ramwal the release notes for MySensors 2.3.2 has the following:

    Important information:

    If you encounter compilation issues, update your board definitions:

    AVR 1.8.2
    ESP8266 2.6.2

    Maybe give 2.6.2 of esp8266 a try?



  • @mfalkvidd, @electrik

    Thank you for the hints. After have been looking further on the internet involving the compile problem and found the solution, that worked for me.link text.
    I inform you that it is Mac OSX python problem in the installed python version on my Mac, a broken link to the python executable.

    I simply installed the newest version 3.8.2 Python on my laptop Mac and the problem disappeared.

    So, everything is working now with all the latest firmwares (see above).


  • Mod

    Nice work @ramwal
    Thanks for reporting back.


  • Hero Member

    @ramwal Thanks for the hint, it made the trick here too!


Log in to reply
 

Suggested Topics

  • 4
  • 2
  • 7
  • 35
  • 14
  • 14
  • 30
  • 2

181
Online

9.4k
Users

10.0k
Topics

104.4k
Posts