Domoticz weather sensor presentation



  • I have created a weather sensor which has hum, temp, baro, predicition and lux.
    Aslo i have attached there another ds temp sensor (for node internal temp).
    Problem is that when i update fw over ota or reboot node, it'll occasionally detect sensors all mixed up:
    temp/hum, temp, baro/temp/hum etc... Also when it does that, not all the data will be updated on combined sensros.
    Is there a way to present the sensors to domticz so, that it recognises 1 combined weather sensor and then others.
    I have tried with all different Sensor ID's 1-4, lux id5 and internal temp id6.
    Also tried with giving same sensor ID number to hum, temp, baro and predicition.
    Domoticz detects it as a combined sensor, but it doesn't update all values after initial value has been sent.
    If i monitor the data on myscontroller, all the variables are updating on the node.



  • I had a similar problem with weather sensors, but it was a while ago and Domoticz has been updated since then.
    I was presenting temp, hum, baro. Domoticz always assumed it was a weather sensor if I presented the baro -- and the humidity wouldn't update. It didn't matter if I used separate child IDs or the same one.
    I really only wanted temperature and humidity, so I quit presenting the baro and the Domoticz temp/hum has always worked well.
    I just assumed I was doing something wrong, but your problem sounds similar. Maybe it's a Domoticz bug.



  • I use a BME280 sensor for outside and some 18b20's for inside. Domoticz works with these without problems but I do not use OTA - not figured that out yet 馃槬 馃槅 I had to cut out all the weather prediction code on for the BME280 to make it run on a pro mini 3.3 but Domoticz has basic prediction built in.


Log in to reply
 

Suggested Topics

  • 2
  • 7
  • 2
  • 1
  • 1
  • 11
  • 2

5
Online

9.5k
Users

10.2k
Topics

105.6k
Posts