Reusing arduinos?



  • I am having an issue reusing any ardionos that were previously networked on the system (and deleted). I have tried clearing the eprom on both the gateway and the units I am trying to reuse and that doesn't seem to work. I am unable to add them when i start inclusion they are never found. Does anyone know how to fix this?


  • Admin

    @ajachierno

    Controller?

    Clearing EEPROM will reset them to original state and they will request a new id from the controller.



  • I am using a serial gateway on a vera 3 controller, everything works fine with new arduinos just not anything i used before. I just tried to clear the eprom again and still not working


  • Admin

    Try restarting vera (power cut). It caches stuff invisibly.



  • Nope tried that once before, and just now 2 more times.


  • Admin

    Tried clearing eeprom of gateway? Maybe a corrupt routing table?



  • yep, tried that as well when i cleared the sensor


  • Admin

    Is communication working all the way to the gateway?



  • I have the same problem. After clearing EEPROM & deleting the node from Vera the same board doesn't want to be identified by GateWay Plugin. The communication is OK, cause hardware is the same & distance is minimum (all boards are on one table).
    I didn't try the above mentioned ways (restarting Vera, clearing EEPROM of GateWay board), but it seems it doesn't help :cry:
    Does any solution exist?


  • Admin

    I don't have any logical reason why it should behave like this. Never encountered it myself.

    You're sure node is working? When you look at the debug messages in serial monitor?



  • It looks like this
    Скриншот 2015-03-01 19.40.10.png


  • Admin

    The node hasn't managed to receive a node id. As you can see it still using id 255.

    You're repeater(4) has a hard time ack:ing messages back to the node. You should add capacitor on that node and/or check powersource.

    So when including the node you should either move it close to the gateway (skip repeater during this initial phase) or fix radio communication between repeater and node.



  • As I've mentioned already, the hardware was the same, and NRF-module has a capacitor. The power for board is enough (about 1A). And this Arduino board was identified without any problem at first.
    Does any way exist to set node ID manually in this case?


  • Admin

    Set a static id of 42 like this.

    gw.begin(NULL, 42)
    

    Still, doesn't fix your ack problems that probably will lead to unnecessary parent-node-searches.



  • I have no idea why but I was able to reuse 2 of my 4 boards like this no idea what changed or why. May just need to give it time?



  • As for me clearing the EEPROM of the board & restart of Vera (shutting off the power for couple of minutes) helped. Vera included early ignored board with the id1 (my first node was deleted from Vera about month ago).
    Thanks to hek for advise.


  • Hero Member

    I'm having a similar issue with a pro-mini clone. If I run the erase eeprom sketch, it completes, but if I then run the eeprom sketch to show all the values in the eeprom, it returns quite a few non-zero values, so not sure why it's not completely erasing. I used the gw.begin(NULL, xx) command to assign a node number to it for now.

    Cheers
    Al


  • Admin

    @Sparkman

    Strange. Could the clearing-sketch be writing to fast for the eeprom to handle it?



  • @Sparkman

    If you mean EEPROM values above address 512 then you are right. The sketch only writes from 0 to 512. Your pro mini EEPROM however has 1024 addresses. Does this make sense?


  • Admin

    Yes, but the id, parent and routing is in the lower region.


Log in to reply
 

Looks like your connection to MySensors Forum was lost, please wait while we try to reconnect.