Cannot find parent when USB plugged in, Works when NOT plugged in!

  • Hi All,

    I am building a node, for irrigation control. I am using a mini Mega 2560 based mcu, so get enough I/O .
    I have used one of these boards on a previous project sucessfully. The radio (RFM69HCW) is a adafruit breakout board, which is new to me. I have already spent several hours pulling hair, when I found forum posts relating to the reset pin, and toggling it.
    IF i power the system via the USB connection, it fails to find a parent.

    10:21:30.198 -> 0 MCO:BGN:INIT NODE,CP=RRNNA---,VER=2.2.0
    10:21:30.198 -> 3 TSM:INIT
    10:21:30.198 -> 4 TSF:WUR:MS=60000
    10:21:30.198 -> 7 TSM:INIT:TSP OK
    10:21:30.198 -> 8 TSM:INIT:STATID=35
    10:21:30.198 -> 10 TSF:SID:OK,ID=35
    10:21:30.198 -> 12 TSM:FPAR
    10:21:31.462 -> 1242 TSF:MSG:SEND,35-35-255-255,s=255,c=3,t=7,pt=0,l=0,sg=0,ft=0,st=OK:
    10:21:33.468 -> 3249 !TSM:FPAR:NO REPLY
    10:21:33.468 -> 3251 TSM:FPAR
    10:21:34.693 -> 4476 TSF:MSG:SEND,35-35-255-255,s=255,c=3,t=7,pt=0,l=0,sg=0,ft=0,st=OK:
    10:21:36.709 -> 6484 !TSM:FPAR:NO REPLY
    10:21:36.709 -> 6487 TSM:FPAR
    10:21:37.925 -> 7715 TSF:MSG:SEND,35-35-255-255,s=255,c=3,t=7,pt=0,l=0,sg=0,ft=0,st=OK:
    10:21:39.936 -> 9722 !TSM:FPAR:NO REPLY
    10:21:39.936 -> 9724 TSM:FPAR
    10:21:41.153 -> 10949 TSF:MSG:SEND,35-35-255-255,s=255,c=3,t=7,pt=0,l=0,sg=0,ft=0,st=OK:
    10:21:43.168 -> 12956 !TSM:FPAR:FAIL
    10:21:43.168 -> 12957 TSM:FAIL:CNT=1
    10:21:43.168 -> 12959 TSM:FAIL:DIS

    If I power either from a 5V supply into the 5V line, or a 8Vsupply int the Vin, then EVIDENTLY it finds the parent, as I can see it communicating in the Domoticz log. data is updated etc.
    I say EVIDENTLY, because I cannot see the debug output in the terminal window, as as soon as I plug the USB in, the device resets, and then fails to find the parent again.

    I am sitting 6 ft from the gateway, I have tried varying the Tx power using #define MY_RFM69_TX_POWER_DBM (13)
    I have a 220microF and a 0.1 microF Tantalum fitted near the board pins of the Adafruit breakout board.
    ALSO please note that when data is being passed to the controller( no usb connected) SENDING data to the node always fails, according to the controller log.

    I could try and redirect Serial.prints to another port, and manage to cobble together a rs232 into my PC, but other than that, any ideas as to the cause?

  • @Njwyborn I think it is either that the USB cannot supply enough current and the voltage is dropping when the radio starts to transmit, or it is a noisy USB power port that needs more filtering (chokes, capacitors) to smooth it out.

    If you are able to get a good quality 5v stable power supply from a reputable electronics supplier it may well solve the issue for you

    Also wortha try is setting minimum transmit power and moving the node and gateway further apart. It may be that the gateway is saturating...

  • @skywatch . The same USB port(s) and cable(s) have been used many times recently on other projects, and it works (tx only) using the 5V or 8V supplies as mentioned above. When supplied via Vin, I imagine that the USB supply is cut off from the 5v buss, though I have no schematics to back up that assumption, it is just that's what other boards do.

  • Mod

    @Njwyborn said in Cannot find parent when USB plugged in, Works when NOT plugged in!:

    could try and redirect Serial.prints to another port, and manage to cobble together a rs232 into my PC, but other than that, any ideas as to the cause?

    Connect rx, tx and gnd to usb, but do not connect vcc. That makes it possible to see the debug output while still using external power.

  • @Njwyborn I guess you checked that all the grounds are conneted. A photo of the setup you have might help. What are you using as a 'USB supply"?

  • @mfalkvidd
    Have tried, however com port isn't "made" in windows, so nothing to connect to. Ill make a RS232 connection, and report back.

  • @skywatch
    The PC port (direct, no hub) is the supply. Should provide 500mA. it's powering the mega, and the RFM breakout board, and two small H bridges, with no loads.
    Ill post a pic after I try the RS232

  • Hi All,

    Making the RS232 hasn't worked, in sofar as all I am getting is gibberish. I am having to use a USB to rs232 converter, I have chopped a lead, and connected to the MCU pins, but all I get is gibberish. I have tried it also on another node, to eliminate the MCU, and the output is similarly gibberish. Have obviously played with baud rates, and even UART settings, no joy. For those wanting the Pic, here it is. I have got one of the underside, but I don't think it will help.
    I don't have a "real" serial port on this PC.(atleast not a DB9 on the rear)
    One recent time I had the USB port connected, if found the gateway!

    3 TSM:INIT
    4 TSF:WUR:MS=60000
    10 TSF:SID:OK,ID=35
    12 TSM:FPAR
    1229 TSF:MSG:SEND,35-35-255-255,s=255,c=3,t=7,pt=0,l=0,sg=0,ft=0,st=OK:
    3238 TSM:FPAR
    4453 TSF:MSG:SEND,35-35-255-255,s=255,c=3,t=7,pt=0,l=0,sg=0,ft=0,st=OK:
    4621 TSF:MSG:READ,0-0-35,s=255,c=3,t=8,pt=1,l=1,sg=0:0
    4626 TSF:MSG:FPAR OK,ID=0,D=1
    6460 TSM:FPAR:OK
    6461 TSM:ID
    6462 TSM:ID:OK
    6464 TSM:UPL
    6477 TSF:MSG:SEND,35-35-0-0,s=255,c=3,t=24,pt=1,l=1,sg=0,ft=0,st=OK:1
    6700 TSF:MSG:READ,0-0-35,s=255,c=3,t=25,pt=1,l=1,sg=0:1
    6708 TSM:UPL:OK
    6709 TSM:READY:ID=35,PAR=0,DIS=1
    6737 TSF:MSG:SEND,35-35-0-0,s=255,c=3,t=15,pt=6,l=2,sg=0,ft=0,st=OK:0100
    6940 TSF:MSG:READ,0-0-35,s=255,c=3,t=15,pt=6,l=2,sg=0:0100
    6957 TSF:MSG:SEND,35-35-0-0,s=255,c=0,t=17,pt=0,l=5,sg=0,ft=0,st=OK:2.2.0
    6977 TSF:MSG:SEND,35-35-0-0,s=255,c=3,t=6,pt=1,l=1,sg=0,ft=0,st=OK:0
    7020 TSF:MSG:READ,0-0-35,s=255,c=3,t=6,pt=0,l=1,sg=0:M
    7036 TSF:MSG:SEND,35-35-0-0,s=255,c=3,t=11,pt=0,l=12,sg=0,ft=0,st=OK:Water Relay4
    7057 TSF:MSG:SEND,35-35-0-0,s=255,c=3,t=12,pt=0,l=5,sg=0,ft=0,st=OK:1.0.0
    7076 TSF:MSG:SEND,35-35-0-0,s=9,c=0,t=35,pt=0,l=13,sg=0,ft=0,st=OK:Soil Moisture
    7357 TSF:MSG:SEND,35-35-0-0,s=7,c=0,t=14,pt=0,l=13,sg=0,ft=0,st=OK:Soil Setpoint
    7636 TSF:MSG:SEND,35-35-0-0,s=11,c=0,t=36,pt=0,l=15,sg=0,ft=0,st=OK:Water Time1 Min
    7917 TSF:MSG:SEND,35-35-0-0,s=12,c=0,t=36,pt=0,l=15,sg=0,ft=0,st=OK:Water Time2 Min
    8197 TSF:MSG:SEND,35-35-0-0,s=13,c=0,t=36,pt=0,l=15,sg=0,ft=0,st=OK:Water Time3 Min
    8476 TSF:MSG:SEND,35-35-0-0,s=14,c=0,t=36,pt=0,l=15,sg=0,ft=0,st=OK:Water Time4 Min
    9966 !TSF:MSG:SEND,35-35-0-0,s=15,c=0,t=14,pt=0,l=20,sg=0,ft=0,st=NACK:Watering UPDATE Bits
    10235 TSF:MSG:SEND,35-35-0-0,s=5,c=0,t=33,pt=0,l=24,sg=0,ft=1,st=OK:Soil Transmitter RX RSSI
    10459 TSF:MSG:READ,0-0-35,s=5,c=0,t=33,pt=0,l=24,sg=0:Soil Transmitter RX RSSI
    10466 TSF:MSG:ACK
    +Ack FMGW


  • Could you try a different USB to serial adapter? Maybe this one is faulty.

  • @electrik
    I'm doing one better, the motherboard has serial ports, they are on headers, and were not brought out to the rear on DB9 connectors. I have ordered a header, so I can get a native serial port to try.

    Regards Nigel

  • Update:
    The issue seems to be with the Mega Mini board.

    I managed to remove the Adafruit RFM69HW daughter board from the verroboard, and wired this to a Nano, and a Teensy 3.2. Both worked with the same PSU.
    The USB converter however is still giving garbage , no matter which of the three sources above.
    So I am in the belated process of porting code to the teensy as the target.

    Many thanks for the help to you all.

    Now, if I can only sort out my sensebender gateway problem....

Log in to reply

Suggested Topics