I need basic advice on getting my ethernet gateway to work



  • Hi all. I'm getting really frustrated with trying to build a gateway and I feel like I'm about to walk away from this, which is too bad because I was really exited about this mysensors thing.

    I'm trying to build a ethernet gateway. I'm following the instructions exactly. First I tried with an Arduino Nano clone, and when that didn't work I switched to my genuine Arduino Uno. I have the W5100 ethernet module and everything is wired exactly according to the directions.
    I've made the prescribed changes to the MyConfig.h file, and I've uploaded the sketch without any issue now that I rolled back to Arduino IDE 1.6.5.

    I plug in the ethernet cable and the usb for power, and I don't see this device anywhere on the network. I've tried a few different ip addresses and still nothing. When I use the default IP, the ping request times out, when I use anything in 192.168.1.xxx to match my network I get the message "destination host unreachable."

    What can I do to troubleshoot this?

    By the way, running Windows 8.1 if that matters.


  • Admin

    Well, the usual problems is

    1. Mis-wiring
    2. Under powering of ethernet module
    3. Wrong configuration.

    You can eliminate the last by running the W5100gateway sketch from the development branch. It's configured to run with SoftSPI from start.



  • I loaded the development branch but there is nothing in the setup or loop functions. Should there be something there?


  • Admin

    @spork said:

    Should there be something there?

    No, that's correct.



  • How would I be able to tell if I was underpowering the Ethernet module?


  • Mod

    @spork said:

    How would I be able to tell if I was underpowering the Ethernet module?

    weird things happen :-)
    When a circuit is under-powered, it stops behaving according to the specification and basically anything can happen so troubleshooting becomes infuriating.

    The best tip I know is to read the specifications on the module you've bought and make sure you have a power supply that exceeds the requirements by a wide margin.



  • @spork said:

    How would I be able to tell if I was underpowering the Ethernet module?

    I have built the ethernet GW recently (genuine Arduino Uno and W5100) and it works like a charm. Try to power it up from an iPhone/iPad charger - they are powerful enough. By the way, Arduino Uno + W5100 + nrf24l01+ take about 250mA


Log in to reply
 

Looks like your connection to MySensors Forum was lost, please wait while we try to reconnect.