Installing MySensors and Arduino IDE on OSX



  • Hi
    I Installed Arduino IDE 1.0.6 and it works fine. I've compiled and uploaded sketches.
    I installed all the mysensors libraries from 1.5 release and this error happens when I compile and upload (HuniditySensor is just an example it happens on other sketches too):
    In file included from HumiditySensor.ino:31:
    /Users/patrickschaerer/Documents/Arduino/libraries/MySensors/MySensor.h:158: error: expected type-specifier before 'MyHwDriver'
    /Users/patrickschaerer/Documents/Arduino/libraries/MySensors/MySensor.h:158: error: default argument for parameter of type 'MyHw&' has type 'int'
    /Users/patrickschaerer/Documents/Arduino/libraries/MySensors/MySensor.h:158: error: expected ',' before 'MyHwDriver'

    I deleted all the libraries an installed mysensor libraries from 1.4 release. Compiling and uploading works fine on 1.4 release.

    Is there a bug in the 1.5 release or is something wrong with my installation?


  • Mod

    The 1.5 release should work.
    When you install 1.5, did you first remove all old libraries (for 1.4)? If not, try that.



  • 1.5 was a clean install. After that I deleted all libraries and installed 1.4 and it worked with 1.4.
    I tried to install 1.5 libraries over 1.4 but this did not help.
    I took mysensor.h from codebender, but that got even more errors 😞


  • Hardware Contributor

    I use the Arduino 1.6.5 IDE and the development build. Works perfectly for me on El Capitan.



  • ok I installed Arduino IDE 1.6.6 and mysensors 1.5
    Now I can compile, but that IDE version doesn't work with my arduinos 😞
    avrdude: ser_open(): can't open device "/dev/cu.wchusbserial1420": Resource busy
    it seems a known problem with osx and serial bus ... I think I'll compile and upload with the windows pc


  • Plugin Developer

    I first tried with 1.6.6 but it did not work so now i use 1.6.5.


 

343
Online

8.2k
Users

9.1k
Topics

96.6k
Posts