Remote Access



  • Is there an easy way to access the MyController web interface from outside my local network?



  • @cjm4909 it is very easy if you just open the port of your Mycontroller web address (default 8443) on your router. If you've got dynamic IP from your ISP you can always apply for ddns provider.



  • Thank you I will take a look



  • I have sort of the same question, but the easy way to give access to my Raspberry thru my router by using a DDNS service is not working for me, as I have a crippled dual stack lite IPv6 implementation.

    So I am more or less left to rely on the other way round: Push data from the home server into the internet. Is there a recommended way of doing this with mycontroller or more general mysensors? I am not using MQTT so far, just an ethernet gateway. For example Domoticz have this my.domoticz service which enables just this very easily.



  • @Velo17 One of my linux servers is also behind double NAT network but I can still use DDNS service however update client has to be installed / configured on the server itself not on the router.

    Other option (if you are running Raspbian) would be Teamviewer.



  • @niccodemi It's been already a couple of years ago when I last tried to get this running like you describe - actually in the IPv4 days. But that client I used doesnt work with IPv6 anymore. Can you tell me which client and maybe DDNS service you are using? And yes, I'm running Raspbian. True, last option would be Teamviewer.

    Thank you and greetings from Germany!



  • @Velo17 I am still on IPv4. I use DDClient as an update agent. I think it works with majority of providers such as NO-IP and DYNU.



  • any idea why i can't acess mycontroler from internet i was opening port 8443 for computer on which controller are running but still not open browser said ERR_INVALID_HTTP_RESPONSE, i was try to run domoticz controller and have no problem to accessing it from internet


  • Mod

    @Mitja-Blazinsek are you using https:// before the ip/host name? Which browsers have you tried and is the result the same in all of them?



  • i try with and without https, i'm using chrome but also try explorer as i said domoticz work fine



  • @Mitja-Blazinsek I had similar issue. I found the cause was port 8443 itself. When I changed Mycontroller config to use another port (8442 or 8444) and opened it, I was able to access Mycontroller from external networks.



  • still no success try chane the ports, shoul i chane anything else in config file like bind ip my settings in config file is:

    mcc.web.bind.address=0.0.0.0
    mcc.web.enable.https=true
    mcc.web.http.port=8181
    mcc.web.file.location=../www/
    mcc.web.ssl.keystore.file=../conf/keystore.jks
    mcc.web.ssl.keystore.password=mycontroller
    mcc.web.ssl.keystore.type=JKS



  • it works now i disabled https, and it works fine thanks folks for help 🙂


Log in to reply
 

567
Online

6.7k
Users

7.6k
Topics

80.6k
Posts

Looks like your connection to MySensors Forum was lost, please wait while we try to reconnect.