Node not connecting in IDE Serial Monitor but does stand alone



  • Since the latest Arduino IDE update I did last week I notice my Display Node project can't be monitored by the IDE Serial Monitor. The node fails to connect to the Gateway.
    However when the node is powered without using the IDE Serial Monitor it is working properly.
    What can be the reason for this?



  • No suggestions?
    In addition: in both situations the node (Nano) is powered by the PC (usb). The node is connecting to the gateway but as soon Arduino IDE Serial Monitor is started (node restarts) the node won't connect to the gateway anymore responding with FAIL (keeping trying).
    Debugging is an issue now.


  • Mod

    Have you tried an older ide version? Or on another computer?


  • Hardware Contributor

    @Petjepet

    However when the node is powered without using the IDE Serial Monitor it is working properly.

    Does the problem only exist, when you open the serial monitor?

    Or does it appear as soon as you attach the node via serial to the computer?

    What is your hardware (arduion type, radio type, serial connection...) and wiring setup?



  • @gohan No I didn't want to downgrade my EDI ending up in having library issues.

    @FotoFieber I have the node attached via USB to my PC. All works fine.
    I open the Arduino IDE having the sketch, as already running on the node, open to edit. All works fine.
    I now start the Serial Monitor. The node restarts and I see this:

    0 MCO:BGN:INIT REPEATER,CP=RNNRA--,VER=2.1.1
    3 TSM:INIT
    4 TSF:WUR:MS=0
    11 TSM:INIT:TSP OK
    13 TSM:INIT:STATID=100
    15 TSF:SID:OK,ID=100
    17 TSM:FPAR
    53 TSF:MSG:SEND,100-100-255-255,s=255,c=3,t=7,pt=0,l=0,sg=0,ft=0,st=OK:
    2061 !TSM:FPAR:NO REPLY
    2063 TSM:FPAR
    2099 TSF:MSG:SEND,100-100-255-255,s=255,c=3,t=7,pt=0,l=0,sg=0,ft=0,st=OK:
    4107 !TSM:FPAR:NO REPLY
    4109 TSM:FPAR
    4145 TSF:MSG:SEND,100-100-255-255,s=255,c=3,t=7,pt=0,l=0,sg=0,ft=0,st=OK:
    6153 !TSM:FPAR:NO REPLY
    6155 TSM:FPAR
    6191 TSF:MSG:SEND,100-100-255-255,s=255,c=3,t=7,pt=0,l=0,sg=0,ft=0,st=OK:
    8199 !TSM:FPAR:FAIL
    8200 TSM:FAIL:CNT=1
    8202 TSM:FAIL:PDT
    18205 TSM:FAIL:RE-INIT
    18207 TSM:INIT
    18214 TSM:INIT:TSP OK
    18216 TSM:INIT:STATID=100
    18219 TSF:SID:OK,ID=100
    18221 TSM:FPAR
    18257 TSF:MSG:SEND,100-100-255-255,s=255,c=3,t=7,pt=0,l=0,sg=0,ft=0,st=OK:
    20267 !TSM:FPAR:NO REPLY
    20269 TSM:FPAR
    20305 TSF:MSG:SEND,100-100-255-255,s=255,c=3,t=7,pt=0,l=0,sg=0,ft=0,st=OK:
    22313 !TSM:FPAR:NO REPLY
    22316 TSM:FPAR
    22352 TSF:MSG:SEND,100-100-255-255,s=255,c=3,t=7,pt=0,l=0,sg=0,ft=0,st=OK:
    24360 !TSM:FPAR:NO REPLY
    24363 TSM:FPAR
    24399 TSF:MSG:SEND,100-100-255-255,s=255,c=3,t=7,pt=0,l=0,sg=0,ft=0,st=OK:
    26407 !TSM:FPAR:FAIL
    26408 TSM:FAIL:CNT=2
    26411 TSM:FAIL:PDT
    

    Continuing to RE-INIT.

    Closing the IDE does not solve anything. I first need to unplug the USB and plug it in again and the node is working again.


  • Mod

    ok, but don't you have another computer to try?



  • @gohan said in Node not connecting in IDE Serial Monitor but does stand alone:

    ok, but don't you have another computer to try?

    No.
    What makes you think it is computer related?


  • Mod

    I am just trying to exclude all possible causes since the problem you are having only happens when connecting to pc. You could also try an older AVR board definition and recompile the node (that's should be easy to try)



  • @gohan I understand. But when running ok it is also connected to the PC (using power of the same USB port but not running IDE Serial Monitor) so I guess the PC itself is not the issue.

    Since it seems a communication issue I just added a decoupling capacitor of 4.7µF on the radio power supply.
    Now the node connected after 5 attempts.
    I guess using the serial monitor generates some noise on the USB influencing the 3.3V output of the Nano making the radio instable.


  • Mod

    it is actually clearly stated in the guides to use a capacitor on the radio.



  • @gohan I know it is suggested only when experiencing bad reception issues:

    Connecting a Decoupling-Capacitor

    If you experience bad reception or if transmitted data never reaches destination, try adding a decoupling capacitor of 4.7µ - >47µF (the exact size usually doesn't matter) across the radio's 3.3V and GND.

    But I didn't have issues, only when using the Arduino IDE Serial Monitor and only with this specific node.
    Until now I only had one in the Gateway radio. All other nodes work without except for the Weather Station node because this is running on a solar cel with rechargeable battery on a larger distance. In this one I also extended the NRF24L01 radio antenna.

    Problem seems solved. Thanks for helping out.


  • Mod

    That happens because the voltage regulator from usb isn't able to supply enough current during transmission while when on battery probably it had sufficiently stable voltage for transmitting correctly.


Log in to reply
 

Looks like your connection to MySensors Forum was lost, please wait while we try to reconnect.