(SOLVED) complete reset for registration and adding



  • hi guys

    i have a issue with my mysensors gateway

    i had a node in that was giving me trouble
    so i rebuilt the code and changed the number of relays on it, and added it in and watched it register on domoticz
    but after changing it a 3rd time i got really confused on which node it was, so deleted both out of domoticz.
    now neither of them appear and im not sure how to get them to re register....

    so i planned to now that i have played around a little and gotten to understand a bit more, just resetting mysensors gateway fully so that i can re register all devices and have them reconnect correctly...

    is this possible?


  • Mod

    @markjgabb the gateway does not keep state, so there is nothing to reset. All state is handled by the controller. I am not sure if there is a better way to reset Domoticz than re-installing it. You could try to clear the eeprom of the node and let it get a new id.



  • that might be the best way....
    as once it has presented to domoticz it doesnt reconize it as a new device again
    so clearing eepron may cause it to re present correctly


  • Mod

    @markjgabb it is already presenting correctly. But since you have instructed Domoticz to ignore that node (by deleting it), Domoticz will obey your order and keep ignoring it.

    If you clear the eeprom, the node will ask Domoticz fow a new ID. Domoticz will give the node a new ID, which is not ignored.



  • ahhh that makes so much sense now.....

    perfect, ill do that tonight... i really should remember to save my sensor files properly



  • this solution has worked perfectly
    thanks guys for all your advice...domoticz definatly cant un ignore anyway that i can find either


Log in to reply
 

Looks like your connection to MySensors Forum was lost, please wait while we try to reconnect.