Error: MySensors: Error opening serial port!



  • Someone have this erro msg at Domoticz LOG web page?

    The sequence is:

    2017-07-05 11:04:57.436 Error: MySensors: Error opening serial port!
    2017-07-05 11:04:58.436 MySensors: retrying in 30 seconds...
    2017-07-05 11:05:27.438 MySensors: Using serial port: /dev/ttyUSB20
    2017-07-05 11:05:27.439 Error: MySensors: Error opening serial port!
    2017-07-05 11:05:28.439 MySensors: retrying in 30 seconds...
    2017-07-05 11:05:57.441 MySensors: Using serial port: /dev/ttyUSB20
    2017-07-05 11:05:57.441 Error: MySensors: Error opening serial port!
    2017-07-05 11:05:58.442 MySensors: retrying in 30 seconds...
    2017-07-05 11:06:27.444 MySensors: Using serial port: /dev/ttyUSB20
    2017-07-05 11:06:27.444 Error: MySensors: Error opening serial port!
    2017-07-05 11:06:28.444 MySensors: retrying in 30 seconds...
    2017-07-05 11:06:57.447 MySensors: Using serial port: /dev/ttyUSB20
    2017-07-05 11:06:57.447 Error: MySensors: Error opening serial port!
    2017-07-05 11:06:58.447 MySensors: retrying in 30 seconds...

    My NRF24L01 is powered supply by an external source.

    All the above steps were OK, I did 3 times from the start!


  • Mod

    Are you sure it is the correct port name? 😀



  • Hi gohan, unfortunately I have, I'm doing this procedure:

    https://forum.mysensors.org/topic/2437/step-by-step-procedure-to-connect-the-nrf24l01-to-the-gpio-pins-and-use-the-raspberry-as-a-serial-gateway-mysensors-1-x/2

    I had already change this number, and this issue continues. This virtual USB port was created here:

    sudo ln -s /dev/ttyMySensorsGateway /dev/ttyUSB20


  • Mod

    I can't help much, I always used ethernet GW or MQTT as to me are much better


Log in to reply
 

Looks like your connection to MySensors Forum was lost, please wait while we try to reconnect.