MySensors 2.3.0 on Mega 2560 Ethernet Gateway



  • All
    A little while ago I had upgraded to MySensors 2.3.0 with horrible results....my 18 node network went kablooey. I couldn't get anything stable to save my own life. I was getting 30-90 minutes of runtime on the gateway before it was shutting down and going off line. I of course did this at the exact same time I was rebuilding my gateway, transitioning to the Mega 2560 from thr UNO 328 due to memory and lag issues. To top it all off I am running an NRF24 LNA/PNA radio at MAX because of distance and placement issues.

    Initial gateway

    What I have found was needed to stabilize the gateway.....POWER POWER POWER! It became the Achilles heel of my project. I was initially feeding into the radio then sending power to the Mega via its VCC input (this was ok for the UNO). Voltage going over was good, current wasn't and the gateway would shutdown no matter what the radio power settings were of which radio chip I used. So I switched to a 12v 2.5A power supply and wyed it one connection to the radio board (which has its own voltage regulator) and the other to the Mega's DC jack. Second issue I noted was heat - the Mega runs hotter than the UNO did. I had 130 degrees Fahrenheit on the processor chip. I solved that with a heat sink I had from a raspberry pi and adding a small fan fed from the Mega's 5v pin placed at the back of the Mega. Since that, chip is a cool 80 degrees. I suspect since Im using the Ethernet shield that played a big role in the Mega heating up and the fan really helped.

    Gateway Attempt 3

    The Fan is seen to the immediate left of the LAN jack.
    The toggle switch serves 2 functions...when pushed to the right it resets the gateway, to the left enables inclusion mode. The three LEDs are TX/RX/ERR.

    Hope this helps folks. I will add my wiring and code when I get a chance.

    Heres the gateway mounted in my Ubuntu box, which runs my home media server and OpenHab.

    alt text

    Happy Building and THANK YOU to everyone who has posted ideas and code snipets that made this possible.


  • Hardware Contributor

    @Dbagioni
    wow, that sounds weird, to need a heatsink on a Mega gw.. which ic is heating?? sounds like a fishy hw or connection. (even with my 3dprinter, Mega board doesn't heat..).



  • @scalz It was the big chip on the board heating up. I had thought that too so I swapped the mega out last night(had to wait until Amazon delivered it). It got warm (100ish Degrees) but not as hot as the other one did. But I tried to power the gateway as I had originally and the problems started right up again. So Im going with the issue was power related. Im going to keep the fan because a little extra cooling isn't going to hurt anything.



  • As promised this is my wiring and code, hope this help people out

    First the wiring.

    Radio - Mega Pin
    +3V - NA
    -3V - NA
    CSN/CS(Yellow) - 6
    CE(Orange) - 5
    SCK(Green) - 14
    MISO(White) - 15
    MOSI(Blue) - 16
    IRQ(Gray) - 2

    Switch - Mega
    Left - RESET
    Right - 3 (inclusion Button)

    LEDs - Mega
    Red(Err) - 40
    Orange(Rx) - 42
    Green(Tx) - 44
    All are grounded with 330 Ohm resistors.

    And here is my Sketch. One thing I had done when I was just getting lots of shutdowns and errors was to wipe the board - I uploaded blink and left it alone for a minute and then reloaded the gateway with the updated libraries and (knocking on wood) it seems to be stable.

    /**
     * The MySensors Arduino library handles the wireless radio link and protocol
     * between your home built sensors/actuators and HA controller of choice.
     * The sensors forms a self healing radio network with optional repeaters. Each
     * repeater and gateway builds a routing tables in EEPROM which keeps track of the
     * network topology allowing messages to be routed to nodes.
     *
     * Created by Henrik Ekblad <henrik.ekblad@mysensors.org>
     * Copyright (C) 2013-2015 Sensnology AB
     * Full contributor list: https://github.com/mysensors/Arduino/graphs/contributors
     *
     * Documentation: http://www.mysensors.org
     * Support Forum: http://forum.mysensors.org
     *
     * This program is free software; you can redistribute it and/or
     * modify it under the terms of the GNU General Public License
     * version 2 as published by the Free Software Foundation.
     *
     *******************************
     *
     * REVISION HISTORY
     * Version 1.0 - Henrik EKblad
     * Contribution by a-lurker and Anticimex,
     * Contribution by Norbert Truchsess <norbert.truchsess@t-online.de>
     * Contribution by Tomas Hozza <thozza@gmail.com>
     *
     *
     * DESCRIPTION
     * The EthernetGateway sends data received from sensors to the ethernet link.
     * The gateway also accepts input on ethernet interface, which is then sent out to the radio network.
     *
     * The GW code is designed for Arduino 328p / 16MHz.  ATmega168 does not have enough memory to run this program.
     *
     * LED purposes:
     * - To use the feature, uncomment MY_DEFAULT_xxx_LED_PIN in the sketch below
     * - RX (green) - blink fast on radio message recieved. In inclusion mode will blink fast only on presentation recieved
     * - TX (yellow) - blink fast on radio message transmitted. In inclusion mode will blink slowly
     * - ERR (red) - fast blink on error during transmission error or recieve crc error
     *
     * See http://www.mysensors.org/build/ethernet_gateway for wiring instructions.
     *
     */
    
    // Enable debug prints to serial monitor
    #define MY_DEBUG
    
    // Enable and select radio type attached
    #define MY_RADIO_RF24
    
    // Enable gateway ethernet module type
    #define MY_GATEWAY_W5100
    
    // W5100 Ethernet module SPI enable (optional if using a shield/module that manages SPI_EN signal)
    //#define MY_W5100_SPI_EN 4
    
    // Enable Soft SPI for NRF radio (note different radio wiring is required)
    // The W5100 ethernet module seems to have a hard time co-operate with
    // radio on the same spi bus.
    #if !defined(MY_W5100_SPI_EN) && !defined(ARDUINO_ARCH_SAMD)
    #define MY_SOFTSPI
    #define MY_SOFT_SPI_SCK_PIN 14
    #define MY_SOFT_SPI_MISO_PIN 16
    #define MY_SOFT_SPI_MOSI_PIN 15
    #endif
    
    // When W5100 is connected we have to move CE/CSN pins for NRF radio
    #ifndef MY_RF24_CE_PIN
    #define MY_RF24_CE_PIN 5
    #endif
    #ifndef MY_RF24_CS_PIN
    #define MY_RF24_CS_PIN 6
    #endif
    
    // Enable UDP communication
    //#define MY_USE_UDP  // If using UDP you need to set MY_CONTROLLER_IP_ADDRESS below
    
    // Enable MY_IP_ADDRESS here if you want a static ip address (no DHCP)
    #define MY_IP_ADDRESS 192,168,1,XXX
    
    // If using static ip you can define Gateway and Subnet address as well
    #define MY_IP_GATEWAY_ADDRESS 192,168,1,XXX
    #define MY_IP_SUBNET_ADDRESS 255,255,255,XXX
    
    // Renewal period if using DHCP
    //#define MY_IP_RENEWAL_INTERVAL 60000
    
    // The port to keep open on node server mode / or port to contact in client mode
    #define MY_PORT 5003//
    
    // Controller ip address. Enables client mode (default is "server" mode).
    // Also enable this if MY_USE_UDP is used and you want sensor data sent somewhere.
    //#define MY_CONTROLLER_IP_ADDRESS 192, 168, 178, 254
    
    // The MAC address can be anything you want but should be unique on your network.
    // Newer boards have a MAC address printed on the underside of the PCB, which you can (optionally) use.
    // Note that most of the Ardunio examples use  "DEAD BEEF FEED" for the MAC address.
    #define MY_MAC_ADDRESS 0xDE, 0xAD, 0xBE, 0xEF, 0xFE, 0xED
    
    // Set LOW transmit power level as default, if you have an amplified NRF-module and
    // power your radio separately with a good regulator you can turn up PA level.
    #define MY_RF24_PA_LEVEL RF24_PA_MAX
    
    // Enable inclusion mode
    #define MY_INCLUSION_MODE_FEATURE
    // Enable Inclusion mode button on gateway
    #define MY_INCLUSION_BUTTON_FEATURE
    // Set inclusion mode duration (in seconds)
    #define MY_INCLUSION_MODE_DURATION 90
    
    // Digital pin used for inclusion mode button
    #define MY_INCLUSION_MODE_BUTTON_PIN  3
    
    // Set blinking period
    #define MY_DEFAULT_LED_BLINK_PERIOD 300
    
    // Inverses the behavior of leds
    #define MY_WITH_LEDS_BLINKING_INVERSE
    
    // Flash leds on rx/tx/err
    // Uncomment to override default HW configurations
    #define MY_DEFAULT_ERR_LED_PIN 40  // Error led pin
    #define MY_DEFAULT_RX_LED_PIN  42  // Receive led pin
    #define MY_DEFAULT_TX_LED_PIN  44  // Transmit led pin
    
    #if defined(MY_USE_UDP)
    #include <EthernetUdp.h>
    #endif
    
    #define MY_SIGNING_SOFT
    #define MY_SIGNING_SOFT_RANDOMSEED_PIN 23
    #define MY_SIGNING_WEAK_SECURITY
    
    #include <Ethernet.h>
    #include <MyConfig.h>
    #include <MySensors.h>
    
    void setup()
    {
        // Setup locally attached sensors
    }
    
    void presentation()
    {
        // Present locally attached sensors here
    }
    
    void loop()
    {
        // Send locally attached sensors data here
    }```

 

339
Online

8.0k
Users

8.8k
Topics

94.4k
Posts