Node sends data only once when battery powered



  • Hi! I built two SI7021 sensor nodes and have a problem with both of them:

    When I power them through the USB port and a FTDI connector (configured to 3.3V) the nodes send data as expected. When I power them using two AA batteries, the nodes connect to the controller only once, but never appear again.

    The nodes are built with the following hardware:

    • Mini Pro 3.3V with power LED and voltage regulator desoldered
    • nrf24l01 radio
    • SI7021 sensor

    Resistors and capacitor for measuring the voltage are not connected yet.

    Any idea what could be the reason? Any hint in some direction?



  • I just measured the voltages and found one main difference:
    The FTDI module powers the sensor with 3.46V whereas the batteries provide only 3.06V. Could this be the reason? But I think this is the intended voltage of the two AA batteries, right? So it should work with this 3.06V, right?

    Another additional note: The LED flashes with every measurement, even when powered by battery. So it looks like the software is working and the arduino gets enough power. Could it be the nrf24l01 chip having troubles?


  • Mod

    @benhub yes it should work with 3.0V. Have you tried different sizes of decoupling capacitors? https://www.mysensors.org/build/connect_radio#connecting-a-decoupling-capacitor

    Next step would be to connect the ftdi without connecting Vcc, so you can see the debug output.



  • Sorry. Forget it. It was just some misunderstanding in the mycontroller UI.
    I just saw that my sensors were in state "NEW" in mycontroller. I had to put it into state "REGISTERED". Don't ask me, why I thought that it worked via USB — I now think, that it never really worked, maybe i read the wrong line and saw another sensor in the list.


 

381
Online

8.0k
Users

8.8k
Topics

94.3k
Posts