Mysensors Build Problem on Ubuntu 20.04 (RPi or Tinker Board)



  • Hi all,
    I have problem compiling Mysensors library on Ubuntu 20.04 image running on RPi 3/4 or Tinker Board.

    Getting the error like:

    ...
    e/Linux/drivers/core -c hal/architecture/Linux/drivers/core/Print.cpp -o build/hal/architecture/Linux/drivers/core/Print.o
    g++ -MT build/hal/architecture/Linux/drivers/core/interrupt.o -MMD -MP -DMY_RADIO_RF24 -DMY_GATEWAY_SERIAL -DMY_DEBUG -DLINUX_SPI_SPIDEV -DMY_LINUX_SERIAL_PORT=\"/dev/ttyUSB01\" -DMY_LINUX_SERIAL_IS_PTY  -Ofast -g -Wall -Wextra -std=c++11 -I. -I./core -I./hal/architecture/Linux/drivers/core -c hal/architecture/Linux/drivers/core/interrupt.cpp -o build/hal/architecture/Linux/drivers/core/interrupt.o
    hal/architecture/Linux/drivers/core/interrupt.cpp:33:10: fatal error: stropts.h: No such file or directory
       33 | #include <stropts.h>
          |          ^~~~~~~~~~~
    compilation terminated.
    make: *** [Makefile:99: build/hal/architecture/Linux/drivers/core/interrupt.o] Error 1
    

    It seems that its missing the <stropts.h> header, but have you any idea how I can resolve that?

    Many thanks

    P.S: I tried on both RPI3 and 4 also on Tinker board and the problem are same for all of them running Ubuntu 20.04.



  • @sghazagh Hi all,
    I tried to create a empty file and it seems that it does work and does not make any problem for the Radio functionality!

    Any idea what this header is and how can I find this genuine library header for future use?

    touch /usr/include/stropts.h
    

  • Mod

    @sghazagh When seraching for this file on google, I come across this hit: https://stackoverflow.com/questions/61029226/how-do-i-install-libraries-for-stropts-h
    It states stropts.h is deprecated, and apparently the gateway doesn't use it, only includes it.
    Could you file a bug report here to remove this include please?


Log in to reply
 

Suggested Topics

179
Online

9.4k
Users

10.0k
Topics

104.4k
Posts