Unable to add node - more than 2



  • Hya,

    i have a esp8266 gateway and had 2 nodes - one with 4 binary sensor (door/window) and one weather station

    Both nodes works very well with the gateway.

    By trying to add a 3rd node, did not work. the 3rd node, a 6 binary sensor (door/window).

    By last resource, i cheared the eeprom of all devices, 3 nodes and the gateway and flashed all again.

    Now, i have 4 binary sensor and 6 binary sensor recognized by the gateway and the weather station not being included.

    Yes, all are using the same radio channel.

    No, no hardware was modified.

    Is there any limitation?

    Any hint of what can be done?

    Thx in advance.


  • Mod

    @pw44 said in Unable to add node - more than 2:

    Yes, all are using the same radio channel.

    All nodes using the same gateway need to use the same channel.

    Is there any limitation?

    Yes. 253 nodes with 254 children each.

    Any hint of what can be done?

    Look at the debug logs from the problematic node and the gateway.



  • @mfalkvidd
    thx for answering.

    all use the same radio channel: 72

    the problematic node was working before.

    original: esp8266 gateway + 4 binarys sensor node + weather station node - all ok, no problem
    by trying to add the 6 binary sensor node, this new node was never added.

    clearead all gw + 3 nodes - eeprom.

    now: esp8266 gateway + 4 binarys sensor node + 6 binary sensor node - all ok, no problem
    the weather station node, which was working before, does not get added.

    seams that by node 3, it gets refused.

    {
        "0": {
            "sensor_id": 0,
            "children": {},
            "type": 18,
            "sketch_name": null,
            "sketch_version": null,
            "battery_level": 0,
            "protocol_version": "2.3.2",
            "heartbeat": 0
        },
        "1": {
            "sensor_id": 1,
            "children": {
                "1": {
                    "id": 1,
                    "type": 0,
                    "description": "",
                    "values": {}
                },
                "2": {
                    "id": 2,
                    "type": 0,
                    "description": "",
                    "values": {}
                },
                "3": {
                    "id": 3,
                    "type": 0,
                    "description": "",
                    "values": {}
                },
                "4": {
                    "id": 4,
                    "type": 0,
                    "description": "",
                    "values": {}
                }
            },
            "type": 18,
            "sketch_name": "Door Window Sns x4",
            "sketch_version": "1.0",
            "battery_level": 0,
            "protocol_version": "2.3.2",
            "heartbeat": 0
        },
        "2": {
            "sensor_id": 2,
            "children": {
                "1": {
                    "id": 1,
                    "type": 0,
                    "description": "",
                    "values": {}
                },
                "2": {
                    "id": 2,
                    "type": 0,
                    "description": "",
                    "values": {}
                },
                "3": {
                    "id": 3,
                    "type": 0,
                    "description": "",
                    "values": {}
                },
                "4": {
                    "id": 4,
                    "type": 0,
                    "description": "",
                    "values": {}
                },
                "5": {
                    "id": 5,
                    "type": 0,
                    "description": "",
                    "values": {}
                },
                "6": {
                    "id": 6,
                    "type": 0,
                    "description": "",
                    "values": {}
                }
            },
            "type": 18,
            "sketch_name": "Door Window Sns x6",
            "sketch_version": "1.0",
            "battery_level": 0,
            "protocol_version": "2.3.2",
            "heartbeat": 0
        }
    }
    


  • @mfalkvidd i really like the concept, but having troubles by trying more than 2 nodes is simply ridiculous.

    I'm not finding out how to solve it.

    i have 3 nodes. all works, but only 2 at a time. clearing the eeproms and flahsing again, it's like the 2 fastest. in any order. but only 2.


  • Mod

    @pw44 the debug logs from the problematic node and the gateway will be essential to troubleshooting



  • @mfalkvidd said in Unable to add node - more than 2:

    which debugs are necessary?

    MY_DEBUG or MY_DEBUG and MY_DEBUG_VERBOSE_RF24?


  • Mod


Log in to reply
 

Suggested Topics

  • 20
  • 3
  • 20
  • 23
  • 8
  • 10
  • 2
  • 15

1
Online

10.3k
Users

10.7k
Topics

109.5k
Posts