ESP8266 Gateway - loosing messages ?



  • After trying many versions, compiling errors,... i finally installed a portable Version of Arduino IDE 1.6.6
    I installed ESP Core 2.0.0 and copied the Dev branch of MySensors.

    Now it looks like the Gateway is loosing / not receiving messages from the sensors, i guess about 50 percent

    DId anybodo successfully instal the ESP8266-Gateway from Developer Branch ?

    I know Developer means not stable, but any hints where to look for my problem ?
    THe other versions, as said, i always got compiling errors




  • Mod

    @kr0815 said:

    ESP Core 2.0.0

    I wasn't even aware they already reached 2.0 for the Core!
    You could give 1.6.5 a try (http://arduino.esp8266.com/versions/1.6.5-947-g39819f0/package_esp8266com_index.json) and see if things improve.
    This is the version (in combination with Arduino 1.6.5) which I used to develop ESP8266 support.

    @robosensor Let's not jump to conclusions!



  • Hello Yveaux,

    thanks for your fast response.

    I don´t thiink the esp is to slow, watched it on my workbench, if a sensor is sending each 30 seconds, i get every second message, very strange...

    I will try to go back to 1.6.5, had 2.0.0 only because of also playing with the espeasy project.
    But the developer code here should be working ?

    Another strange thing now, i tried it now with an ESP8266-201, uploading is ok, but after boot i get

    0;0;3;0;9;Radio init successful.
    ...........................................................
    

    and the dots go on and on, what does the code expect ? finding the wifi now ?



  • So i went back to the 1.6.5, did another portable installation of arduino IDE, downloaded everything exactly as described in the "buld"-Section

    Gateway is running now, but as soon as i try to connect in FHEM, i get

    Exception (28):
    epc1=0x4000bf80 epc2=0x00000000 epc3=0x00000000 excvaddr=0x00000000 depc=0x00000000
    
    ctx: cont 
    sp: 3ffeaca0 end: 3ffeaf20 offset: 01a0
    
    >>>stack>>>
    3ffeae40:  3fffdab0 00080000 3ffe97c7 40203ac0  
    3ffeae50:  3ffeaf80 00000001 3ffe8fc9 4020b73c  
    3ffeae60:  3ffeaf80 00000009 3ffe98bd 00000000  
    3ffeae70:  00000003 00000000 3ffe98a8 4020ae11  
    3ffeae80:  00000001 3ffe98b4 3ffeaf80 4020ae11  
    3ffeae90:  3ffe98b4 3ffe98b4 3ffeaf80 3ffeaf80  
    3ffeaea0:  3ffe98b4 3ffe97c0 3ffe97c7 402024b4  
    3ffeaeb0:  3ffe9ab8 3ffe98b4 00000000 40202784  
    3ffeaec0:  3ffe8e48 00000000 000003e8 3ffe9c4c  
    3ffeaed0:  00000000 3fff4c88 3fff4c18 3ffeaf4c  
    3ffeaee0:  00000000 0000000a 00000000 00000000  
    3ffeaef0:  40201c35 4db2a8c0 00000000 3ffeaf4c  
    3ffeaf00:  3fffdc20 00000000 3ffeaf44 40201c92  
    3ffeaf10:  00000000 00000000 3ffe9f00 40100378  
    <<<stack<<<
    
     ets Jan  8 2013,rst cause:2, boot mode:(3,0)
    
    load 0x4010f000, len 1264, room 16 
    tail 0
    chksum 0x42
    csum 0x42
    ~ld
    
    
    ESP8266 MySensors Gateway
    Connecting to Power-LAN
    .....Connected!
    IP: 192.168.178.77
    0;0;3;0;9;gateway started, id=0, parent=0, distance=0
    0;0;3;0;9;read: 255-255-0 s=255,c=3,t=3,pt=0,l=0,sg=0:
    255;255;3;0;3;
    0;0;3;0;9;read: 255-255-0 s=255,c=3,t=3,pt=0,l=0,sg=0:
    255;255;3;0;3;
    


  • I investigated further - the developer version still only gets some messages, seems like radio reception is partly not working ?

    The old / stable version crashes not when going to inclusion mode, but after initiating inclusion mode, then when the first node sends something.

    I tried to use different power sources - didn´t change anything :-(

    Tried even the MQTT Gateway - can´t get in into iclusion mode ?
    (i uncommented the inclusion part, connected a switch , should there be any debug message when hitting that switch ? )

    THE ESP is node a NodeMCU, but another chinese developer Board, but it runs fine with EasyESP, so i don´t think that is the cause

    I have other gateways running and at the moment, all are at the same channel, but i can´t think this is the cause for a reset of the ESP ?


  • Mod

    @kr0815 said:

    other gateways running and at the moment, all are at the same channel

    Do they also use the same MySensors base ID? There shall be only one gateway for each base ID/channel combination!

    Other people reported crashes on ESP8266 vanished when switching nRF24 radios. Did you give that a try?



  • At the moment they use same Channel and base ID, as it´s, i have to confess, very complicated to change them each time in the file and to recompile everything.

    But i will try tomorrow to give them different ID´s / Channels.

    WHat confuses me even more, and i don´t expect to get help here, but as i use FHEM, i saw, that ID´s i deleted in the past were reasigned to new sensors, with some values from the old / deleted ones, maybe that´s already where the problems start....
    I think the easiest for me would be to Switch either to the developer Version- as said it´s ot receiving all Messages, or use the MQTT Gateway, but how to get it in inclusion mode ? Do i understand it right that the MQTT ESP Gateway will handle the allowed childs by itself and broadcast the Messages of only These childs to the MQTT Broker ?


Log in to reply
 

Looks like your connection to MySensors Forum was lost, please wait while we try to reconnect.