MySensors Library



  • Hi Guys,

    I am struggling to import the MySensors library into Arduino IDE. I have spent the last two days googling and trying things to no avail. I am running Ubuntu 16.04.

    I have the Arduino IDE installed ant it is functional. I can upload one of the example codes to a Arduino MicroController and it works. I can even see the MySensors Library under sketchbook. The problem arises when i try and use any of the codes bundled in the MySensors library. When I try and verify the code I get the following error...

    Arduino: 1.6.9 (Linux), Board: "Arduino Nano, ATmega328"

    /home/dane/sketchbook/Arduino-master/libraries/MySensors/examples/HumiditySensor/HumiditySensor.ino:31:24: fatal error: MySensor.h: No such file or directory
    #include <MySensor.h>
    ^
    compilation terminated.
    exit status 1
    Error compiling for board Arduino Nano.

    Any help would be GREATLY appreciated.


  • Admin

    You need the library folder of the mysensors project installed in ~/Arduino/library, then everything should be ok.



  • So first I tried placing the entire folder in ~/Arduino. No luck there. Then left that folder where it was and copied the Libraries folder from Arduino-Master into ~/Arduino/Libraries. No luck. Nothing was showing up under sketchbook either.

    I then placed the Arduino-Master in ~/sketchbook and that allowed me to see the library in the Arduino IDE but I still get the same error. I then copied the Library folder from Arduino-Master into ~/sketchbook/libraries and still came out with the same error. Im considering doing a fresh Arduino IDE install.

    Running Arduino IDE version 1.6.9 with the newest MySensors Library and Ubuntu 16.04



  • @tbowmo I deleted all the files and reinstalled the Arduino IDE. Placed the library as you said and everything works! Thanks and sorry for the inconvenience!


  • Mod

    Great work @Ddawme, thanks for reporting back


 

369
Online

7.8k
Users

8.7k
Topics

93.0k
Posts