Including new sensor problem



  • Sorry, but I`m a newbie of this. What do I do wrong?

    I made a new BinarySwitchSleep sensor that I trying to include to my Vera. I go to My Sensors plugin and start the including but right away it says "0 devices found".

    Could someone please explain exactly how this process should be done.

    I saw on the site about it and found this "Start inclusion mode on the Arduino Vera device by pressing the "Start" button. Inclusion mode is normally active for 1 minute."

    What start button???


  • Hardware Contributor

    @miro - Hello!
    When you are building a gateway you can add a "Inclusion mode button"
    See here: https://www.mysensors.org/build/advanced_gateway

    Im not sure about Vera, but my guess it should work without and/or you can manually start inclusion mode from vera GUI.



  • Now when I trying to verify the BinarySwitchSleepSensor sketch it says "Error compiling for board Arduino Pro or Pro Mini."

    Strange?


  • Hardware Contributor

    @miro - then you have made a coding error. Maybe a typo somewhere.



  • Then I think there is a bug on this sketch. Because I just downloaded the new version and tried to upload.


  • Hardware Contributor

    @miro - maybe you should upload the code and error message and im sure we can help you out.



  • Sorry for late answer

    /**
     * The MySensors Arduino library handles the wireless radio link and protocol
     * between your home built sensors/actuators and HA controller of choice.
     * The sensors forms a self healing radio network with optional repeaters. Each
     * repeater and gateway builds a routing tables in EEPROM which keeps track of the
     * network topology allowing messages to be routed to nodes.
     *
     * Created by Henrik Ekblad <henrik.ekblad@mysensors.org>
     * Copyright (C) 2013-2015 Sensnology AB
     * Full contributor list: https://github.com/mysensors/Arduino/graphs/contributors
     *
     * Documentation: http://www.mysensors.org
     * Support Forum: http://forum.mysensors.org
     *
     * This program is free software; you can redistribute it and/or
     * modify it under the terms of the GNU General Public License
     * version 2 as published by the Free Software Foundation.
     *
     *******************************
     *
     * DESCRIPTION
     *
     * Interrupt driven binary switch example with dual interrupts
     * Author: Patrick 'Anticimex' Fallberg
     * Connect one button or door/window reed switch between 
     * digitial I/O pin 3 (BUTTON_PIN below) and GND and the other
     * one in similar fashion on digital I/O pin 2.
     * This example is designed to fit Arduino Nano/Pro Mini
     * 
     */
    
    
    // Enable debug prints to serial monitor
    #define MY_DEBUG 
    
    // Enable and select radio type attached
    #define MY_RADIO_NRF24
    //#define MY_RADIO_RFM69
    
    #include <SPI.h>
    #include <MySensors.h>
    
    #define SKETCH_NAME "Binary Sensor"
    #define SKETCH_MAJOR_VER "1"
    #define SKETCH_MINOR_VER "0"
    
    #define PRIMARY_CHILD_ID 3
    #define SECONDARY_CHILD_ID 4
    
    #define PRIMARY_BUTTON_PIN 2   // Arduino Digital I/O pin for button/reed switch
    #define SECONDARY_BUTTON_PIN 3 // Arduino Digital I/O pin for button/reed switch
    
    #if (PRIMARY_BUTTON_PIN < 2 || PRIMARY_BUTTON_PIN > 3)
    #error PRIMARY_BUTTON_PIN must be either 2 or 3 for interrupts to work
    #endif
    #if (SECONDARY_BUTTON_PIN < 2 || SECONDARY_BUTTON_PIN > 3)
    #error SECONDARY_BUTTON_PIN must be either 2 or 3 for interrupts to work
    #endif
    #if (PRIMARY_BUTTON_PIN == SECONDARY_BUTTON_PIN)
    #error PRIMARY_BUTTON_PIN and BUTTON_PIN2 cannot be the same
    #endif
    #if (PRIMARY_CHILD_ID == SECONDARY_CHILD_ID)
    #error PRIMARY_CHILD_ID and SECONDARY_CHILD_ID cannot be the same
    #endif
     
    
    // Change to V_LIGHT if you use S_LIGHT in presentation below
    MyMessage msg(PRIMARY_CHILD_ID, V_TRIPPED);
    MyMessage msg2(SECONDARY_CHILD_ID, V_TRIPPED);
    
    void setup()  
    {  
      // Setup the buttons
      pinMode(PRIMARY_BUTTON_PIN, INPUT);
      pinMode(SECONDARY_BUTTON_PIN, INPUT);
    
      // Activate internal pull-ups
      digitalWrite(PRIMARY_BUTTON_PIN, HIGH);
      digitalWrite(SECONDARY_BUTTON_PIN, HIGH);
    }
    
    void presentation() {
      // Send the sketch version information to the gateway and Controller
      sendSketchInfo(SKETCH_NAME, SKETCH_MAJOR_VER "." SKETCH_MINOR_VER);
    
      // Register binary input sensor to sensor_node (they will be created as child devices)
      // You can use S_DOOR, S_MOTION or S_LIGHT here depending on your usage. 
      // If S_LIGHT is used, remember to update variable type you send in. See "msg" above.
      present(PRIMARY_CHILD_ID, S_DOOR);  
      present(SECONDARY_CHILD_ID, S_DOOR);  
    }
    
    // Loop will iterate on changes on the BUTTON_PINs
    void loop() 
    {
      uint8_t value;
      static uint8_t sentValue=2;
      static uint8_t sentValue2=2;
    
      // Short delay to allow buttons to properly settle
      sleep(5);
      
      value = digitalRead(PRIMARY_BUTTON_PIN);
      
      if (value != sentValue) {
         // Value has changed from last transmission, send the updated value
         send(msg.set(value==HIGH ? 1 : 0));
         sentValue = value;
      }
    
      value = digitalRead(SECONDARY_BUTTON_PIN);
      
      if (value != sentValue2) {
         // Value has changed from last transmission, send the updated value
         send(msg2.set(value==HIGH ? 1 : 0));
         sentValue2 = value;
      }
    
      // Sleep until something happens with the sensor
      sleep(PRIMARY_BUTTON_PIN-2, CHANGE, SECONDARY_BUTTON_PIN-2, CHANGE, 0);
    } 
    

    And error message

    Arduino:1.6.11 (Windows 10), Kort:"Arduino Pro or Pro Mini, ATmega328 (3.3V, 8 MHz)"

    C:\Program Files (x86)\Arduino\libraries\MySensors\examples\BinarySwitchSleepSensor\BinarySwitchSleepSensor.ino:41:23: fatal error: MySensors.h: No such file or directory

    #include <MySensors.h>

                       ^
    

    compilation terminated.

    exit status 1
    Error compiling for board Arduino Pro or Pro Mini.

    This report would have more information with
    "Show verbose output during compilation"
    option enabled in File -> Preferences.


  • Mod

    @miro seems like the Arduino IDE is unable to find the MySensors library. How did you install the library? Which version did you install?

    Instructions for installing the library are available at https://www.mysensors.org/about/arduino#installing-the-sensor-libraries if you need them.



  • @mfalkvidd You were right. My mistake.

    Now there is a new error message when try to upload the scetch. Any ideas?

    Using Port                    : COM6
    Using Programmer              : arduino
    Overriding Baud Rate          : 57600
    
    avrdude: stk500_getsync() attempt 1 of 10: not in sync: resp=0x6a
    avrdude: stk500_getsync() attempt 2 of 10: not in sync: resp=0x15
    avrdude: stk500_getsync() attempt 3 of 10: not in sync: resp=0x44
    avrdude: stk500_getsync() attempt 4 of 10: not in sync: resp=0x12
    avrdude: stk500_getsync() attempt 5 of 10: not in sync: resp=0x61
    avrdude: stk500_getsync() attempt 6 of 10: not in sync: resp=0xaa
    avrdude: stk500_getsync() attempt 7 of 10: not in sync: resp=0x6c
    avrdude: stk500_getsync() attempt 8 of 10: not in sync: resp=0xef
    avrdude: stk500_getsync() attempt 9 of 10: not in sync: resp=0x38
    avrdude: stk500_getsync() attempt 10 of 10: not in sync: resp=0x50
    
    avrdude done.  Thank you.
    
    An error occurred while uploading the sketch```

  • Hardware Contributor

    @miro - check your connection/wiring from the programmer to your board.



  • There was something wrong on the sensor so I made a new one. Now it looks ok in the serial monitor "I THINK"?

    But I still can`t get it included in Vera Edge UI7?

    I did a test with the button that was written here before, but that function I have in Vera so not nessecary.
    (When I activated the button on pin 3, it activated the vera UI button)

    When I click on START to include the sensor it just says "0 devices found" and nothing happends. What is the problem?
    Now I have no clue.

    Starting sensor (RNNNA-, 2.0.0)
    TSM:INIT
    TSM:RADIO:OK
    TSP:ASSIGNID:OK (ID=1)
    TSM:FPAR
    TSP:MSG:SEND 1-1-255-255 s=255,c=3,t=7,pt=0,l=0,sg=0,ft=0,st=bc:
    TSP:MSG:READ 0-0-1 s=255,c=3,t=8,pt=1,l=1,sg=0:0
    TSP:MSG:FPAR RES (ID=0, dist=0)
    TSP:MSG:PAR OK (ID=0, dist=1)
    TSM:FPAR:OK
    TSM:ID
    TSM:CHKID:OK (ID=1)
    TSM:UPL
    TSP:PING:SEND (dest=0)
    TSP:MSG:SEND 1-1-0-0 s=255,c=3,t=24,pt=1,l=1,sg=0,ft=0,st=ok:1
    


  • I tried to include a different motion sensor and that workt on the first try. This is strange.



  • The only thing I changed in parts is that I use a NRF24L01+ with antenna. But I don`t think I need to change anything in the code for that?

    And I use a Arduino Pro mini 3.3V with two AA Batteries.


 

407
Online

7.8k
Users

8.7k
Topics

92.9k
Posts