Problem with RFM69 on Arduino nano...



  • Hi all,

    Since this is my first post I would like to congratulate all mysensors community for the fantastic work.

    I've been running some prototypes of sensor nodes using standalone ESP8266 as node/gateway with no major problems.
    But now, I've ordered some RFM69 modules to start building a sensor network and I'm having trouble getting mysensors to work in a particular combination: Arduino Nano and RFM69HCW (Adafruit 5v safe breakout).

    Using test sketches from the RFM69 library everything works fine (on the other end I have an 3.3v arduino pro mini with a RFM69 module) but from mysensors I only get this output:

    0;255;3;0;9;MCO:BGN:INIT GW,CP=RRNGA--,VER=2.0.1-beta
    0;255;3;0;9;TSM:INIT
    0;255;3;0;9;!TSM:INIT:TSP FAIL
    0;255;3;0;9;TSM:FAIL:CNT=1
    0;255;3;0;9;TSM:FAIL:PDT
    0;255;3;0;9;TSM:FAIL:RE-INIT
    0;255;3;0;9;TSM:INIT

    I've tried to replace the default RFM69 driver with the version from LowPower Labs with no success.

    The strange is that the very same code uploaded to an arduino pro mini works fine.

    What can it be?


  • Hardware Contributor

    @fcflopes - Power?



  • I also suspected that so I've powered the module from another power supply (and connected all the grounds).

    Still the same result.

    I still can't figure is why this only happens with MySensors... Test sketches run ok...


  • Hardware Contributor

    @fcflopes - ok, sorry im not into RFM but maybe @scalz know more?



  • @fcflopes did you ever figure this one out? I'm having the same problem on an UNO.
    I'm using a RFM69HCW from Adafruit, which works fine with the Radiohead/Adafruit test lib but I only get TSP FAIL when using a mysensor serial GW sketch.



  • If the message says: TSP FAIL there is no communication between your Arduino and the RFM, you need to check your wires, which is strange as you have success with that other lib. Have you commented the right #defines before the include <mysensors.h>?



  • @DavidZH
    I finally figured it out, after some forum digging. Check https://forum.mysensors.org/topic/5806/solved-adafruit-rfm69hcw-breakout-doesnt-respond.

    These things should be sticky'ed somewhere, would have saved me a lot of time ;-)



  • Ah! I never thought of that. Nice to see it's solved! And I think you're right, this kind of info should be made available for easy access.


Log in to reply
 

Looks like your connection to MySensors Forum was lost, please wait while we try to reconnect.