[Beginner] WS2811 lights just doesn't light up normally



  • Hi! Just bought WS2811 type strip of lights http://ebay.to/2icZpfa and started using FastLed with Arduino Mega to get them working. I wrote a simple script for it http://pastebin.com/RmMqKcgn . However, after connecting them, nothing lights up. But if I touch the ground wire at the end of lights with the data wire at the beginning of the lights, the lights will go crazy and after separating those wires the lights light up as it should be (not all though, few of them are different color, but hey, its something!). What do I do wrong? Maybe I should connect some resistor to the data pin? Or maybe I just got broken lights?
    Also I checked with multimeter the begining and the end of the wire. On power and ground cords there is only 1ohm, while data wire has 900ohm resistance. Not sure if it should be like it, so just pointing it out.
    P.S. Sorry if I posted in the wrong forum. I'm so desperately looking for any help, because I need to get them running until New Year. :smile:


  • Mod

    @Mantvydas-Ri 1ohm on power and gnd is normal. Not sure about data, but 900 sounds reasonable.

    Maybe the connections on the strip are mislabeled? The chinese stuff isn't always correct :)

    Except that, I can't think of anything that should cause this behavior. The Adafruit Überguide is a great resource, maybe read it and see if you can spot anything?



  • Reversed wiring (connected 5v and ground at the end of strip) and connected BOTH sides data wire (the one from beginning and one at the end). Don't know why, but it started working now. Any ideas now? :laughing:


  • Mod

    @Mantvydas-Ri Interesting :) Could you post photos of both ends of the strip?



  • The ends looked like this http://www.ipix.lt/image/6kFGp but I cut them off because of huge interference (The lights worked after disconnecting 5v pin :smiley: - probably data pin was colliding with 5v or something ). Now there are just plain wires.

    I feel so dumb because I don't even know how and why this happens.
    For example sometimes lights just works by simply connecting those pins as they should be, sometimes the lights just blinking randomly, sometimes nothing happens, but this often can get fixed if I attach both ends of data pin to arduino (and sometimes not). :confused:

    Feeling like I have bought defected strip or just don't have enough brains to connect it :laughing:


  • Mod

    @Mantvydas-Ri sorry I meant the strip itself, to see the markings for the connectors. Like this:
    0_1483108219158_leds.png
    (not that this image is from a different type of strip though)



  • Every pixel looks like this http://www.ipix.lt/image/6kzdh and the other side like this http://www.ipix.lt/image/6kBSl. Don't know if you can see here, but there is written "+" , "DI" (data input probably), and "GND", so I guess contacts are marked correctly.


  • Mod

    @Mantvydas-Ri can't see the markings but I don't see anything strange so they are probably fine.

    How are you powering the strips? Is gnd on the power source connected to gnd on the Mega?


  • Mod

    @mfalkvidd said:

    How are you powering the strips?

    Good question :+1:

    @Mantvydas-Ri How many LEDs are you trying to control?
    Each LED consumes 0.3W (60mA) according to the link in the 1st post, so a strand of 50 consumes 3A at maximum brightness.

    That's far too much for the 5V supply of the Arduino Mega, so try powering the LEDs from a separate, beefy (min. 4 Amps) power supply, or test with a much shorter strand (e.g. start with 1 LED only).



  • Tried external power supply, same problem as on Arduino mega. I have also decreased brightness of the bulbs to ensure this is not an issue.
    Also, as I said, connecting both ends of data pin most likely solves the problem, but it is a little impractical.



  • But I will try it again anyway- maybe this time i'll be lucky



  • Alright, tested it with 10A 5V power supply. But now lights doesn't work at all. Even from battery it works, but not from the external power supply.
    And yes, I have checked that power supply is working with multimeter.
    Weird..



  • Btw is it normal that after removing GND wire lights are still glowing? :laughing:


  • Mod

    @Mantvydas-Ri Might be. Data line serves as gnd. But don't operate them like that, things might break!


Log in to reply
 

Looks like your connection to MySensors Forum was lost, please wait while we try to reconnect.