Multiple gateways in domoticz



  • Hi.
    I have an issue with two gateways in my mysensors network.

    I thought that the the controller (domoticz) toke care of the node numbers and that is all so knew what node number was on with gate way.
    Now it turns out that this is not the case.
    it is more like the gateway giving the node number.

    I programmed a node in side the house in the office and there it got a node number from the "inside" gateway, placing it outside in the green house it now got a new node number, and there by "losing" its connection to the sensor idx in domoticz.

    I also have a node in the utility room, that some times get connection the the "outside" gateway.

    is there a way of setting the node number globally and then i does not matter with gateway the node connect to?
    or am i missing something here?

    some help and comments are very welcome.


  • Mod

    @mhko the solution is to use different channels for the gateways. If nodes can become connected to more than one gateway the whole system will be confused (as you have noticed).

    How to set change the channel depends on which transport you are using. Look for the channel setting in MyConfig.h. All nodes in one network need to use the same channel.



  • thank you for your answer.
    is one channel differences enough?


  • Mod

    @mhko I haven't tried it but one channel difference should be enogh.



  • okay thank you again.
    I tried to change form channel 76 to 86 that did not do a difference.
    now i will try with channel 124.


Log in to reply
 

Looks like your connection to MySensors Forum was lost, please wait while we try to reconnect.