Problem to program pro mini

  • I have purchased some pro mini 5V and an USB to TTL programmer, from china.
    I have connect them occording to the following:
    Programmer Pro mini

    Arduino IDE 1.8.0
    Board: "Arduino pro or pro mini"
    Processor: "ATmega328 (5V 16MHz)"
    Port: "COM6"
    Programmer: "AVRISP mk II"

    When I try to upload the sketch "Blink" I got the following message:
    avrude: verification error, content mismatch
    0xff != 0x0c
    avrude: verification error, content mismatch
    avrude: verification error; content mismatch

    Anyone who can tell me what the error is?

  • Mod

    Have you tried latest ide and boards definitions?

  • Hardware Contributor


    it looks like a serial communication problem to me, are you sure you have no problem with the DTR connexion ?
    While the sketch compile, press the reset button on the pro mini, and just when it says it's starting to transfer, release it. If it works like that it means the DTR signal is wrong and not doing a reset on your board. But cable/jumper, adapter or arduino board problem, I don't know.
    Make sure also you have selected the right voltage on the USB to TTL adapter, if it's on 3.3V the atmega will not run.

  • I have updated ide to 1.8.3 but the result is the same. Find no way to update boards difinations.
    I missed one row in the error message which I think is important:
    "avrdude: stk500_recv(): programmer is not responding"

  • Mod

    maybe bad FTDI adapter?

  • Hardware Contributor

    Or a bad bootloader?

  • The problem is partially resolved, the first Pro mini is wrong in any way.
    Tried another Pro mini and it worked.
    Before I switched the minis, I searched the Arduino forum and found this topic on how to test a serial adapter and according to this test the FTDI adapter was ok.

    After switching to Ide 1.8.3 and even when I switch back to 1.8.0 and I choose sketch, include library, manage library I get the following error message:
    Index error: could not find referenced tool name=gcc-arm-none-eabi version=5_2-2015q4 packager=sandeepmistry
    Index error: could not find referenced tool name=openocd version=0.10.0-dev.nrf5 packager=sandeepmistry

    Is there something to care about?

  • Hardware Contributor

    You're trying to program using the wrong programmer maybe ?
    Select back Avr ISP mk2

  • I have programmed 3 more boards with the first settings and it worked well.
    What I understood, only the choice of programmers is used when burning bootloaders, is this correct?

  • @sundberg84
    I read in another topic your reference to on how to burn a bootloader.
    Is this an opportunity to get the wrong card to work?
    Do you know if the capacitor mentioned in the reference is needed for a Pro Mini?

  • Hardware Contributor

    @MagnusF - if the error is a bad bootloader, but that is rarely the case... I have seen that once. It will not hurt though to re-upload the bootloader if you suspect thats the problem.

Log in to reply

Suggested Topics

  • 3
  • 2
  • 15
  • 24
  • 2
  • 2