Gateway spamming Domoticz log file



  • Hi

    I have been running Domoticz for about 6 months.
    I am running a Rpi3, mys Serial gateway (USB) original sketch and RFlink gateway (USB)
    Recently the log file is showing the following entries:

    2017-09-14 08:40:22.230 MySensors: Gateway Version: 2.1.1
    2017-09-14 08:40:24.215 MySensors: Gateway Ready...
    2017-09-14 08:40:24.291 MySensors: Gateway Version: 2.1.1
    2017-09-14 08:40:26.234 MySensors: Gateway Ready...
    2017-09-14 08:40:26.309 MySensors: Gateway Version: 2.1.1
    2017-09-14 08:40:27.557 MySensors: Gateway Ready...
    2017-09-14 08:40:27.632 MySensors: Gateway Version: 2.1.1
    2017-09-14 08:40:30.428 MySensors: Gateway Ready...
    2017-09-14 08:40:30.504 MySensors: Gateway Version: 2.1.1
    2017-09-14 08:40:32.329 MySensors: Gateway Ready...

    etc etc ...

    To me It looks like the Mys Serial gateway is constantly rebooting, but it is not.

    Any ideas?

    /John


  • Mod

    Välkommen to the MySensors community @John-Mälarström

    Is this from /var/log/domoticz.log ?
    Which version of Domoticz are you using?
    What is your "Data Timeout" setting for the gateway? (Setup->Hardware->Click on your gateway and look at the settings beneath the gateway list)

    I am using Domoticz 3.8153 with two MySensors 2 ethernet gateways and one MySensors 1 USB gateway and I don't get these messages.



  • @mfalkvidd

    Hi I cannot see that I have a file called domoticz.log in /var/log.
    I am still at version 3.5877, to chicken to upgrade...
    The data timeout is set to disabled. Is it better to put a value?


  • Hardware Contributor

    @John-Mälarström - I have data timout to disabled which I think is correct.

    Are you sure the GW isnt rebooting? If you have a rebooting GW my guess would be a power issue.
    If not, maybe try another usb cable?



  • @sundberg84

    Hi
    I change the usb cable and are now supplying the Arduino Uno Rev3 with external 12v, 2A
    Unfortunately that did not help. If the gateway keeps rebooting, shouldent my sensors loose the connection and the ability to function and not update values in Domoticz?
    When I manually reboot the gateway I can see the power led go on and off and when it is ready,
    only the tx/rx led has activity.



  • Hi

    Yesterday I noticed that the log was "normal again". I can not tell if it has to do with the addition of power supply or changing the usb cable or something else. Thank you guys for all help.

    /John



  • Update... Solved!

    Again I got the entry:
    2017-09-14 08:40:22.230 MySensors: Gateway Version: 2.1.1
    2017-09-14 08:40:24.215 MySensors: Gateway Ready...
    in the log.

    I found that I had a broken sensor. When checking the sketch for this sensor
    i noticed that I had enabled repeater function. After removing this faulty sensor, there are no more
    spamming in the Domoticz log file.



  • @John-Mälarström I hit the same a while back. I had to disable all acks on my network to solve it on 2.1.1 - worked ok previously. I opened a thread about it here somewhere. Sounds like repeater/ack related.



  • Dear all,
    I encoutered te same issue with my USB Gateway.
    I'm now powering it with an external 7.2V supply (VIN/GND), but still the same log list as mentionned up.
    Any idea ?

    Thanks.

    //EDIT//
    I've build on a bredboard a new one with other component. When power on, the Gateway reboot (I can see that in Domoticz). could it be a Sensor problem ?
    2017-10-03 20:35:36.864 MySensors: Gateway Ready...
    2017-10-03 20:35:36.939 MySensors: Gateway Version: 2.1.0


Log in to reply
 

Looks like your connection to MySensors Forum was lost, please wait while we try to reconnect.