Just cant get PiDome to work.



  • I am having the worst time trying to figurer out how to get PiDome working with my sensors. I have a sensor on a 3.3v Arduino Mini Pro (from sparkfun) and I have tried a serial gateway on both a Mini Pro as well as a Leonardo.

    I have tried to first watch to make sure that data is coming from my sensor to the gateway. I monitor the serial output from the gateway and I get the below (after I restart my sensor node)

    0;0;3;0;14;Gateway startup complete.
    0;0;3;0;9;read: 255-255-0 s=255,c=3,t=3,pt=0,l=0:
    255;255;3;0;3;
    0;0;3;0;9;read: 255-255-0 s=255,c=3,t=3,pt=0,l=0:
    255;255;3;0;3;
    0;0;3;0;9;read: 255-255-0 s=255,c=3,t=3,pt=0,l=0:
    255;255;3;0;3;
    0;0;3;0;9;read: 255-255-0 s=255,c=3,t=3,pt=0,l=0:
    255;255;3;0;3;
    0;0;3;0;9;read: 255-255-0 s=255,c=3,t=3,pt=0,l=0:
    255;255;3;0;3;
    0;0;3;0;9;read: 255-255-0 s=255,c=3,t=3,pt=0,l=0:
    255;255;3;0;3;
    0;0;3;0;9;read: 255-255-0 s=255,c=3,t=3,pt=0,l=0:
    255;255;3;0;3;

    so after that, I plug the gateway to the Raspberry Pi, I add it to a peripheral without problems.
    peripheral.PNG

    after that, I made that discovery was enabled.
    discovery.PNG

    I have then look at the drivers to see if there are any nodes discovered but nothing. and I don't see any logs
    drivers.PNG

    now, this all might be because I am just a nube to all of this and just don't know how to sue PiDome. I am basically using a Dallas Temperature sensor and trying to monitor temperature for this first project.

    Any help (screen shots, etc) would be greatly appreciated.

    regards,

    brian


  • Plugin Developer

    @dafoink
    sueing would be a bit harsh?

    It looks like you are doing everything the right way. It looks like there is no response from the gateway when PiDome requests the version number of the software running on the gateway. This should appear right behind the "Version:" label. As long there is no version mentioned the driver does not respond to any data coming in.

    A couple of things to check:

    • Be sure to use the correct baud rate, correct data and stop bits. If these are wring the data can not be interpreted.
    • Is the Arduino Pro mini an original one? I have seen cases where non originals do not work as expected on the pi.

    When the above have passed the test. Could you please do the following for me:

    • Remove the peripheral from the list,
    • shutdown the server,
    • start the server with "./server.sh trace" (You probably have to a "chmod 755 server.sh" first).
    • Follow the steps as you already did, because i do not see any wrong,
    • Start the discovery
    • remove the power from the sensor, and start it (to make sure it sends out a request for an id.
    • let the discovery run for a minute or so.
    • disable trace logging by going to "Server settings" > disable debug (trace is a "hidden feature" providing a bunch of info and possible to disabled as debugging is).
    • send the file logs/systems/appLog.txt to support@pidome.org. with a reference to this post.

    I'm still working hard on this system, and logging and improving messaging about attached components is still worked on.

    Cheers!



  • @John thanks. I will try this this afternoon. NOTE: all of the arduino's are from sparkfun.com. so, they are pretty reliable.

    on Suing? I didn't do a typo saying about suing did I? 🙂 I didn't meant to if I did. You provide awesome support.

    I will check this out this afternoon. I am excited about PiDome. I have a hydroponics garden in my back yard, and this could be a pretty cool thing for monitoring and controlling

    I will update once I follow your instructions. thanks.....


  • Plugin Developer

    @dafoink It certainly will be a new level for support though, I understood it was a typo 😉

    Make sure to mention this thread, it will make it a lot quicker for me, and you won't have to retype everything.



  • I did a quick change of the connection settings for the serial and changed it to N,8,1 @ baud=115200. But now I am getting a check wires. which at least is an error that I can see. Thoughts on this? could this be a problem with my FTDI controller? I am using a spark fun FTDI Basic controller. perhaps that is my problem now?

    I haven't turned on the trace yet. I will do that later today. Below is what I see in the Drivers view:

    Last known messages
    Below is a list of last known 20 messages
    11-01-2015 14:43:59
    0;0;3;0;9;check wires


    Update:
    I switched out arduinos to one with a built in ftdi an and now I see the sensor, but get this in my logs.

    Below is a list of last known 20 messages

    11-01-2015 15:20:21
    :
    Trying assigning address '1' to a new node

    11-01-2015 15:18:12
    :
    Trying assigning address '1' to a new node


  • Admin

    @dafoink

    The "check wires" message is the arduino's way of saying it can't find the radio module. So check all the wires between the arduino and radio.


  • Plugin Developer

    @dafoink I personally had run the MySensors gateway on 57600 (currently my pro's are used for other purposes in a live environment, i could otherwise test).

    Trying to assign node id one means it sends the command to the sensor to assign the node id. When you restart the sensor, do you see this one appear with node id 1?

    The reason why it says "trying" is because the response to node assignment could be a fail message even when it is not.

    P.S. sorry for the late response, it was getting late yesterday.



  • Thanks for the support so far. I noticed that you were up late yesterday for your timezone.

    ok. I have been playing with this for a few hours and I it seems that I am now getting reads from the sensor.

    in case this doesn't link, this is reference to this thread: http://forum.mysensors.org/topic/810/just-cant-get-pidome-to-work/7

    sensorworks.PNG

    but, I think what might have been happening is I get a lot of the below error after updating data. What I have been doing is hitting the cancel X on the error popup instead of hitting ok a bunch of times (the error popup keeps popping up). and from there, maybe I was causing the code to halt at that error point instead of running past it.

    not sure what is causing that error.

    error.PNG

    one other question, will PiDome run on windows?



  • @dafoink said:

    one other question, will PiDome run on windows?

    Yes it will if you have a JRE installed.


  • Admin

    @dafoink

    I reported the "Object doesn't support" error a while back to the pidome issue tracker, and there was an update to fix it. (It fixed it in my setup anyway).

    So I think you need to update to a more recent build.



  • Thanks for the info. I will grab a newer build later today!


  • Plugin Developer

    Please clear the browser cache after updating!

    And yes PiDome will run on windows, will it behave as expected? Sometimes. A while ago when i started with the usb connect/disconnect features my test system was a windows system. To get the real time usb connect/disconnect events you have to reference windows DLL's (create a hidden window, to be able to receive the events, hook up to processes etc...). At time of testing it did work from windows XP (i had an old laptop laying around) up to windows Vista (that was my win os at that time).

    This part of the code hasn't been touched for a while, and the procedures to install PiDome as a windows service has been removed because of the older code from which i currently can not say it should work. I will be picking up this part when the server has hit beta and the procedures will be updated.

    Regarding connecting USB devices, PiDome tracks a list of devices which work reliable, and this list is used when hot plugging. Not in the "safe" list, it also does not show up in the list when connected and the log says unsupported. This behavior will change in later builds when more work is done on more stable usb connect routines. An item which already is long on the list is to be able to add devices to the safe list when connecting.



  • Thanks John for the information about windows. I think I might hold off on that for awhile. I have enough on my shoulders right now.

    For now, it seems that I have everything working.

    ----- Edit (don't worry. I didn't read your "clear cache" I did that and everything is working!!!!!!! Very cool. thanks for your help!


  • Plugin Developer

    I will notify users using twitter when windows support becomes official.

    Good you have it working! What was the actual change you did so data was received?



  • The big thing that I did is change the serial settings. once I did that and then had a bit of patience, things started showing up. Clearing the cache in my browser also removed the time that it took to save and test things.

    I think my biggest issue was coming up to speed on the controller interface and getting a feeling of the terminology.

    I appreciate the patience and help you have provided. I think that this will help me monitor and control my hydro/aquaponics farm and also help others in the small scale farming industry automate.


  • Plugin Developer

    @dafoink
    Ok, this makes it clear to me, i already got some responses regarding the serial settings, Need to take a good look at it, it is not all that clear. But because it uses a common serial driver a lot of options are available and makes it difficult to set specific "default" values for every possible serial device.

    The controller interface "was" quite easy, with the latest changes it can be a bit confusing. Especially the terminology. I have started a page where a little explanation is done: http://platform.pidome.org/help Maybe it helps a bit on how the device structures are set up (information will grow on the site explaining more about PiDome).



  • I noticed that when I reboot the RPi, I loose the peripheral save. I have to re-add the peripheral manually in the peripheral screen. Once I do that, all of my device setup shows up.

    Any way to save that peripheral setting in case I want to create a trigger that reboots the pi for some reason?


  • Plugin Developer

    @dafoink
    When an peripheral is added there is an option to start, and to save and start. The save and start saves the usb port it is connected to. The start starts the peripheral, but forgets it as soon it is disconnected.

    The save and start does do a check that if a specific peripheral has been saved at usb1, removed and attached again, it still is the same device.

    The main reason this is implemented is that a lot are using for example FTDI. or Arduino's and attach multiple of them at the same time. By saving the mapping it kinda tries to keep the attached devices apart from eachother. It is not completely fool proof.

    If the mapping is usb2, and after reboot the mapping becomes usb1, it has to be re-added. So it depends on mapping availability.
    I know it is not wise to map the savings to the specific port names and it's better to be mapped to the usb bus locations and also keep the device's serial numbers (not only vid and pid) where possible. It is on the list ;).


 

217
Online

8.7k
Users

9.5k
Topics

99.9k
Posts