NRF24L01 radio not connecting



  • Hello, please help me since I'm stuck!
    My sensor node has problem with the radio communication. I am using an NRF24L01.
    Actually I do not think that the radio, nor the Arduino is faulty. I have tested both on an Easy/Newbie PCB and they are working good.
    I have designed my own PCB (https://www.openhardware.io/view/374/MyQTherm-replace-IQTherm-heating-thermostat). The radio does not communicate with my gateway when I use this PCB.
    The strange thing is that if I touch the radio chip with a finger the signals get through! Or even if I let the chip lie on a plastic surface it works. I also tested to fix a short cable with tape onto the chip and it works. When I remove my finger, cable or move the chip from a surface, the communication is interupted.
    As I said above, I have tested the radio chip and the Arduino (Pro Mini 5V clone) in another setup so I know they are good.
    In my investigations I tried with a fresh PCB (MyQTherm) an soldered just the NRF24L01, Arduino, LE33 voltage regulator and 4.7 uF capacitor for the radio. Leaving out all other stuff. Then I connected the Arduino to a serial chip connected to USB. So the node was then powered from USB. In this test the radio was also behaving faulty as described above.
    I have tested 3 of my own designed PCBs with the same result.
    Any ideas?


  • Mod

    @kontrollable if I'm understanding the PCB design correctly, the nrf24l01 module will be placed so the nrf's antenna is in the middle of the PCB. Is that correct? If so, I'm pretty sure we have an answer: there is a lot of metal close to the antenna, which will interfere with the radio signal.


  • Mod

    See https://forum.mysensors.org/topic/8869/troubleshooting-communication-solved for more details on a similar case. You have found the same solution as I did: find something to extend the antenna



  • Thanks!
    The NFR chip is oriented in such a way that the antenna is way outside the PCB. So I'm not sure that this is he problem.


  • Mod

    @kontrollable ok. Good. Then it is probably something else. Have you looked at the troubleshooting diagram at https://forum.mysensors.org/topic/666/debug-faq-and-how-ask-for-help/ ?

    Debug logs from the node and the gateway will probably be very useful when troubleshooting.



  • @mfalkvidd Awesome! I will check the debug logs from my node and gateway this evening.



  • OK, so enabled MY_DEBUG on my serial gateway. MY_DEBUG was already enabled in my sensor node.
    I found that the gateway did not receive any signals from the node at all.
    The node reports that it does not find any parent.
    So my conclusion is that the radio on the node sends a weak signal.

    Here is the log from the gateway:
    0;255;3;0;9;MCO:BGN:INIT GW,CP=RNNGA--,VER=2.1.1
    0;255;3;0;9;TSM:INIT
    0;255;3;0;9;TSF:WUR:MS=0
    0;255;3;0;9;TSM:INIT:TSP OK
    0;255;3;0;9;TSM:INIT:GW MODE
    0;255;3;0;9;TSM:READY:ID=0,PAR=0,DIS=0
    0;255;3;0;9;MCO:REG:NOT NEEDED
    0;255;3;0;14;Gateway startup complete.
    0;255;0;0;18;2.1.1
    0;255;3;0;9;MCO:BGN:STP
    0;255;3;0;9;MCO:BGN:INIT OK,TSP=1

    Here is the log from the node:
    0 MCO:BGN:INIT NODE,CP=RNNNA--,VER=2.1.1
    3 MCO:BGN:BFR
    19 TSM:INIT
    20 TSF:WUR:MS=0
    27 TSM:INIT:TSP OK
    28 TSF:SID:OK,ID=6
    30 TSM:FPAR
    50 TSF:MSG:SEND,6-6-255-255,s=255,c=3,t=7,pt=0,l=0,sg=0,ft=0,st=OK:
    2057 !TSM:FPAR:NO REPLY
    2059 TSM:FPAR
    2077 TSF:MSG:SEND,6-6-255-255,s=255,c=3,t=7,pt=0,l=0,sg=0,ft=0,st=OK:
    4085 !TSM:FPAR:NO REPLY
    4087 TSM:FPAR
    4106 TSF:MSG:SEND,6-6-255-255,s=255,c=3,t=7,pt=0,l=0,sg=0,ft=0,st=OK:
    6114 !TSM:FPAR:NO REPLY
    6116 TSM:FPAR
    6134 TSF:MSG:SEND,6-6-255-255,s=255,c=3,t=7,pt=0,l=0,sg=0,ft=0,st=OK:
    8142 !TSM:FPAR:FAIL
    8143 TSM:FAIL:CNT=1
    8145 TSM:FAIL:PDT
    18148 TSM:FAIL:RE-INIT
    18150 TSM:INIT
    18157 TSM:INIT:TSP OK
    18159 TSF:SID:OK,ID=6
    18161 TSM:FPAR
    18181 TSF:MSG:SEND,6-6-255-255,s=255,c=3,t=7,pt=0,l=0,sg=0,ft=0,st=OK:
    20188 !TSM:FPAR:NO REPLY
    20190 TSM:FPAR
    20209 TSF:MSG:SEND,6-6-255-255,s=255,c=3,t=7,pt=0,l=0,sg=0,ft=0,st=OK:
    22216 !TSM:FPAR:NO REPLY
    22218 TSM:FPAR
    22238 TSF:MSG:SEND,6-6-255-255,s=255,c=3,t=7,pt=0,l=0,sg=0,ft=0,st=OK:
    24245 !TSM:FPAR:NO REPLY
    24247 TSM:FPAR
    24266 TSF:MSG:SEND,6-6-255-255,s=255,c=3,t=7,pt=0,l=0,sg=0,ft=0,st=OK:
    26273 !TSM:FPAR:FAIL
    26274 TSM:FAIL:CNT=2
    26276 TSM:FAIL:PDT



  • I used a multimeter to measure 3.3 V on the output from my voltage regulator. 3.3 V on the radio chip and capacitor. So it seems to power the radio alright.


  • Mod

    Is there a reason why are you still using version 2.1.1?



  • @gohan said in NRF24L01 radio not connecting:

    Is there a reason why are you still using version 2.1.1?

    The only reason is that I have not bothered to update. But do you really think that updating would help? Could it really be a software problem?


  • Mod

    Always stay up-to-date as many bugs get corrected



  • @gohan

    @gohan said in NRF24L01 radio not connecting:

    Always stay up-to-date as many bugs get corrected

    Oh my god! Updated the sensor (not the gateway yet) and now it seems to work! Am I surprised? Yes!
    Thanks so much!



  • @kontrollable I think you should update the GW as well. I had a lot of problems with downlink messages from GW to an RGB controller. Updating the GW solved all of this immediately.



  • @bgunnarb Thanks, I did update the gateway also.


 

391
Online

7.6k
Users

8.5k
Topics

91.2k
Posts