New to MySensors

  • Hello, I am new to Mysensors and pretty much the whole IOT world. I am an electronics student in college, and I've been trying to get hands on with real life projects and applications. I'm working with an older cousin of mine he loves to tinker with these things, and is really dedicated to open source. We managed to flash one Sonoff with tasmota using Usb to TTL serial converter CP2012, and can't get any others to transmit. Wanted to test with Home Assistant on Pi 3. You can also see that I broke a button lol. Any ideas to fix that? Last thing if anyone lives remotely close to central CT and wants to discuss projects and help each other along. We'd gladly buy lunch.
    1_1526075845717_0505181657a.jpg 0_1526075845716_0509181851.jpg

  • @joshwizzard Welcome to MySensors. If you have questions, there is a GREAT team of people on this forum that can help with nearly any issue you have related to home automation.

    I have a number of Sonoff devices in play in my automation setup, but I have never used Tasmota though, and nor have I used Home Assistant. Mine use ESP Easy firmware and I use it with my Vera home controller. I wrote a BLOG post article on how to set it up for a Vera. Maybe you can get some information from it.

    As for the button, looks like you'll be replacing that or living without it. It is not crucial that you have it outside of the fact that it helps for programming it.

  • Mod

    @joshwizzard look for debug output over serial console, that helps understand what it is doing (if you flashed it successfully). For the first time I usually suggest to use the precompiled bin file and upload it with any flash tool for esp8266

  • I found this
    They added a wire right to the chip. Does anyone do this, or has anyone tried this before?

  • Mod

    Of course we have done it, soldering pin headers for vcc gnd TX rx is the standard way to get access to the esp8266 to flash it with anything you want. There is no need for the extra wire (but you may need to solder a wire in place of the broken button if you want to put the esp8266 in flash mode)

  • I've soldered the connectors. Checked power with a voltmeter. I still only get the RX to flash once, and will not flash the sonoff. Arduino IDE won't even show the Port.

  • @joshwizzard are you holding GPIO0 to ground at power on to put it in programming mode?

  • @dbemowsk I'm holding the button in before connecting the USB.

  • @joshwizzard that sounds correct. What are you using to program it? Arduino IDE?

  • @dbemowsk Yes I am. The error is failed to open COM1 and I cannot select a port because it is grayed out.

  • Mod

    Maybe it's a bad usb serial adapter you have.

  • @joshwizzard if you are using windows, check the device manager. Could be a driver issue. Check for devices with an exclamation point on them, probably under COM & LPT section. If it shows an error 10 or other error, Google your adapter model and the error you see. You should come up with a solution.

  • Mod

    @joshwizzard said in New to MySensors:

    @dbemowsk Yes I am. The error is failed to open COM1 and I cannot select a port because it is grayed out.

    Are you sure it is COM1? Usually that is the computer serial port, not the external one. Did you set the correct voltage for the Arduino you are using?

  • @gohan I have a USB to serial adapter that is apparently a clone of a more popular brand. I don't have the model in front of me right now, but I had to download a different driver for it to make it work. That's why I mentioned to him to check the Windows device manager. You are also correct that Com1 is usually the computers internal serial port, that is if it has one. Most newer laptops don't have a serial port any more, and Desktops have not come with one in quite some time. So there is the possibility that it could still identify as Com1.

  • Mod

    yes, it could be too many things

  • @dbemowsk Thank you for the help so far. The first time we flashed tasmota successfully I did update the drivers from the USB converters website and were able to select COM5. We have since tried pogo pins and other USB adapters. I will check everything again.

Log in to reply

Suggested Topics

  • 2
  • 2
  • 2
  • 13
  • 8
  • 4
  • 6
  • 6