MySensors 2.3.0 released

  • Contest Winner


    Thanks to all GitHub users who contributed to this release:

    Kartik Arora
    Marcelo Aquino
    Marco Bakera
    Martin Hjelmare
    Mikael Falkvidd
    Miloslav Kazda
    Patrick Fallberg

  • Do we need to upgrade everything? gateway/nodes? or is there some compatibility?

  • Contest Winner

    @crankycoder We use semantic versioning based on the OTA protocol. That means that a major change require network wide updates. A minor change (like this one) means there are features added but they shouold be backwards compatible (OTA wize) and a patch change is just a bugfix (which might also be included in minor and major releases).

    To be more concise: No, you do not need to upgrade anything. 2.3.0 is fully 2.2.0 compatible. But some features are changed so you might need to do some changes to your sketch if you use 2.3.0 version (like signing flags, rPi configuration options and such).

  • Perfect!!! Thanks for the update!

  • Version 2.3.0 has very big problem with communication on radio RFM69HW.
    On version 2.2.0 the same configuration and parameters has no problem. Works perfect.

    Now i can not use 2.3.0 with RFM69HW. Please help and correct this problem.

    I use gateway on RPI3. I updated gateway to 2.3.0 but it no working with nodes with version 2.3.0
    Also problem is when on Gateway and Nodes has the same version 2.3.0

    For me on radio RFM69HW only works correct on version 2.2.0

  • Hello,

    please, how to update version 2.2.0 to 2.3.0 on Raspberry pi?

    Thank you.

  • Mod

    @mirikbb either delete the MySensors folder and start from the beginning, or do git pull inside the MySensors folder and start from the build step.

  • Hello,
    I set the update, but now i've some issues.
    I can't edit and manage switches anymore:
    as soon i click on edit i have this word "undefined" .and that's all.
    i can't set timers too.

    I tryed this:
    My installation was pretty simple , so i stoped domoticz serveur , removed domoticz folder and proceeded to an fresh install.
    Problems are still present.
    log don't say anything.
    so, anyone have a clue ?

    here what i get when i click on edit:

  • Mod

    @eric007 I don't see how MySensors can cause that problem. Looks like something with Domoticz. Have you tried rolling back to the latest stable Domoticz version?

  • @mfalkvidd you'r right, i was in a hurry , so i forgoted using my brain!!
    the update was with domoticz and i have to check this way.

  • @eric007
    I have the same problem. It is related to Domoticz update sice today afternoon where some of the sensors started to show like undefined. This has nothing to do with Mysensors 2.3.0 update.

  • @eric007
    The problem is in browser's cache was not refreshed after the update. For Firefox browser clear Cache and Site Data (Options->Privacy&Security->Clear History->Cache+Offline WebSite Data)
    then reload window. The message "refreshing cache" should appear on Domoticz page, right up side corner.
    The graphs should then display normally. Without clearing the cache you can see the normal Domoticz graphs in new private Firefox window or other browser.

  • Hum I am not sure what the deal is here but I have spent the last two days updating and then removing 2.3.0 from Gateways and Repeaters. It completely trashed my 22 node network. I still have some 2.3.0 nodes running but if I installed 2.3.0 and setup #define MY_REPEATER_FEATURE my nodes would crash within about 30 mins of booting. Also on the gateway the through-put of the radio RF24 died to a crawl. I was trying to OTA my nodes and they were going line by line for about 60mins or more each (MYSController). I simply went back to 2.2.0 on Ethernet Gateway made NO other configuration changes and the nodes flashed in less than a minute each.

    Since removing 2.3.0 from gateway and repeaters the whole network appears to have stabilised again.

  • Thank you for your great work on this project. It is the best project for most of us to build a cheap and reliable wireless iot network.
    I am stuck at version 1.5 with my home network. I have several repeaters and even more nodes. I have some quite complex nodes so I decided to make the version update slowly. My system can't be stopped for days.
    I plan to operate the 1.5 and the 2.3 network parallel and change the nodes one by one.
    The system runs on Domoticz using a serial gateway. First I will add a new serial gateway (2.3) and I will start to migrate the nodes.
    Can I keep the node_ids in Domoticz to keep the controller-side scripts unchanged?
    Can you suggest the best way to migrate everything?

  • With released 2.3.0 is many problem with communication on radio RFM69HW. On 2.2.0 this problem is no available.

  • Admin

    @pvoj Domoticz will reassign internal sensor id's to each sensor it sees on the new gateway.

    One way could be to use nodered in front of domoticz, and create some basic mysensors dual gateway routing, so domoticz only sees one gateway. I did this when I was running domoticz as controller. (I have now switched completely to nodered).

  • Hello,

    please, how to revert from v2.3 to 2.2 on rpi? I started to have a problem with stability/freezing of my raspberry pi 3 after installing v 2.3, and I am not sure if it has something to do with new Mysensors v2.3. I need to elaborate a bit but I don't know how to use Git clone to get older version. I have no skills with git.
    Many thanx.

  • Mod

    @mirikbb you can download all versions from

  • Hi
    I have MSGW 2.1.0 version on arduino
    today I was install RPi3 MSGW 2.3.0
    Can I work with sensors 2.1.0 or need to upgrade all ?
    Thank you

  • Please modify source !!!!! 2.1.1 2.2.0 2.3.0

    anvil 2 years ago
    Solved - user error πŸ™‚
    Inside the Raspberry Pi setup (file /MySensors/examples_linux/mysgw.cpp), the inclusion mode define must be added:
    This is present in the Serial & Ethernet gateway example ino files, just missing from the Raspberry Pi version as it is on GitHub.

    With this added, the response to the StartInclusion mode request is then received & everything is fine:

    TX(fromController) 0;0;3;0;5;1
    RX(fromRaspberryPiGateway) 0;255;3;0;5;1
    On the plus side, by working this out I'm a lot more familiar with the workings of MySensors!



  • Mod

    @cadet looks like it is already present:
    Or am I missing something?

  • @mfalkvidd ok its present
    But I spend two days to find it