FTDI No more?



  • Today I realized that none, absolutely none of my usb to serial converters works. I've been using them in the past, but lately I was uploading sketches through ISP and I didn't need anything to debug.
    Seems that my Windows 10 throws a different error for every one like "the device did not turn on" or "error 43, requesting device descriptor"
    Is this happening only me or is anyone having such problems?
    I read something about original brands distributing malicious drivers and wrecking supposedly fake chips, but I didn't even update any driver.
    What you guys are using for serial debugging?



  • Can you check which updates that your win10 have installed? maybe you need to
    I know the links are a few years old, but could this be your error? can you roll-back the win updates?

    https://hackaday.com/2016/02/01/ftdi-drivers-break-fake-chips-again/
    https://www.techrepublic.com/article/ftdi-abuses-windows-update-pushing-driver-that-breaks-counterfeit-chips/



  • @bjacobse My system gets all the updates. That means at least one major every month. So identifying the culprit or going back can be impossible, as I wasn't using those devices for a while. Sure that's the problem.

    Althought I've been raising a new ubuntu VM in my esxi server in the hope I could configure it for mysensors developments, but I stepped into so many problems that I'm now turning it of definitely.
    First ubuntu (18.04) desktop didn't resolve names in my intranet. I had to ditch it's fancy networking interface and go back to the old school /etc/network/interfaces file.
    Then I had problems mounting samba shares and had to do it with nfs. And when I tried to open my shared sketches folder with the Arduino IDE I realized that it can't browse network mounts even when I have full access to them.
    Also I passed through the servers usb controller to the VM and tried to get the ftdi device shown in ubuntu, but the passthrough doesn't work on any usb controller.

    I feel like I've been cursed.



  • maybe it's 'only' your computer which is been cursed and not 'you'- could you try your FTDI with another computer?



  • Yes ,try in other computer to be sure. I already had one windows that ftdi driver was broken(i did it trying revive an almel 34u2) and another time an Windows update (Windows 7 i think) brick all my ebay red and fake ftdi. I had to unbrick them... Nowadays i think Microsoft already don't do that.



  • Yes, I think it must be a windows native driver that tried to self install, something "Prolific..." alike. But when I came to the updates history, it showed as a fail.
    I could try with my wifes laptop, but it's also win10.
    I'll have to bring a fresh windows 7 in an htpc board I have around.

    Do anyone knows what's the latest working version of the brand drivers, and perhaps have a copy to send me?


  • Mod

    Last time I used the FTDI cheap clones I have it was about 2/3 weeks ago and they were still running. I haven't tried them lately so I can't confirm if any new update broke the drivers



  • Newer drivers don't work(anymore).
    I use the driver Prolific from 24-Sep-08 version 3.3.2.102
    You have manually to tell windows to use the older one instead of the newer.



  • @gerard-van-seventer Thanks Gerard for the hint on version. I wonder how you manually choose betwenn drives in windows. I guess you simply uninstall the existing when the device is present and then install the wanted one?



  • HUM.. nice to advise us then ..and make sense because my windwos 10 have driver updates off(and main updates off aswell…
    that explains why i don't have my fake ftdi driver broken on my win 10,because i never update nothing that works,,, grrrr , i hate that Windows update and run policy…

    by the way ,rollback to previews drivers and lock them from update. how to do?

    if that is not enough create a rule on outgoing firewall trafic that block Windows update service and sihclient.exe from runing.



  • In fact, I had updates blocked using a group policy, and it worked for a while. But someday I noticed that the PC was turning itself on while I was not there. I thought it was the cat hitting the keyboard so I deactivated mouse and keyboard wake up and powering while off. But it didn't help. I also discarded wake on lan because the PC was doing it even without lan cable.
    One day I saw that updates where happening and I realized that windows was turning the computer on for it. And then this message saying "we'll run updates when we find your computer is so behind on them" appeared below the one indicating that I blocked then by group policy, in updates screen. And last week, the computer was up to date.
    So that's the way it is.

    Even if you create firewall rules, I think they'll surpass them for their sake. I have opnsense as router/firewall, and I saw that now mistersoft uses thirty party cdns for their updates, so blocking them may be also a problem.


 

466
Online

7.9k
Users

8.7k
Topics

93.6k
Posts