Problems uploading Serial Gateway on to Arduino Pro Micro



  • Not sure what I am doing wrong. NOOB.

    Is installing the Libraries for MySensors a completely manual process? I am trying to get the Serial Gateway installed on an Arduino Pro Micro.

    If I don't want to touch any of the code, it seems I need to copy a whole bunch of files manually to specific folders managed by the Arduino IDE.

    I must be doing something wrong.

    Example.
    Copy /libraries/XXXX files into /arduino/libraries
    Copy /libaries/MySensors/Myxxxx.xx files into /arduino/examples?


  • Hero Member

    What exact error do you get?
    Did you re-start arduino IDE after putting the libraries into the correct folder?



  • Yes. I get nothing on the Arduino IDE Serial Monitor for the gateway.

    It compiles and uploads.

    I understand the Serial Monitor on the Gateway, spits out a responses.


  • Hero Member

    Did you set the serial monitor to 115200 bps?



  • Yup. As additional info.

    I also noticed on Pidome under Drivers / Gateway Info - it says waiting for gateway.

    I find this strange because I plug in the gateway and it "sees" it under Peripheral.

    Do I need to plug in a NODE? to have data show up on the Arduino Serial Monitor?

    I did so, but still see nothing.


  • Hero Member

    You must see 'Gateway started' or something like that in serial monitor. Otherwise your controller will not notice it.



  • I have a Pi Controller. Do you mean I need to see "Gateway started" in the serial monitor on the Arduino IDE when I have the Pro Micro gateway connected to the PC?

    Just trying to be extra clear, as it seems to be working for some many, so I'm trying to rule out stupid assumptions on my end.

    If yes. I dont see anything.

    I downloaded MySensor 1.5 API and believe I correctly followed the instructions....I've done this a few times already... Hmmm.


  • Hero Member

    @den2k said:

    Do you mean I need to see "Gateway started" in the serial monitor on the Arduino IDE when I have the Pro Micro gateway connected to the PC?

    Yes, that's what you need to see. It's odd that you don't see anything. Are you sure it's programming correctly? I updated my serial gateway from 1.4 to 1.5 tonight and I had no issues. Which version of the Arduino IDE are you using? Did you delete the 1.4 libraries from the Arduino libraries section?

    Cheers
    Al



  • I'm using Arduino IDE 1.6.5.


  • Hero Member

    @den2k That's what I used as well. If you downloaded the 1.5 zip file, delete all of the 1.4 files and drop all of the folders in the libraries folder in the zip file into your local Arduino libraries folder. Also, can you confirm which exact Arduino you are using (maybe provide a link).

    Cheers
    Al



  • This is what I see.
    upload-e2cd0ccc-1b64-40ea-913c-c7c34fc342d9


  • Hero Member

    "Arduino as ISP"? Did you try the standard "AVR ISP mkII' instead?

    "Arduino as ISP" Means you are using an arduino to program another arduino (as described here). If you are connecting the target-arduno directly into an FTDI-USB adapter, use AVR ISP-like ....

    Even if you do have two arduinos, after uploading your program you must use an FTDI adapter directly between your target-arduino and your computer-usb. I'm saying that because I could never get serial monitor using 'ArduinoISP' programmer, maybe it works with some trick.



  • I changed it to AVRISP mkll, Arduino ISP, Arduino as ISP. Didn't seem to make a difference....

    Still not seeing anything on the serial monitor. After programming it successfully.

    I may try deleting all libraries and try the install of MySensors again. I've seen that suggested else.

    I did upgrade from 1.4 previously to 1.5. Was having problems (posted on separate thread) so thought 1.5 might help...
    upload-3bd3f1e5-1627-40b4-9605-5c31260dd8ee



  • Nope.

    I just finished

    • reinstalling the Arduino IDE 1.6.5.
    • Reinstalled Pro Micro Drivers
    • Reinstalled Pro Micro PlugIn for IDE
    • Reinstalled MySensors 1.5 libraries into IDE libraries
    • Uploaded the Serial gateway script to the Pro Micro.
    • Successfully compiled and uploaded to the micro.

    Not working....still. I still don't see anything on the Serial Monitor.

    What am I suppose to see on the Monitor?


  • Hero Member

    @den2k Do you have a different Arduino you can test with?


  • Hero Member

    @den2k Also, try connecting and pressing a reset switch on the Pro Micro quickly twice in a row just before uploading. See https://learn.sparkfun.com/tutorials/pro-micro--fio-v3-hookup-guide/troubleshooting-and-faq#ts-reset.



  • I tried to check if it has anything to do with my nRF24L01+ radios.

    When I go back to basics and use the RF24 Getting Started example. this is what I get.

    upload-f193aa6d-a6ea-481a-87b6-f3da60f61bde

    Looking around I thought I was suppose to get a status register output on the serial monitor.

    Does it mean the radios are not genuine?

    I'm really pulling my hair out trying to figure this stuff out.

    I know my radios works because I've used other examples to have different nRF radios send messages back and forth...



  • @Sparkman

    I tried that. I'm pretty sure the radios and arduinos themselves work. I have several that I play with and have swapped out some - just to eliminate HW being the issue.

    I'm guess it's a dumb problem that I caused....hmm

    thanks for the help everyone! Just wished it was working!


  • Hero Member

    Maybe you can post a picture or schematics showing how you are connecting the radio to arduino? You last screenshot is showing only 'failed' for any radio operation.


Log in to reply
 

Looks like your connection to MySensors Forum was lost, please wait while we try to reconnect.