Raspbery PI + nrf24 (gpio) not work Domoticz Temp+humanidy PLS HELP



  • Hello do not speak English and this is my first post :) PLS HELP MY

    I am a beginner in the subject raspberry want to read the temperature of the Arduino Nano mini through nRF2401 ( scratch is from github standard temperature reading ), the second nrf24 is attached directly to the RPI via GPIO ports , according to the
    http://forum.mysensors.org/topic/1151/tutorial-raspberry-pi-nrf24l01-direct-connection
    performing the test ./PiGatewaySerial and including the Arduino Mini can be seen on the test that the data is sent but do not see anything in domoticz please help what I'm doing wrong really been a long time over this sit

    pi@mysensors ~/Raspberry $ sudo ./PiGatewaySerial
    Starting PiGatewaySerial...
    Protocol version - 1.4
    Created PTY '/dev/pts/2'
    Gateway tty: /dev/ttyMySensorsGateway
    ================ SPI Configuration ================
    CSN Pin = CE0 (PI Hardware Driven)
    CE Pin = Custom GPIO22
    Clock Speed = 8 Mhz
    ================ NRF Configuration ================
    STATUS = 0x02 RX_DR=0 TX_DS=0 MAX_RT=0 RX_P_NO=1 TX_FULL=0
    RX_ADDR_P0-1 = 0xa8a8e1fc00 0xa8a8e1fc00
    RX_ADDR_P2-5 = 0xff 0xc4 0xc5 0xc6
    TX_ADDR = 0xe7e7e7e7e7
    RX_PW_P0-6 = 0x20 0x20 0x20 0x00 0x00 0x00
    EN_AA = 0x3b
    EN_RXADDR = 0x07
    RF_CH = 0x4c
    RF_SETUP = 0x23
    CONFIG = 0x0e
    DYNPD/FEATURE = 0x3f 0x06
    Data Rate = 250KBPS
    Model = nRF24L01+
    CRC Length = 16 bits
    PA Power = PA_LOW
    read: 1-1-0 s=255,c=0,t=17,pt=0,l=3:1.5
    read: 1-1-0 s=255,c=3,t=6,pt=1,l=1:0
    read: 1-1-0 s=255,c=3,t=11,pt=0,l=18:Temperature Sensor

    upload-7837c535-0689-4868-b5b6-959c7b5ee456

    upload-05eaed92-9672-4b5a-a003-c04a365d2745


  • Admin

    What is the problem then?
    (I cannot read/understand the red text message on screen.)



  • domoticz not read with raspberry or I do not know how to read temperature and humidity



  • I am a domoticz user, but I have a serial gateway and did not try a direct gateway.
    But I am sure your hardware-configuration is wrong.
    You need to delete the entries no. 5 and 3 and add a "MySensors Gateway USB" with the serial port "/dev/ttyMySensorsGateway".
    The actual sensors are not configured in the hardware-setup. If domoticz receives a reading from a new sensor, you can find the sensor in the devices-section.

    If you are a beginner, I strongly recommend to start with a serial gateway!



  • hello I know but I have tried through the gate USB and also was not working , help me as you can, how you want your file ttyMySensorsGateway , I like it open in the nano this file is empty or perhaps me someone some idea how this is supposed to look , please , I really already sit on it week and nothing


  • Contest Winner

    I'm not sure, but I think I read somewhere on the Domoticz forum, that it's only possible to use the GPIO's, on the pi you're running Domoticz on, as digital output. I'm not even sure if you can use them as input.

    But if you can hook a temperature sensor to it. I'm really interested in how you'd accomplished it.



  • @revoltec112 said:

    http: // forum.mysensors.org/topic/1151/tutorial-raspberry-pi-nrf24l01-direct-connection

    here is the link to connect and for testing can be seen on the RPI data transmitted from the remote sensor but the question is how to do it domoticz read ???



  • whether in the / dev file must be named ttyMySensorsGeteway ? if so how it developed and what it should contain


  • Mod

    I am not sure I understand your question, but I have a NRF24L01+ connected to my Raspberry Pi and I am able to read the sensors in Domoticz.

    I had to do

    sudo ln -s /dev/ttyMySensorsGateway /dev/ttyUSB20
    

    because /dev/ttyMySensorsGateway did not show up in the serial port list on the Domoticz Hardware page. Then I added Mysensors to Domoticz like this:
    domoticz_add_hardware.png

    I hope this helps



  • Please can you help me step by step how you did it



  • I made this command does nothing fortunately still does not work : ( ( (


  • Mod

    Install the gateway:

    git clone https://github.com/mysensors/Raspberry.git
    cd Raspberry/librf24-bcm
    make all && sudo make install
    cd ..
    make all && sudo make install
    sudo make enable-gwserial
    sudo /etc/init.d/PiGatewaySerial start
    

    Verify that the gateway started properly:

    cat /dev/ttyMySensorsGateway
    0;0;3;0;14;Gateway startup complete.
    
    

    Domoticz is unable to read from /dev/ttyMySensorsGateway so create a link to a name that Domoticz understands:

    sudo ln -s /dev/ttyMySensorsGateway /dev/ttyUSB20
    

    To automatically create the link on startup, add

    ln -s /dev/ttyMySensorsGateway /dev/ttyUSB20
    

    just before

    exit0
    

    in /etc/rc.local

    I then added the gateway as per the image in my last post.

    EDIT: Changed instructions to use librf24-bcm instead of tmrh20. tmrh20 tricked my Gateway into forwarding everything to a strange (non-existing) parent node.



  • @mfalkvidd I am attempting to follow your lead here on compiling the Raspberry mysensors gateway. However, this is failing on my rpi2 with tons of repeating errors like:
    bcm2835.c: In function "bcm2835_init" :
    error invalid suffix "x" on integer constant

    I have enabled SPI from rasp-config. This is using the domoticz image of raspbian wheezy. Any thoughts on how to get around this?


  • Mod

    @wergeld I remember seeing those errors as well. I think that's why I switched to tmrh20 but then I switched back and didn't get any errors when I tried again. Not sure what happened between, I hacked away now and then during several weeks.



  • @mfalkvidd Okay, that is what i was going to go for as well:
    Try tmrh20 and then see what happens.

    I think there is some issue with the code in general as the rpi2 does not have the bcm2835 chip, right? I think it is bcm2836 (mind not working this early in the morning).


  • Mod

    Looks like it. Output from hwinfo:

    raspberrypi-firmware: /devices/platform/soc/soc:firmware
        bcm2835-mbox: /devices/platform/soc/3f00b880.mailbox
        bcm2835_AUD0: /devices/platform/bcm2835_AUD0.0
        bcm2835_AUD0: module = snd_bcm2835
        bcm2835_AUD1: /devices/platform/bcm2835_AUD1.1
        bcm2835_AUD1: module = snd_bcm2835
        bcm2835_AUD2: /devices/platform/bcm2835_AUD2.2
        bcm2835_AUD2: module = snd_bcm2835
        bcm2835_AUD3: /devices/platform/bcm2835_AUD3.3
        bcm2835_AUD3: module = snd_bcm2835
        bcm2835_AUD4: /devices/platform/bcm2835_AUD4.4
        bcm2835_AUD4: module = snd_bcm2835
        bcm2835_AUD5: /devices/platform/bcm2835_AUD5.5
        bcm2835_AUD5: module = snd_bcm2835
        bcm2835_AUD6: /devices/platform/bcm2835_AUD6.6
        bcm2835_AUD6: module = snd_bcm2835
        bcm2835_AUD7: /devices/platform/bcm2835_AUD7.7
        bcm2835_AUD7: module = snd_bcm2835
          alarmtimer: /devices/platform/alarmtimer
             dwc_otg: /devices/platform/soc/3f980000.usb
         spi-bcm2835: module = spi_bcm2835
         spi-bcm2835: /devices/platform/soc/3f204000.spi
          bcm2708_fb: /devices/platform/soc/soc:fb
    bcm2708-dmaengine: /devices/platform/soc/3f007000.dma
     uio_pdrv_genirq: module = uio_pdrv_genirq
          serial8250: /devices/platform/serial8250
     pinctrl-bcm2835: /devices/platform/soc/3f200000.gpio
         mmc-bcm2835: /devices/platform/soc/3f300000.mmc
             arm-pmu: /devices/platform/soc/soc:arm-pmu
     bcm2835_thermal: /devices/platform/soc/soc:thermal
       bcm2835_vchiq: /devices/platform/soc/3f00b840.vchiq
         bcm2708_i2c: /devices/platform/soc/3f804000.i2c
         bcm2708_i2c: module = i2c_bcm2708
    
    

  • Mod

    This thread might be useful for troubleshooting



  • @mfalkvidd Yes, I used that to do the build initially. I cannot even get past the "make" command (tried sudo make as well). One person there had same error but they "solved it" and did not mention how they did it. I am going to give it another go tonight with a fresh image of raspbian.



  • Finally got mysensors built on my RPi2. And have built domoiticz and it is up and running! I have added my USB gateway but now not sure what to do? It does not appear to pick up my sensor node. Where do I change the Gateway's channel and radio parameters?



  • Actually forgot that MyConfig file when I built the RPi gateway. That is all set but now when I debug using ./PiGatewaySerial i see good output for the radio parameters but then it spits out continuous reams of:

    read: 0-0-0 s=0,c=0,t=0,pt=0,l=0:
    version mismatch
    read: 0-0-0 s=0,c=0,t=0,pt=0,l=0:
    version mismatch
    read: 0-0-0 s=0,c=0,t=0,pt=0,l=0:
    version mismatch

    Not sure what this is about as I do not have any nodes on this channel (76). All my active nodes are on channel 90 and are talking just fine to my RPi running easyIOT server.

    What is this version mismatch about?


Log in to reply
 

Looks like your connection to MySensors Forum was lost, please wait while we try to reconnect.