1.4b Radio Transmission(?) Problem Not Present in 1.3b


  • Hero Member

    Ok,
    So I 'upgraded' to 1.4b, and everything upgraded fine, except all my temp sensors would not display in F while on battery power, but worked fine while connected to my computer. The Temps would update just fine. I wound up hard coding the conversion with @hek help.

    So today I build up a relay node on my breadboard, coded everything up and it working great while connected to my computer, but again as soon as it's on battery power, Vera cannot control (send out commands?) the node (Vera buttons don't respond).

    Keep in mine this is not a problem in 1.3b.

    This is what I've discovered:

    • Regulator is sending 3.325vdc, Direct Battery feed is 3.016vdc, and USB wall wart is sending 3.308vdc.

    • When regulator is providing power, FAILS

    • When powered by either direct battery feed or USB wall wart everything works perfectly.

    • Tried different radio's, and regulators (3 radio's and 4 regulators; results are the same.

    • Installed 4.7 cap across vvc and gnd on the radio; results are the same

    Is this really a matter of having too much voltage being sent to the radio causing problems in version 1.4b1 ??

    Is this even fixable on my end?


  • Admin

    USB normally gives 5V. Which also is what an attached relay requires to operate. I really don't understand how your USB wall wart can give 3.3VDC?
    I would not recommend driving a relay on battery. It won't last for long.


  • Hero Member

    @hek
    I'm sorry, those voltage readings are @ the radio vcc pin (the USB source I'm using an FTDI set to 3.3v to connect to the Arduino).

    I don't believe this problem has anything to do with utilizing a battery vs hardwired power source. I don't plan on running this project on battery's, but in my testing I believe I've found a strange problem in 1.4b, as I had the same communication problem with all my temps sensors while on battery power, but not on the other 2 methods after moving to 1.4b

    I think one of 2 things are happening here. The step up regulator IS causing a problem in 1.4b that is not present in 1.3b in my environment. What I'm not sure is if it has to do with the 3.325vdc or some other noise problem the regulator is creating.

    I scrounge up some old batteries, which are @ 2.842vdc and everything is still working, as soon as I use the regulator and the voltage @ the radio is 3.326 (on same batteries) it fails..


  • Admin

    @ServiceXp

    The radio messages is sent in bursts in 1.4. This probably uses more power for a short split of a second and the voltage drop may very well be larger.


  • Hero Member

    @hek
    Any way to resolve?. Is there anyway you can build up a 3.3 mini pro with regulated power test bed? I've got to believe that this problem is reproducible.

    In my testing it seems that when the voltage @ the radio's vcc pin is above 3.310vdc we stop communicating properly. When I'm below that level, even down to 2.82vdc proper communication is established.


  • Hero Member

    @hek
    Ok so it's definitely a voltage problem to the radio in 1.4b.

    Using a 1N5226B Zener Diode and a 22ohm resistor across the regulated supply, I was able to reduce the regulated voltage down to 2.901vdc. and with that we now have communication using the step up regulator.

    I don't know much about electronics and it's interaction between code, but this is the strangest thing I've seen. Not sure how one set of 'firmware' works perfectly fine with higher radio vcc, and another does not.

    If this is reproducible, I guess there will be some hardware changes required for 1.4b.


  • Plugin Developer

    Because it is send in bursts it can require more current then when not send in bursts. Can not check because have only a cheap multimeter which does not show maximum currents and is not fast enough to show even the current used.

    Also i have a device with multiple sensors and display where the radio which is getting 3.4something volts from a L78L33AC regulator which is having an regulated input of 5 volts from a power source regulator and it works almost perfectly in the beginning but now perfectly.

    I forgot to put a capacitor between the L78 Vout and RF Vin / ground. But now it is sending happily even when there is current pulled by the display (120>ma when back light is on) at the same time.

    If you have the equipment check if the supplied current is the same in all the configurations. Maybe the regulator is requesting to much current to step up in combination with the radio when sending and the batteries can not supply it.


  • Hero Member

    @John
    Yeah I only have a Fluke 16, so I can't measure the current while the radio is transmitting either. Are there any alternative step up regulators to the one in the store? http://www.ebay.com/itm/231083181020


  • Hero Member

    Looking at the specs on the regulator I listed, I doubt the radio is exceeding 400-600MA?


  • Hero Member

    Looks like the NRF24L01 power consumption is WAY below the regulators limit.

    11.3mA Radio TX at 0dBm
    12.3mA Radio RX at 2Mbps on-air data-rate


  • Hero Member

    Yeah those regulators in the Ebay store are probably not great. Decoupling is probably a good idea, but 4.7nF wasn't enough if I recall an earlier discussion correctly. Try 22nF or something like that. Or ceramic? But you can probably run the sensors on just 2x1.5V batteries for the time being, until another regulator is available. That is what I plan to do anyway.

    The boost modules that @axillent was prototyping can't arrive fast enough 🙂


  • Mod

    @bjornhallberg said:

    4.7nF wasn't enough if I recall an earlier discussion correctly. Try 22nF or something like that.

    I guess you mean 4.7uF and 22uF (micro Farad instead of nano Farad)?!


  • Mod

    @ServiceXp Looks like actual power consumtion is much less. See http://forum.mysensors.org/topic/250/how-do-i-use-the-interrupt/13


  • Plugin Developer

    It was just a wild guess, because i personally didn't have any noticeable problems haven't dived deep into to hardware (yet), only software part.


  • Hero Member

    @Yveaux Haha, yeah, uF. But I think I remember some thread where we tried larger capacitors with greater success. Basically, the 4.7uF was pretty much useless?


  • Hero Member

    @bjornhallberg

    That was it!!!!! I tried 22uF, was still doggie, so I thought why not move up to 47uF 😉 and what do you know, that seems to be the winning value. I have some more testing, but looking pretty good so far.

    Thanks everybody for all the suggestions.


Log in to reply
 

Suggested Topics

  • 7
  • 9
  • 7
  • 11
  • 2
  • 5
  • 14
  • 23

234
Online

9.8k
Users

10.3k
Topics

106.8k
Posts