πŸ’¬ Distance Sensor



  • @Boots33 Still waiting on the gateway to arrive, as well as the DYP sensor, so had a go at assembling the electronics. Having red elsewhere about potential interference between a booster and ultrasonic, have mounted the booster with the ground plane facing the board and direct mounted onto the SR04T (I see this is 2.0 version which reportedly gave problems before). Although it works electrically with 3v firing the bistable relay feeding the booster feeding the SR04T, and switches off fine, any opinions on the proximity issues?
    0_1498892631584_WP_20170701_09_44_38_Pro[1].jpg
    0_1498892749650_WP_20170701_09_44_24_Pro[1].jpg



  • @jjk Well I think I am done trying to get this JSN-SR04T-2.0 to work, tried different versions of ping and newping, as well as other sketches from suppliers of this device, but got no joy at all. Even separated the 5v booster in case of potential interference, no joy whatsoever.
    Recent complaints on supplier sites seem to confirm problems persist for this version 2.0, and on one site there was a note "Note: Version 2.0 requires echo pin to be pulled up to VCC. A 4.7K to 10K resistor can be used as pull-up resistor."
    Fat lot of use that is to me with a 3.3v unit, and if it needs a dedicate sketch to work, good luck with those sales..
    I guess I can only wait on the DYP to arrive now....


  • Hero Member

    @zboblamont Still no luck with the JSN unit I see. Hope the DYP unit will bring better results.



  • @Boots33 It seems that the newer version (2.0) is the one giving problems, the previous version did not. Presumably the sensor head is unchanged and common across all of them, so perhaps not a total waste of $10.
    It will be interesting to see if mounting the 5v booster so close on the DYP causes any issues, as it makes for a compact arrangement in a corner of a box.
    As an aside, with one of these heads needed in a sewage tank I needed a robust holder. The sensor head is a snug fit in the big end of a 3/4" to 1/2" GS tube reducer, giving both protection and rigidity.



  • I have tried to compile this sketch, but it fails, see error below. Any idea what's the reason and how it can be fixed ?
    I use the latest Arduino 1.8.3 (windows) version, mysensors 2.x and the above NewPing library.

    C:\Users\arthur\AppData\Local\Temp\ccAlQHJ9.ltrans2.ltrans.o: In function `setup':

    Y:_Domotica\NRF24L01\DistanceSensor/DistanceSensor.ino:53: undefined reference to `getControllerConfig()'

    collect2.exe: error: ld returned 1 exit status

    exit status 1
    Fout bij het compileren van board Arduino/Genuino Uno



  • Fixed the problem by changing some code:
    void setup()
    {
    Serial.begin(115200);
    // metric = getControllerConfig().isMetric;
    }



  • @Boots33 Now I am flummoxed.... Got the DYP unit and yet, no difference in responses.... I can only conclude this has to be a hardware or device issue, as I checked all wiring (unless I missed something really stupid), tried the same 6 sketches even on a spare 3v3 device with the same result. Now ordered up a couple of Pro-Mini 5v to check out whether this is a 5v related issue since I cannot create a timed response otherwise, nothing makes sense with respect to the ultrasonic units now otherwise unless my earlier information that 3v3 was sufficient to trigger the device was wrong... Time for a slow drink, a long smoke, and shout abuse at passing dogs.... Nice weather, 26c, Friday, what's not to smile about.... Ah, Port..



  • @Boots33 Well, finally I got some positive results, but not quite as expected...
    The JSN-SR04T-2.0 nor the DYP-ME007Y I could get to work on all six variations of sketches tried. Still not sure why neither would work using this 3v3 board even with 5v to the ultrasonic board and dropper resistors on the echo. Allegedly the ping from 3.3v should work.

    So, bought and finished today trialling a 5v/16MHz Pro-Mini ;
    The JSN version 2.0 nor the DYP would not respond to NewPing, simply churning out zeroes.
    Other sketches would turn out fixed numbers and zeroes which did not alter irrespective of the transducer/object distance.
    The JSN finally got working with a simple PulseIn calculation loop with a 500 delay. First reading was always Zero, all the rest consistent and rock solid.
    The DYP unexpectedly responded only to the SoftwareSerial method originally found to work from a Russian site. The readings are spot on from the start.

    Now that they work, I need to figure out if there is a workaround for the 3.3v transceiver node....
    Phew....


  • Hero Member

    @zboblamont it certainly has been a bumpy road for you. good to see you making some headway.



  • I've been fighting with DYP-ME007Y myself for the last few days...
    Originally i wanted to monitor the level of a water tank with an SR04 ; as it is not waterproof i assumed that it would die fairly quickly.
    So i ordered a DYP-ME007... but the last letter ("Y") means that it uses serial communication, so the ping Library doesn't apply.
    Bouncing from site to site i found the following code that @zboblamont refers to :

    #include <SoftwareSerial.h>
    
    SoftwareSerial mySerial =  SoftwareSerial(10,11); 
    
    #define echoPin 10
    #define trigPin 11
    
    unsigned int reading;
    byte readByte;
    byte read_buffer[4]; 
    byte crcCalc;
    word distance;
    String outText;
    
    void setup() {
      mySerial.begin (9600);
    
      Serial.begin (9600);
      Serial.println("start");
      for (byte loopstep = 0; loopstep <= 3; loopstep++) {
        read_buffer[loopstep] = 0;
      }
    }
    
    void loop() {
      if (mySerial.available() < 1) {
        return;  
      }
      readByte = mySerial.read();
      
      for (byte loopstep = 0; loopstep <= 2; loopstep++) {
        read_buffer[loopstep] = read_buffer[loopstep + 01];
      }
      read_buffer[03] = readByte;   
      if (read_buffer[00] != 0xff) {
        return;
      };
      crcCalc = read_buffer[00] + read_buffer[01] + read_buffer[02];
      if (read_buffer[03] != crcCalc) {
        return;
      };
      distance = (read_buffer[01] * 0xff) + read_buffer[02];
      outText = "bytes: ";
      outText = String(outText + read_buffer[00]);
      outText = String(outText + "+");
      outText = String(outText + read_buffer[01]);
      outText = String(outText + "+");
      outText = String(outText + read_buffer[02]);
      outText = String(outText + "+");
      outText = String(outText + read_buffer[03]);
      outText = String(outText + " = ");
      outText = String(outText + distance);
      outText = String(outText + " mm");
      
      Serial.println(outText);
    
      delay(1000);
    
      while (mySerial.available() > 0) {
         readByte = mySerial.read();
      }
    }
    

    Worked first shot



  • @ben999 So glad it worked, I tormented myself as a newbie in Arduinoworld. I didn't realise that the 'Y' was significant though, I recall others saying it fitted NewPing like a glove...
    I don't think it helps when there are so many conflicting model numbers for completely (physically) different devices...
    Hey ho....



  • hi folks, received my DYP-ME007Y finally, tried it and got the same inconsistent readings with the old sketch that @zboblamont and others reported. I was excited to see the code that @ben999 found and tested successfully - but I don't even get past the "start" print out in the serial monitor. the LED on the DYP board is flashing eagerly, but it doesn't look like it gets any readings... Have you guys changed anything else to get it t work?



  • update: we're getting there... after a bit a tweaking and trying different angles, I'm now getting readings. The good news: in one position, when readings come in, they are consistent. The bad news: as soon as I move the sensor head, it's a gamble, in some cases the readings are o.k., in other cases it drops to 0mm... Anybody has seen a similar effect?



  • @jjk sensor head need to be perpendicular to surface being measured?



  • @jjk If the readings you ARE getting are accurate when moved to new positions, it could as @ben999 said be inaccurate alignment to the reflective surface, or as was commented somewhere else, the plug/socket on the board being loose.
    With a 3/4 to 1/2 reducer on a 1/2 pipe ready here for final installation, I sat transducer the socket to take out movement or alignment issues, it drifts off quite readily if angle is wrong. The code Ben refers to for this DYP gave me a slightly lower but not silly first reading then consistent results thereafter, no zeroes.

    Please note that I had tried all 6 sketch variants on the 3.3v device with a 5v DYP supply and got nonsense. Using the 3.3v Trig with drop resistors on the Echo neither the JSN nor the DYP worked properly despite the 5v power from the separate booster supply to them.
    I only found consistency using a 5v pro-mini, with the DYP power supplied from logic pins, which leads me to think Trig and/or Echo are also 5v sensitive, contradicting previous advice and complicating my layout.

    Have not yet got round to trialling a logic converter from the 3.3v pro-mini for Trig and Echo with the original 5v supply, which is the next step, will report back once I get some time to test.



  • @ben999 and @zboblamont thanks for the swift feedback and advice. I think you are right, the DYP seems to be VERY sensitive to alignment. The tests I did were "handheld" and readings jumped arbitrarily btw zeroes, accurate, and off values. I've done a few tests now with the sensor head fixed and more aligned to the target surface and that seems to work out much better now. I also found that readings get less accurate above 1m, though?!



  • btw. I'm using a pro mini 5V to power and trigger the DYP at the moment. Have played with an external 5V supply, but that didn't seem to make a noticeable difference.



  • @jjk Sounds like you're getting there, it should be no problem with the 5v pro-mini, the only variables should be alignment and sketches.

    To clarify, I only got a 5v pro-mini to figure out whether the DYP and JSN devices would work, which they did after trying different sketches. Those same sketches had retrieved garbage on the 3.3v pro-mini, despite a separate 5v supply to the DYP, running contrary to experience of others. That supply was unnecessary with the 5v pro-mini.

    As the 3.3v is the intended battery powered radio node, I need the DYP to work with it, hence the logic level converter being the next attempt to get the DYP to work with the node.



  • DYP measuring range starts at 30cm -ish

    When water tank is full-up, water level is near the top of the cistern...

    So to achieve the minimum reading distance I used a big PVC pipe placed vertically on top of cistern (about 30cm) through a hole...
    I went from 5cm to 8cm but no luck : I guess there must be some "echo" in the pipe that fools the reading...

    I will end-up with a plastic bucket (dia 30cm height 30cm) on top of cistern opening (not tested yet)

    Final word : be aware of confined spaces, that sensor is kind of claustrophobic πŸ˜‰



  • I don't quite like the idea of the DYP board being powered full-time...
    It "ticks" every one second and i only need a few updates of water level per day.

    I would like to power it via a transistor (itself being triggered by arduino)

    What would be your thoughts on that ?

    • powering that board say 4 times a day for 10 seconds would be more deadly than being powered on all the time ?
    • looks like the serial "conversation" kicks-in as soon as power is applied to the board... could it damage either board if serial link is cut anytime ?
    • DYP board uses on average less than 15mA. What transistor would be a good contender for that job ?

    Thanks again for reading and thanks even more for your input πŸ™‚



  • @ben999 Surprised if you are getting echoes in a pipe, there are no surfaces to reflect the signal. Both the tanks I am looking to monitor are quite big, I might have to use a pipe in the water tank as it is a plastic moulding which has vertical facing flats on the ribs. Will report back once tested in place.

    I looked at transistor switching the device due to RTC and radio occupying all but 4 analogue lines on the node, but there were reportedly some issues with switching ground, so I settled on the latching dpdt relay I posted further up the thread. It needs two pins to open or close by changing outputs from high to low. It opened or closed in less than 30ms, about 33mA from memory, zero consumption once latched.

    In my own case the node is 3.3v, the 5v boosted line for the DYP power was originally controlled by the relay.
    Having established now that the DYP requires a 5v trig/echo, the relay is being reworked so one contact switches the 3.3v the other the 5v to power both the DYP and the level switcher, hopefully resolving earlier failures.



  • Hi Everyone,

    Just trying to get everything set back up correctly and I def have something wrong, my distance sensors show Zero.
    0 MCO:BGN:INIT NODE,CP=RNNNA--,VER=2.1.1
    3 TSM:INIT
    4 TSF:WUR:MS=0
    11 TSM:INIT:TSP OK
    13 TSF:SID:OK,ID=254
    15 TSM:FPAR
    51 TSF:MSG:SEND,254-254-255-255,s=255,c=3,t=7,pt=0,l=0,sg=0,ft=0,st=OK:
    2059 !TSM:FPAR:NO REPLY
    2061 TSM:FPAR
    2097 TSF:MSG:SEND,254-254-255-255,s=255,c=3,t=7,pt=0,l=0,sg=0,ft=0,st=OK:
    2615 TSF:MSG:READ,0-0-254,s=255,c=3,t=8,pt=1,l=1,sg=0:0
    2620 TSF:MSG:FPAR OK,ID=0,D=1
    4105 TSM:FPAR:OK
    4106 TSM:ID
    4107 TSM:ID:OK
    4109 TSM:UPL
    4118 TSF:MSG:SEND,254-254-0-0,s=255,c=3,t=24,pt=1,l=1,sg=0,ft=0,st=OK:1
    4128 TSF:MSG:READ,0-0-254,s=255,c=3,t=25,pt=1,l=1,sg=0:1
    4133 TSF:MSG:PONG RECV,HP=1
    4136 TSM:UPL:OK
    4137 TSM:READY:ID=254,PAR=0,DIS=1
    4150 TSF:MSG:SEND,254-254-0-0,s=255,c=3,t=15,pt=6,l=2,sg=0,ft=0,st=OK:0100
    4157 TSF:MSG:READ,0-0-254,s=255,c=3,t=15,pt=6,l=2,sg=0:0100
    4166 TSF:MSG:SEND,254-254-0-0,s=255,c=0,t=17,pt=0,l=5,sg=0,ft=0,st=OK:2.1.1
    4177 TSF:MSG:SEND,254-254-0-0,s=255,c=3,t=6,pt=1,l=1,sg=0,ft=0,st=OK:0
    4211 TSF:MSG:READ,0-0-254,s=255,c=3,t=6,pt=0,l=1,sg=0:M
    4234 TSF:MSG:SEND,254-254-0-0,s=255,c=3,t=11,pt=0,l=15,sg=0,ft=0,st=OK:Distance Sensor
    4246 TSF:MSG:SEND,254-254-0-0,s=255,c=3,t=12,pt=0,l=3,sg=0,ft=0,st=OK:1.0
    4265 TSF:MSG:SEND,254-254-0-0,s=1,c=0,t=15,pt=0,l=0,sg=0,ft=0,st=OK:
    4272 MCO:REG:REQ
    4282 TSF:MSG:SEND,254-254-0-0,s=255,c=3,t=26,pt=1,l=1,sg=0,ft=0,st=OK:2
    4289 TSF:MSG:READ,0-0-254,s=255,c=3,t=27,pt=1,l=1,sg=0:1
    4294 MCO:PIM:NODE REG=1
    4296 MCO:BGN:STP
    4298 MCO:BGN:INIT OK,TSP=1
    Ping: 0 cm
    4336 MCO:SLP:MS=5000,SMS=0,I1=255,M1=255,I2=255,M2=255
    4341 MCO:SLP:TPD
    4343 MCO:SLP:WUP=-1
    Ping: 0 cm
    4380 MCO:SLP:MS=5000,SMS=0,I1=255,M1=255,I2=255,M2=255
    4386 MCO:SLP:TPD
    4387 MCO:SLP:WUP=-1
    Ping: 0 cm
    4425 MCO:SLP:MS=5000,SMS=0,I1=255,M1=255,I2=255,M2=255
    4430 MCO:SLP:TPD

    Any idea why? Pins are set correctly 5 and 6.

    Thanks



  • @Newzwaver which sensor are you using? And which library?



  • Thanks for the reply, I am using the HC SR04



  • @ben999 Finally good news at least on getting the DYP-SR04T-2.0 to behave with the 3.3v Pro Mini, currently arrangement like wire spaghetti. How it all fits in the weatherproof box is another day's work, as is coding it up to send hourly data back to the Gateway.

    Earlier trials using the 5v Mini worked perfectly, so ended up with latching relay and booster on separate battery pack, unfortunately I did not realise the complications of using a single coil latching relay on the Arduino.

    Needed to get some work done on the house, so delayed getting back to until last week.

    So the working hardware is now 10k resistor to DIODES DMG6968U-7 switching a NEC EE2-3TNU double coil relay, a level converter for trig/echo, and a 5v booster to power the ultrasonic. Works fine now even though the first reading is still always a Zero.
    Relay switch on and switch off is less than 10ms- Arduino and low current..
    0_1504352019537_WP_20170902_13_56_09_Pro[1].jpg



  • @ben999 As a postscript to the above, I puzzled over how quickly I could get a valid result before being able to power down the secondary circuit of relay, booster, level converter etc...

    I looked at the results coming in (in this case from the JSN sensor) and read up on median analysis and gave up pretty quickly on that level of sophistication, as I realised only the first result was incorrect, that puzzling zero, all the rest were consistent and repetitive.

    Inserting a while statement in the Void Setup (instead of the forever version in the Void Loop) checking the time duration < 1, I got a valid result immediately after the first ping, and the secondary circuit could be shut down.

    As I only need one valid result to switch the relay off and radio the reading in once and hour, this seems to satisfy my requirements while limiting power drain on the secondary circuit.



  • I had to add some lines to the sample sketch to get console printouts:

    #include <SoftwareSerial.h>

    and in the void setup():
    Serial.begin(115200);

    Is everybody so specialized that they see immediately this omission? πŸ™‚


  • Mod

    @peerv strange. Those lines should not be needed. I've never had to add them.

    What board are you using? Did you change anything in the example sketch?



  • I am using a Nano V3.
    Apart from the above lines I didn't change anything in the sketch.
    Before the change I only got debug messages and no Serial.print lines!

    Is the SoftwareSerial.h included in one of the other libraries?


  • Mod

    @peerv SoftwareSerial should not be needed at all, the hardware serial is used.



  • Thanks. Due to some bad dupont cable connection the program was not entering the void loop() and not printing to the console. Was not aware about a hardware serial print. It is stable now.



  • Found a new distance sensor HC-SR04P .
    De spec shows that the input voltage of this model is 3-5V. So this model can be used with a 3.3V arduino.
    https://www.aliexpress.com/snapshot/0.html?spm=a2g0s.9042647.6.2.1AslKf&orderId=89862296499774&productId=32711959780


  • Banned

    Sorry for bumping up an old question but I’m in the same boat of requirement.

    And to my surprise there are quite a few new sensors in town:

    This one has 2 transducers instead of 1 therefore has less minimum detection distance as compared to JSN SR04T. It is also completely sealed and waterproof.

    Ebay spam link removed by moderator

    Before finalizing on this I had bought another one which was a waterproof modified version of HC-SR04 from here

    Ebay spam link removed by moderator

    The 1st one is much more rugged and waterproof as compared to the latter one



  • @ritesh-t Dual sensor types were the first on the market, send on one sensor receive on the other from memory, but could suffer in high water vapour Zones.
    The single sensor types switches between send and receive on the same head, commonly used as car parking sensors.

    The cheaper one you show has exposed diaphragms and says it is water resistant not waterPROOF πŸ˜‰
    Aside the smaller deadband of 3cm the more expensive one used more robust moulded sensors but steep on price, 3 times the JSN single sensor head device, but 20cm deadband is adequate for my use.
    Both need 5v supply same as the JSN single sensor type, for a 3.3v Node this adds complication.



  • Are there any tricks to configure one node with two distance sensors? I tried, it generally works, shows two distances, but periodically shows first or second distance =0



  • Actually, even when I use this example without any changes with single sensor, quite often node sends out 0cm. Real distance in my office from table top to ceiling is about 160cm. Maximum distance set to 300.



  • @apl2017 There are many techniques to get avoid bogus or wrong results, assuming there are no environmental effects (reflective side objects to make readings difficult).
    On the setup here the sensor is a single transducer, and the sketch is a basic single pulse, time the echo to calculate the distance, with a sufficient delay to ensure the preceding pulse has decayed (hard surface underground tank) - The sketch tests for two consective results within the expected range, if it does not succeed in X attempts it does not update the Gateway and goes back to sleep for the next event, hence not flattening batteries.



  • zboblamont . Thank you, I understand all of this except I really don't see in sketch testing of two consecutive results in X attempts. I see that node will wake up and update the distance if new data is different than old data, but, anyway, question was about something different. Why, single sensor node based on this example periodically generates 0 distance? Are there different models of these sensors, so NewPing library needs to be altered?



  • @apl2017 Verifying the reading is something you have to write into the sketch yourself, nothing complicated. I didn't use a library so no idea what advantage it brings over the simple timing method. Because I only take readings every hour triggered by an RTC, I don't care if it is the same as previous, only that it is valid in which case it is sent in.
    Parts of my sketch follow, all fairly self-explanatory, perhaps they are of some use.
    Main loop - Call subroutine and test to ensure it lies between two values, up to 10 attempts allowed to get a proper reading.

    while ((tankdepth<350||tankdepth>1000)&&counter<=10){//10 attempts to get proper range
       READULTRASONIC();
       counter++;
       } 
    

    The READULTRASONIC subroutine uses the simple timing method to get the 2 consecutive readings.

      void READULTRASONIC(){//JSN-SR04-2.0
    //Main loop checks valid range on a defined number of readings
      tankdepth=0;
      duration=0;
      distance=0;
      test=1;
      test2=3;
    // Normal range should lie between 389 and 989 absolutely empty is 1520
    while (test!=test2){// Get two consecutive readings
      digitalWrite(Trigpin, LOW);
      delayMicroseconds(100);
      digitalWrite(Trigpin, HIGH);
      delayMicroseconds(150);
      digitalWrite(Trigpin, LOW);
      duration = pulseIn(Echopin, HIGH);
      distance = duration/5.82;//This is in mm
     if (test!=distance){
        test=distance;
        distance=0;
       }
       else{
        test2=distance;
      }
      delay(100);///// 500 originally but why???????
      }
      tankdepth=distance;
     }
    

    There are many version of these sensors, neither of the two I trialled reliably ran unless on 5v, which made it bit more complicated for a 3.3v Node.
    One operated on softserial from memory, but I couldn't get it to do what I wanted, I settled on the one which allows straightforward timing.

    When I was first testing these, the first reading would always be a zero for reasons unknown, then solid readings, but the 2 consecutive readings test worked for me.



  • @zboblamont Thanks, you are proposing to filter out wrong reading, I am trying to understand why system periodically sends out 0.



  • @apl2017 Understood, good luck finding out whether environment, hardware, software, in isolation or combination are the cause.
    As said previously, aside the leading zero, the arrangement and technique here returns stable readings, the only critical aspect found was need of a solid 5v.
    The only anomaly found were a condensation drip on the sensor face at below -10 outside air temp, hence the 10 attempts limitation.
    Good luck



  • @APL2017 Did you find the reason for this problem of reading periodically 0cm?
    I have the same problem with a Arduino Uno connected to a HC-SR04 sensor. (in reality I made two sensors and both have regularly 0cm as output)
    I can blindly adapt the software to filter out these strange values, but like you, I prefer to understand why this behaviour?



  • Maybe replying to myself : I read just in the sensor example:

      int dist = metric?sonar.ping_cm():sonar.ping_in();
      Serial.print("Ping: ");
      Serial.print(dist); // Convert ping time to distance in cm and print result (0 = outside set distance range)
      Serial.println(metric?" cm":" in");
    

    0 = outside set distance range
    Good chance that this is the reason...



  • @mfalkvidd Should we not adapt the example sketch to include this problem of returning a zero?
    I did configure an automatisation in my controller when the distance was less than 10 cm, so it was fired regularly because 0cm was sent as message from the sensor node.
    Change following code:

      if (dist != lastDist) {
          send(msg.set(dist));
          lastDist = dist;
      }
    

    to

      if (dist != lastDist && dist != 0) {
          send(msg.set(dist));
          lastDist = dist;
      }
    

    The '0' means here that an error is fired inside the newping library, not that the distance is 0cm.


  • Mod

    @evb sorry, I have no experience with this sensor so I can’t give much input.



  • @evb That looks good - You could even add and 'else' statement to send an error message too...



  • @evb Having had various problems with two US devices using the ping library, found the simpler timing method gave consistent results after only an initial false.
    Setting the upper and lower thresholds in the sketch (if that is appropriate - viz tanks) and checking for two consecutive readings within that over up to 10 attempts then validates the value, only then reporting the result. Converting the distance to mm is perhaps overkill, but for me it works 99.99% of the time.



  • do as Zboblamont suggest.
    I have my distance sensor to measure in a loop until 3 last measurements are equal. Unfortunately it's a few years ago so I no longer have the code



  • I did some research and the myssensors documentation should be updated...
    @mfalkvidd I saw that you updated as latest person the example one year ago.
    Maybe you could now mentioning the newer lib?

    The example is linking to an old legacy implementation of the NewPing library version 1.5.
    This example uses the external NewPing library found here. Please install it and restart the Arduino IDE before trying to compile.
    Better is to use the standard way in Arduino IDE to add the latest version of the NewPing library, now at version 1.9.1.
    You can find information about this lib : https://bitbucket.org/teckel12/arduino-new-ping/wiki/Home

    I changed the implementation to use the ping_median method provided by the lib author
    sonar.ping_median(iterations [, max_cm_distance]) - Do multiple pings (default=5), discard out of range pings and return median in microseconds. [max_cm_distance] allows you to optionally set a new max distance.

    Using this method will discard out the spikes and out of ranges of the ultrasonic sensors.

    /**
     * The MySensors Arduino library handles the wireless radio link and protocol
     * between your home built sensors/actuators and HA controller of choice.
     * The sensors forms a self healing radio network with optional repeaters. Each
     * repeater and gateway builds a routing tables in EEPROM which keeps track of the
     * network topology allowing messages to be routed to nodes.
     *
     * Created by Henrik Ekblad <henrik.ekblad@mysensors.org>
     * Copyright (C) 2013-2015 Sensnology AB
     * Full contributor list: https://github.com/mysensors/Arduino/graphs/contributors
     *
     * Documentation: http://www.mysensors.org
     * Support Forum: http://forum.mysensors.org
     *
     * This program is free software; you can redistribute it and/or
     * modify it under the terms of the GNU General Public License
     * version 2 as published by the Free Software Foundation.
     *
     *******************************
     *
     * REVISION HISTORY
     * Version 1.0 - Henrik EKblad
     * Version 1.1 - Eric Van Bocxlaer - Use of the ping_median method of the NewPing library
     * 
     * DESCRIPTION
     * This sketch provides an example how to implement a distance sensor using HC-SR04 
     * http://www.mysensors.org/build/distance
     */
    
    // Enable debug prints
    //#define MY_DEBUG
    //#define MY_DEBUG_VERBOSE_RFM69
    
    #define MY_NODE_ID 1  // set the node ID manually because a MQTT gateway with Home Assistant as controller will not assign automatically a node Id - this must be set before the mysensors.h call
    
    // Enable and select radio type attached
    #define MY_RADIO_RFM69
    #define MY_RFM69_FREQUENCY RFM69_868MHZ // Set your frequency here
    #define MY_IS_RFM69HW // Omit if your RFM is not "H"
    #define MY_RFM69_NEW_DRIVER
    
    //enable radio communication encryption
    //enable simple signing and encryption
    #define MY_SECURITY_SIMPLE_PASSWORD "my32bitpassword"
    
    #include <SPI.h>
    #include <MySensors.h>  
    #include <NewPing.h>
    
    #define SENSOR_NAME "Distance Sensor"
    #define SENSOR_VERSION "1.1"
    
    #define CHILD_ID 1  // Each radio node can report data for up to 254 different child sensors. You are free to choose the child id yourself. 
                        // You should avoid using child-id 255 because it is used for things like sending in battery level and other (protocol internal) node specific information.
    #define TRIGGER_PIN  6  // Arduino pin tied to trigger pin on the ultrasonic sensor.
    #define ECHO_PIN     5  // Arduino pin tied to echo pin on the ultrasonic sensor.
    #define MAX_DISTANCE 300 // Maximum distance we want to ping for (in centimeters). Maximum sensor distance is rated at 400-500cm.
    unsigned long SLEEP_TIME = 30000; // Sleep time between reads (in milliseconds)
    
    NewPing sonar(TRIGGER_PIN, ECHO_PIN, MAX_DISTANCE); // NewPing setup of pins and maximum distance.
    MyMessage msg(CHILD_ID, V_DISTANCE);
    int lastDist;
    bool metric = true;
    
    void setup()  
    { 
      metric = getControllerConfig().isMetric;
    }
    
    void presentation() {
      // Send the sketch version information to the gateway and Controller
      sendSketchInfo(SENSOR_NAME, SENSOR_VERSION);
    
      // Register all sensors to gw (they will be created as child devices) by their ID and S_TYPE
      present(CHILD_ID, S_DISTANCE);
    }
    
    void loop()      
    { 
      // use the build-in digital filter to discard out of range pings
      int echoTime = sonar.ping_median(10);
      int dist = metric?sonar.convert_cm(echoTime):sonar.convert_in(echoTime);
      Serial.print("Ping: ");
      Serial.print(dist);
      Serial.println(metric?" cm":" in");
    
      if (dist != lastDist) {
          send(msg.set(dist));
          lastDist = dist;
      }
    
      sleep(SLEEP_TIME);
    }
    

    Pay attention that I use the RFM69 radio, so adapt this if you are using another radio.
    Also disable signing and encryption if you don't use it (you should!)
    Adapt sleep time if you want more than 2 readings per minute.



  • @evb No I did not. I was thinking about filtering out obviously wrong readings, but never implemented it since it was not high priority project. I am glad that there is some activity going on related to this issue.


Log in to reply
 

Suggested Topics

  • 152
  • 10
  • 231
  • 4
  • 103
  • 54
  • 40
  • 1054

4
Online

9.4k
Users

10.0k
Topics

104.3k
Posts