Unstable radio connection.



  • I've been trying to set the connection for a good while already but I keep facing multiple problems. I use 10uF caps instead of 4,7uF recommended. I also use nRF24L01+PA+LNa version. I assign a static node id to both the gateway (I have a sensor connected) and to the node.

    Here is the log

    72816 TSM:FAIL:RE-INIT
    72818 TSM:INIT
    72825 TSM:INIT:TSP OK
    72827 TSM:INIT:STATID=7
    72829 TSF:SID:OK,ID=7
    72832 TSM:FPAR
    72868 TSF:MSG:SEND,7-7-255-255,s=255,c=3,t=7,pt=0,l=0,sg=0,ft=0,st=OK:
    74876 !TSM:FPAR:NO REPLY
    74878 TSM:FPAR
    74915 TSF:MSG:SEND,7-7-255-255,s=255,c=3,t=7,pt=0,l=0,sg=0,ft=0,st=OK:
    76922 !TSM:FPAR:NO REPLY
    76924 TSM:FPAR
    76960 TSF:MSG:SEND,7-7-255-255,s=255,c=3,t=7,pt=0,l=0,sg=0,ft=0,st=OK:
    78968 !TSM:FPAR:NO REPLY
    78970 TSM:FPAR
    79006 TSF:MSG:SEND,7-7-255-255,s=255,c=3,t=7,pt=0,l=0,sg=0,ft=0,st=OK:
    81014 !TSM:FPAR:FAIL
    81015 TSM:FAIL:CNT=5
    81017 TSM:FAIL:PDT
    91020 TSM:FAIL:RE-INIT
    91022 TSM:INIT
    91029 TSM:INIT:TSP OK
    91031 TSM:INIT:STATID=7
    91033 TSF:SID:OK,ID=7
    91035 TSM:FPAR
    91072 TSF:MSG:SEND,7-7-255-255,s=255,c=3,t=7,pt=0,l=0,sg=0,ft=0,st=OK:
    93079 !TSM:FPAR:NO REPLY
    93081 TSM:FPAR
    93117 TSF:MSG:SEND,7-7-255-255,s=255,c=3,t=7,pt=0,l=0,sg=0,ft=0,st=OK:
    95125 !TSM:FPAR:NO REPLY
    95127 TSM:FPAR
    95163 TSF:MSG:SEND,7-7-255-255,s=255,c=3,t=7,pt=0,l=0,sg=0,ft=0,st=OK:
    97171 !TSM:FPAR:NO REPLY
    97173 TSM:FPAR
    97209 TSF:MSG:SEND,7-7-255-255,s=255,c=3,t=7,pt=0,l=0,sg=0,ft=0,st=OK:
    99217 !TSM:FPAR:FAIL
    99218 TSM:FAIL:CNT=6
    99220 TSM:FAIL:PDT
    109223 TSM:FAIL:RE-INIT
    109225 TSM:INIT
    109233 TSM:INIT:TSP OK
    109235 TSM:INIT:STATID=7
    109237 TSF:SID:OK,ID=7
    109240 TSM:FPAR
    109276 TSF:MSG:SEND,7-7-255-255,s=255,c=3,t=7,pt=0,l=0,sg=0,ft=0,st=OK:
    109739 TSF:MSG:READ,0-0-7,s=255,c=3,t=8,pt=1,l=1,sg=0:0
    109744 TSF:MSG:FPAR OK,ID=0,D=1
    110668 TSF:MSG:READ,0-0-7,s=255,c=3,t=8,pt=1,l=1,sg=0:0
    111284 TSM:FPAR:OK
    111285 TSM:ID
    111287 TSM:ID:OK
    111288 TSM:UPL
    111292 TSF:MSG:SEND,7-7-0-0,s=255,c=3,t=24,pt=1,l=1,sg=0,ft=0,st=OK:1
    111503 TSF:MSG:READ,0-0-7,s=255,c=3,t=8,pt=1,l=1,sg=0:0
    111508 !TSF:MSG:FPAR INACTIVE
    111520 TSF:MSG:READ,0-0-7,s=255,c=3,t=25,pt=1,l=1,sg=0:1
    111525 TSF:MSG:PONG RECV,HP=1
    111528 TSM:UPL:OK
    111531 TSM:READY:ID=7,PAR=0,DIS=1
    111535 TSF:MSG:SEND,7-7-0-0,s=255,c=3,t=15,pt=6,l=2,sg=0,ft=0,st=OK:0100
    113544 TSF:MSG:SEND,7-7-0-0,s=255,c=0,t=17,pt=0,l=10,sg=0,ft=0,st=OK:2.1.0-beta
    113552 TSF:MSG:SEND,7-7-0-0,s=255,c=3,t=6,pt=1,l=1,sg=0,ft=0,st=OK:0
    Send Sketch Info: 
    115598 !TSF:MSG:SEND,7-7-0-0,s=255,c=3,t=11,pt=0,l=10,sg=0,ft=0,st=NACK:RADIOTEST 
    115642 !TSF:MSG:SEND,7-7-0-0,s=255,c=3,t=12,pt=0,l=2,sg=0,ft=1,st=NACK:v1
    RADIOTEST v1
    Get Config: Metric
    Presenting Nodes
    ________________
      S_TEMP
    116691 !TSF:MSG:SEND,7-7-0-0,s=1,c=0,t=6,pt=0,l=16,sg=0,ft=2,st=NACK:House Temperarue
    ________________
    116750 MCO:REG:REQ
    116788 !TSF:MSG:SEND,7-7-0-0,s=255,c=3,t=26,pt=1,l=1,sg=0,ft=3,st=NACK:2
    118830 !TSF:MSG:SEND,7-7-0-0,s=255,c=3,t=26,pt=1,l=1,sg=0,ft=4,st=NACK:2
    120871 !TSF:MSG:SEND,7-7-0-0,s=255,c=3,t=26,pt=1,l=1,sg=0,ft=5,st=NACK:2
    120879 !TSM:READY:UPL FAIL,SNP
    120882 TSM:FPAR
    120918 TSF:MSG:SEND,7-7-255-255,s=255,c=3,t=7,pt=0,l=0,sg=0,ft=6,st=OK:
    122880 !TSF:SND:TNR
    122926 !TSM:FPAR:NO REPLY
    122928 TSM:FPAR
    122964 TSF:MSG:SEND,7-7-255-255,s=255,c=3,t=7,pt=0,l=0,sg=0,ft=0,st=OK:
    126882 !TSM:FPAR:NO REPLY
    126884 TSM:FPAR
    126921 TSF:MSG:SEND,7-7-255-255,s=255,c=3,t=7,pt=0,l=0,sg=0,ft=0,st=OK:
    128928 !TSM:FPAR:NO REPLY
    128930 TSM:FPAR
    128967 TSF:MSG:SEND,7-7-255-255,s=255,c=3,t=7,pt=0,l=0,sg=0,ft=0,st=OK:
    130974 !TSM:FPAR:FAIL
    130976 TSM:FAIL:CNT=1
    130978 TSM:FAIL:PDT
    140981 TSM:FAIL:RE-INIT
    

    Some times I do have a connection but it usually doesn't last for a long time. Here is my gateway log:

    0;255;3;0;9;MCO:BGN:INIT GW,CP=RNNGA--,VER=2.1.0-beta
    0;255;3;0;9;TSM:INIT
    0;255;3;0;9;TSF:WUR:MS=0
    0;255;3;0;9;TSM:INIT:TSP OK
    0;255;3;0;9;TSM:INIT:GW MODE
    0;255;3;0;9;TSM:READY:ID=0,PAR=0,DIS=0
    0;255;0;0;18;2.1.0-beta
    0;2;0;0;6;
    0;255;3;0;14;Gateway startup complete.
    0;255;0;0;18;2.1.0-beta
    0;2;0;0;6;
    0;255;3;0;9;MCO:BGN:STP
    0;255;3;0;9;MCO:BGN:INIT OK,TSP=1
    Temperature is: 28.06
    0;2;1;0;0;28.06
    0;255;3;0;9;TSF:MSG:READ,7-7-255,s=255,c=3,t=7,pt=0,l=0,sg=0:
    0;255;3;0;9;TSF:MSG:BC
    0;255;3;0;9;TSF:MSG:FPAR REQ,ID=7
    0;255;3;0;9;TSF:PNG:SEND,TO=0
    0;255;3;0;9;TSF:CKU:OK
    0;255;3;0;9;TSF:MSG:GWL OK
    0;255;3;0;9;!TSF:MSG:SEND,0-0-7-7,s=255,c=3,t=8,pt=1,l=1,sg=0,ft=0,st=NACK:0
    0;255;3;0;9;MCO:BGN:INIT GW,CP=RNNGA--,VER=2.1.0-beta
    0;255;3;0;9;TSM:INIT
    0;255;3;0;9;TSF:WUR:MS=0
    0;255;3;0;9;TSM:INIT:TSP OK
    0;255;3;0;9;TSM:INIT:GW MODE
    0;255;3;0;9;TSM:READY:ID=0,PAR=0,DIS=0
    0;255;0;0;18;2.1.0-beta
    0;2;0;0;6;
    0;255;3;0;14;Gateway startup complete.
    0;255;0;0;18;2.1.0-beta
    0;2;0;0;6;
    0;255;3;0;9;MCO:BGN:STP
    0;255;3;0;9;MCO:BGN:INIT OK,TSP=1
    Temperature is: 28.13
    0;2;1;0;0;28.13
    
    

    Any help would be appreciated!


  • Hero Member

    @Nikita Do you power the nRF24L01+PA+LNa from its own supply, they can draw too much for for the arduino 3v regulator and become unstable.
    Have you tried a standard nrf24l01+ to see if that improves reliability. is the distance too great between the nodes, can you try them close together. Being too close can also cause trouble as well.
    There have been several threads on range/reception issues, have a look at these and see if you can find some help. I know the ugly fix made a huge difference for my nRF24L01+PA+LNa nodes.

    Also you can see

    Which are the best NRF24L01+ modules?

    NRF24l01+ vs. NRF24l01+ pa + lna

    NRF24L01 can't find parent on gateway



  • @Boots33 Thanks for such a detailed answer!

    I power my radio from the arduino unfortunately. Also I don't have other radio modules to test my project with. The distance between the node and the gateway is about 3m so it shouldn't be a problem. I covered my radios with foil to lower the interference. None of that really helped.

    There was one thing that actually worked. I have a sensor connected to the gateway that reads the temperature and sends it to itself. I use a serial-gateway to feed the data to the openhab installed on my pc. Once I disconnected this sensors from the gateway (so there is only one sensor total, on the node) everything worked fine 😕 I assume there was an interference with gateway's own messages. I thought that it was possible to have sensors connected to gateway but when I do so the connection becomes unstable.
    P.S. I also installed 47uF capacitor to the gateway, just in case.


  • Hero Member

    @Nikita said:

    I power my radio from the arduino unfortunately. Also I don't have other radio modules to test my project with.

    It may be worth getting a few of the non amplified nrf modules and 3v regulators so you can do some testing. The amplified versions should really have their own supply. You could also try forcing the nrf to low power mode

    // Enable and select radio type attached
    #define MY_RADIO_NRF24
    
    // Set LOW transmit power level as default
    #define MY_RF24_PA_LEVEL RF24_PA_LOW
    

    I covered my radios with foil to lower the interference. None of that really helped.

    I found with the foil covering you have to be very thorough, if you leave even the smallest of gaps it will allow some rf noise to escape and cause trouble. The foil must also be earthed by allowing it to touch the aerial socket. it took me a few attempts to get it right.

    This is where having an extra nrf module comes in handy. you can build a simple node to be used as a range tester and then you can see if your range has improved. have a look at this post for my tester. I found it very useful in working out where to place repeater nodes as well.

    There was one thing that actually worked. I have a sensor connected to the gateway that reads the temperature and sends it to itself. I use a serial-gateway to feed the data to the openhab installed on my pc. Once I disconnected this sensors from the gateway (so there is only one sensor total, on the node) everything worked fine 😕

    I can't be of much help there as I don't have any sensors on my gateway. Others do though without any problems so it should be ok. Perhaps the extra power draw of the sensors is enough to cause problems with the amplified nrf.



  • @Boots33 Thanks for advice! I will definitely get some extra non amplified nrf modules and think about having a separate power supply for my radio.


Log in to reply
 

310
Online

6.7k
Users

7.6k
Topics

80.4k
Posts

Looks like your connection to MySensors Forum was lost, please wait while we try to reconnect.