MySensors protocol page improvement recommendation
Hi MySensors team,
as I am working a lot with the MySensors library at the moment, I just found a little inconsistency between the API and the protocol documentation (https://www.mysensors.org/download/serial_api_20).
The documentation says that messages consists of these parts: node-id ; child-sensor-id ; message-type ; ack ; sub-type ; payload.
In the source code (class MyMessage.h) you don't use "message-type" and "sub-type" but instead "command" and "(message) type".
As I think the latter terms are more suitable for the protocol understanding I'd like to raise the discussion whether it would we better using "command-type" and "message-type" in the protocol documentation as well instead. Then docs and sources would be "in sync" again and I think the protocol structure would be even better understandable.
Finally another little improvement request: The protocol docs are still talking about "Serial Protocol - 2.0.x" - maybe you should update this to "2.x".
Nice, thanks for the quick response.
Another typo i think : for S_WATER_QUALITY you have V_STATUS but in V_STATUS line you don't reference S_WATER_QUALITY.
also found typo
V_STATUS missing S_BINARY, S_WATER_QUALITY
V_LIGHT missing S_BINARY
V_WATT missing S_BINARY, S_RGB_LIGHT, S_RGBW_LIGHT
V_PERCENTAGE missing S_COVER
V_TEMP missing S_WATER_QUALITY
S_HEATER missing V_STATUS, V_HVAC_SETPOINT_HEAT
S_HVAC missing V_STATUS, V_TEMP, V_HVAC_SPEED
V_HVAC_SETPOINT_COLD is missing