Paying peanuts



  • I have a breadboard with an arduino nano (funduino V.30) and an NRF240L1+ attached to it.
    It also has a a DHT22 attached to it and there is a MySensors Temperature and Humidity sensor.ino running fine and reporting to node-red/openhab
    However when i replace the funduino with a cheaper Nano (Gravitech v3.0) with the exact same sketch, there is a radio fail. Any Ideas please guys?



  • Are they both 3.3V? nrf24 needs 3.3V power supply..



  • 0_1486053334327_Nanosmall.jpg

    As far as i can tell they both have a 3.3v and 5v pins

    The one on the rightworks fine.



  • Although on closer inspection, it looks as though the one on the left 3.3v pin has no route to the chip.

    Do sellers make these with unconnected 3.3v pins?



  • 3.3 pin should be connected to a regulator on the back side.
    If you have a multimeter you can measure on 3.3 pin, if you don't have a multimeter use a led diode with a resistor



  • @flopp Ok Thanks, Ill try i with an LED later.



  • Ohh right, the nano, my head spins only around the mini pro at the moment. Sorry ^^

    Could you solve your problem?



  • I solved the problem by clearing the EEPROM. Then adding the 47uF CAP solved the next issue that sprung up.

    Never had to clear EEPROM on other boards

    Lesson learned. thanks for the responses guys 🙂



  • Good to know and good to hear. Have fun with your projects!


Log in to reply
 

401
Online

6.7k
Users

7.6k
Topics

80.3k
Posts

Looks like your connection to MySensors Forum was lost, please wait while we try to reconnect.