NRF24 i cant configure raspberry pi1



  • hello everbody, i need your help.
    I connect my NRF to Raspberrypi according the tutorial: https://www.mysensors.org/build/raspberry

    1 step i installed that line:
    git clone https://github.com/mysensors/MySensors.git --branch master

    OK

    2 step i wrote: cd MySensors

    but when i tried 3 step

    pi@hassbian:~ $ cd MySensors
    pi@hassbian:~/MySensors $ --my-transport=nrf24

    give this error:

    -bash: --my-transport=nrf24: command not found

    what can i do?

    thanks


  • Mod

    @Rodolfo-Vieira enter ./configure before you add all the parameters



  • @mfalkvidd

    pi@hassbian:~/MySensors $ ./configure
    [SECTION] Detecting target machine.
    [OK] machine detected: SoC=unknown, Type=unknown, CPU=armv6l.
    [SECTION] Checking GPIO Sysfs.
    [OK] /sys/class/gpio/export found
    [SECTION] Detecting SPI driver.
    [WARNING] No supported SPI driver detected.
    [SECTION] Detecting init system.
    [OK] init system detected: systemd.
    [SECTION] Saving configuration.
    [SECTION] Cleaning previous builds.
    [OK] Finished.
    pi@hassbian:~/MySensors $ --my-transport=nrf24
    -bash: --my-transport=nrf24: command not found

    the error continues


  • Mod

    @Rodolfo-Vieira put everything on the same line before you press enter :)



  • @Rodolfo-Vieira said in NRF24 i cant configure raspberry pi1:

    [SECTION] Detecting SPI driver.
    [WARNING] No supported SPI driver detected

    @mfalkvidd ahhhh ok :) sorry, now i can solve this problem:
    [SECTION] Detecting SPI driver.
    [WARNING] No supported SPI driver detected


  • Mod

    @Rodolfo-Vieira that is just a warning. What does it say after?



  • @mfalkvidd
    ok, already actived SPY
    [SECTION] Detecting target machine.
    [OK] machine detected: SoC=unknown, Type=unknown, CPU=armv6l.
    [SECTION] Checking GPIO Sysfs.
    [OK] /sys/class/gpio/export found
    [SECTION] Detecting SPI driver.
    [OK] SPI driver detected:SPIDEV.
    [SECTION] Detecting init system.
    [OK] init system detected: systemd.
    [SECTION] Saving configuration.
    [SECTION] Cleaning previous builds.
    [OK] Finished.

    now what the frequency i should in this line:
    --my-transport=rfm69 --my-rfm69-frequency=868 --my-is-rfm69hw

    remember i use nrf24 no rfm69


  • Mod

    @Rodolfo-Vieira none of the rfm parameters are applicable if you use the nrf24 radio.



  • @mfalkvidd
    ok thank you so...i make this:

    1 git clone https://github.com/mysensors/MySensors.git --branch master
    cd MySensors

    2 ./configure --my-transport=nrf24

    3 ./configure --my-gateway=ethernet --my-port=5003

    4 ./configure --my-gateway=ethernet --my-controller-ip-address=192.168.1.65

    5 make

    6 sudo ./bin/mysgw -h

    7 sudo ./bin/mysgw -d

    and i receive this:
    pi@hassbian:~/MySensors $ sudo ./bin/mysgw -d
    mysgw: Starting gateway...
    mysgw: Protocol version - 2.1.1
    mysgw: MCO:BGN:INIT GW,CP=RNNG---,VER=2.1.1
    mysgw: TSM:INIT
    mysgw: TSF:WUR:MS=0
    mysgw: !TSM:INIT:TSP FAIL
    mysgw: TSM:FAIL:CNT=1
    mysgw: TSM:FAIL:PDT
    mysgw: TSM:FAIL:RE-INIT
    mysgw: TSM:INIT
    mysgw: !TSM:INIT:TSP FAIL
    mysgw: TSM:FAIL:CNT=2
    mysgw: TSM:FAIL:PDT

    what is the problem?


  • Mod

    @Rodolfo-Vieira everything on a single line :)
    ./configure and then add all the options you want. Then press enter. Then run make.

    But it looks like the radio is not correctly wired. Could you post a photo?



  • @mfalkvidd lol ok, i am newbie sorry for the stupid acts.

    1 ./configure --my-transport=nrf24 --my-gateway=ethernet --my-port=5003 --my-gateway=ethernet --my-controller-ip-address=192.168.1.65

    2 make

    3 sudo ./bin/mysgw -h

    4 sudo ./bin/mysgw -d

    result:

    mysgw: Starting gateway...
    mysgw: Protocol version - 2.1.1
    mysgw: MCO:BGN:INIT GW,CP=RNNG---,VER=2.1.1
    mysgw: TSM:INIT
    mysgw: TSF:WUR:MS=0
    mysgw: !TSM:INIT:TSP FAIL
    mysgw: TSM:FAIL:CNT=1
    mysgw: TSM:FAIL:PDT


  • Mod

    TSM:INIT:TSP FAIL means the software is unable to communicate with the radio. That is usually due to the radio not being correctly wired. Could you post a photo?




  • Mod

    @Rodolfo-Vieira thanks. It will take me a while to compare to the wiring guide but I'll report as soon as I have mapped the colors.



  • @mfalkvidd ok no problem i waiting


  • Mod

    @Rodolfo-Vieira on raspberry pi 1, pin 15 is not gnd. Move it to pin 20 or one of the other gnd pins. Stop mysgw (ctrl+c) and start it again after you have switched pins.



  • @mfalkvidd you are correct. I confirm all the wires 5 times.
    but the error is the same.

    after that i changed my nrf for two other that i had, and the error is the same.

    exist any way to confirm if the nrf24 is working fine? may be my nrf are damaged. i dont know.

    edit: I tried to , connect POWER NRF24 to external power, and connect ground external power to ground raspberry pi.. and the result is the same.

    TSM:INIT:TSP FAIL


  • Mod

    @Rodolfo-Vieira do you mean that moving gnd on nrf24 from 19 to 20 on raspberry pi did not help?



  • @mfalkvidd
    yes i changed gnd As you told me,,,and not work.
    after that i confirm again all wires...and not work again.... then i connect more two nrf24...make sudo reboot
    and run sudo ./bin/mysgw -d

    but the error is the same,,, so a decide help with external source 3.3v

    i connected wire power nrf24 ---> power external source
    gnd powersource -------> other gnd raspberry pi

    sudo reboot again...
    after sudo ./bin/mysgw -d

    and the error is the same..... :(


  • Mod

    Sorry, I see now that I probably misinterpreted the photo.

    Cross-referencing your colors with the official wiring instructions is very tedious.

    But it looks like the wiring is indeed correct.


Log in to reply
 

Looks like your connection to MySensors Forum was lost, please wait while we try to reconnect.