NRF24L01+ problems in 2.1.1 and 2.2.0 Beta



  • Hello,

    I would like to submit a bug report for these libraries in the use of NRF24L01+ radio

    I have problems with NRF24L01+ on both 2.1.1 and 2.2.0 Beta

    I have installed a fresh RPI with all new libraries and trying to make a RPI Serial GW

    In 2.1.1 it doesn't start at all but in 2.2.0 it starts but in the log I constantly receive the following in the Domoticz log where I have added the GW

    I2017-10-09 19:25:12.306 MySensors: Gateway Version: 2.2.0-beta
    2017-10-09 19:25:12.306 Error: Serial Port closed!... Error: End of file
    2017-10-09 19:25:13.306 MySensors: retrying in 30 seconds...
    

    After a while I get the following in the console

    mysgw: TSF:MSG:READ,0-0-0,s=0,c=3,t=2,pt=0,l=11,sg=0:Get Version
    mysgw: !TSF:MSG:LEN,0!=18 
    

    The above points at something wrong with the radio connection

    I have tried 3 different radios but still no luck so I guess it has something to do with the libraries


  • Mod

    Did you try to compile it as ethernet gw?



  • This post is deleted!


  • @gohan Yes, I have tried compiling it as Ethernet GW but that didn't work either

    Output:

    mysgw: Starting gateway...
    mysgw: Protocol version - 2.2.0-beta
    mysgw: MCO:BGN:INIT GW,CP=RNNGL---,VER=2.2.0-beta
    mysgw: TSF:LRT:OK
    mysgw: TSM:INIT
    mysgw: TSF:WUR:MS=0
    mysgw: TSM:INIT:TSP OK
    mysgw: TSM:INIT:GW MODE
    mysgw: TSM:READY:ID=0,PAR=0,DIS=0
    mysgw: MCO:REG:NOT NEEDED
    mysgw: Listening for connections on 0.0.0.0:5003
    mysgw: MCO:BGN:STP
    mysgw: MCO:BGN:INIT OK,TSP=1
    mysgw: TSF:MSG:READ,0-0-0,s=0,c=0,t=0,pt=0,l=0,sg=0:
    mysgw: !TSF:MSG:LEN,0!=7
    mysgw: TSF:MSG:READ,0-0-0,s=0,c=0,t=0,pt=0,l=0,sg=0:
    mysgw: !TSF:MSG:LEN,0!=7
    mysgw: TSF:MSG:READ,0-0-0,s=0,c=0,t=0,pt=0,l=0,sg=0:
    mysgw: !TSF:MSG:LEN,0!=7
    mysgw: TSF:MSG:READ,0-0-0,s=0,c=0,t=0,pt=0,l=0,sg=0:
    mysgw: !TSF:MSG:LEN,0!=7
    mysgw: New connection from 127.0.0.1
    mysgw: Client 0 connected
    mysgw: Client 0: 0;0;3;0;2;
    mysgw: Client 0: 0;0;3;0;2;Get Version
    mysgw: Client 0: 0;0;3;0;18;PING
    mysgw: TSF:MSG:READ,0-0-0,s=0,c=3,t=18,pt=0,l=4,sg=0:PING
    mysgw: !TSF:MSG:LEN,0!=11
    mysgw: TSF:MSG:READ,0-0-0,s=0,c=3,t=18,pt=0,l=4,sg=0:PING
    mysgw: !TSF:MSG:LEN,0!=11
    
    

    Then the GW repeats the last 2 lines forever

    Compiled it with IP 127.0.0.1 for the controller and port 5003

    It does not pick up the sensors and values

    If I compile it with the local IP of the controller I get the following errors

    mysgw: Starting gateway...
    mysgw: Protocol version - 2.2.0-beta
    mysgw: MCO:BGN:INIT GW,CP=RNNGL---,VER=2.2.0-beta
    mysgw: TSF:LRT:OK
    mysgw: TSM:INIT
    mysgw: TSF:WUR:MS=0
    mysgw: TSM:INIT:TSP OK
    mysgw: TSM:INIT:GW MODE
    mysgw: TSM:READY:ID=0,PAR=0,DIS=0
    mysgw: MCO:REG:NOT NEEDED
    mysgw: connect: Connection refused
    mysgw: failed to connect
    mysgw: Eth: connect
    mysgw: connect: Connection refused
    

    After that the last 2 lines repeats forever


  • Mod

    @miljume 2.1.1 has been out for many months without problem, so it is not likely that there is a problem with the MySensors library. But you could of course have stumbled on a corner case that no-one has seen before.

    Could you post the full debug log for the gateway and the full configure command you used to compile it?

    Edit: sorry, I see that you have the full log in a later post. So just post the configure command and branch/version used for each output.



  • @mfalkvidd Sure, below are commands and debug logs for both 2.1.1 and 2.2.0 Beta

    As you can see both of the Gateways fails with 2.1.1. I have seen other people having the exact same problem so that is why I thought it could be something with the libraries

    Commands with 2.2.0 Beta (serial GW)

    ./configure --my-transport=nrf24
    ./configure --my-gateway=serial --my-serial-is-pty --my-serial-pty=/dev/ttyUSB020
    make
    

    Debug Log

    mysgw: Starting gateway...
    mysgw: Protocol version - 2.2.0-beta
    mysgw: MCO:BGN:INIT GW,CP=RNNGL---,VER=2.2.0-beta
    mysgw: TSF:LRT:OK
    mysgw: TSM:INIT
    mysgw: TSF:WUR:MS=0
    mysgw: TSM:INIT:TSP OK
    mysgw: TSM:INIT:GW MODE
    mysgw: TSM:READY:ID=0,PAR=0,DIS=0
    mysgw: MCO:REG:NOT NEEDED
    mysgw: MCO:BGN:STP
    mysgw: MCO:BGN:INIT OK,TSP=1
    

    Domoticz Log

    2017-10-10 18:43:07.538 MySensors: Using serial port: /dev/ttyUSB020
    2017-10-10 18:43:07.538 Error: Serial Port closed!... Error: End of file
    2017-10-10 18:43:08.538 MySensors: retrying in 30 seconds...
    

    Repeats every 30th second,

    Commands with 2.2.0 Beta (Ethernet GW)

    ./configure --my-transport=nrf24
    ./configure --my-gateway=ethernet --my-port=5003
    ./configure --my-gateway=ethernet --my-controller-ip-address=127.0.0.1
    make
    

    Debug Log

    mysgw: Starting gateway...
    mysgw: Protocol version - 2.2.0-beta
    mysgw: MCO:BGN:INIT GW,CP=RNNGL---,VER=2.2.0-beta
    mysgw: TSF:LRT:OK
    mysgw: TSM:INIT
    mysgw: TSF:WUR:MS=0
    mysgw: TSM:INIT:TSP OK
    mysgw: TSM:INIT:GW MODE
    mysgw: TSM:READY:ID=0,PAR=0,DIS=0
    mysgw: MCO:REG:NOT NEEDED
    mysgw: connect: Connection refused
    mysgw: failed to connect
    mysgw: Eth: connect
    mysgw: connect: Connection refused
    mysgw: failed to connect
    mysgw: Eth: connect
    

    Commands with 2.1.1 (serial GW)

    ./configure --my-transport=nrf24
    ./configure --my-gateway=serial --my-serial-is-pty --my-serial-pty=/dev/ttyUSB020
    make
    

    Debug Log

    mysgw: Starting gateway...
    mysgw: Protocol version - 2.1.1
    mysgw: MCO:BGN:INIT GW,CP=RNNG---,VER=2.1.1
    mysgw: TSM:INIT
    mysgw: TSF:WUR:MS=0
    mysgw: !TSM:INIT:TSP FAIL
    mysgw: TSM:FAIL:CNT=1
    mysgw: TSM:FAIL:PDT
    

    Commands with 2.1.1 (Ethernet GW)

    ./configure --my-transport=nrf24
    ./configure --my-gateway=ethernet --my-port=5003
    ./configure --my-gateway=ethernet --my-controller-ip-address=127.0.0.1
    make
    

    Debug Log

    mysgw: Starting gateway...
    mysgw: Protocol version - 2.1.1
    mysgw: MCO:BGN:INIT GW,CP=RNNG---,VER=2.1.1
    mysgw: TSM:INIT
    mysgw: TSF:WUR:MS=0
    mysgw: !TSM:INIT:TSP FAIL
    mysgw: TSM:FAIL:CNT=1
    mysgw: TSM:FAIL:PDT
    

  • Mod

    @miljume thanks. And yes, there seems to be something fishy going on since other people also have problems.

    I don't have a spare raspberry pi at the moment so I can't reproduce the problem. Hopefully someone else can help troubleshooting. I'll try to get my hands on a new raspberry within a week.


  • Mod

    @miljume said in NRF24L01+ problems in 2.1.1 and 2.2.0 Beta:

    ./configure --my-transport=nrf24
    ./configure --my-gateway=ethernet --my-port=5003

    it should be on a single line like this

    ./configure --my-transport=nrf24 --my-gateway=ethernet --my-port=5003
    

    --my-controller-ip-address=127.0.0.1 is not needed



  • @gohan Thanks, will try that as soon as I can


  • Mod

    @miljume I've seen the same length errors in the past when my radio wiring wasn't stable (flaky jumper wires). The TSP Fail messages indicate the same.
    Could you check your connections from the pi to the radio?



  • @Yveaux Thanks for the feedback but I am using a RPI Shield so the connections should be stable



  • @miljume I am having the same issue since 2.1 and trying to revert to 2.2 beta it fails as well. I am using an RPi model 2 B and the same RPI shield (I have traded out the shield as I have a few and same result). All of my nodes have been offline for months as the gateway does not function.


  • Mod

    I remember there was a bug in the library for rpi2 but I can't remember the details



  • @gohan That bug had to do with the chipset but that was resolved i think.



  • @gohan Now I have tried compiling it with one line command but the GW still don't start with 2.1.1

    ./configure --my-transport=nrf24 --my-gateway=ethernet --my-port=5003
    
    mysgw: Starting gateway...
    mysgw: Protocol version - 2.1.1
    mysgw: MCO:BGN:INIT GW,CP=RNNG---,VER=2.1.1
    mysgw: TSM:INIT
    mysgw: TSF:WUR:MS=0
    mysgw: !TSM:INIT:TSP FAIL
    mysgw: TSM:FAIL:CNT=1
    mysgw: TSM:FAIL:PDT
    

  • Mod

    @miljume I see alternating !TSM:INIT:TSP Fail and TSM:INIT:TSP OK in your logs.
    The fails indicate a failure to communicate with the radio module.
    Is there a pattern in these fails between software versions?



  • @Yveaux The FAIL´s all occur with 2.1.1 and the OK is with 2.2.0 Beta. Same radio connections for both so the FAIL´s should not be connected to communication with the radio module. I have also tried 3 radios and 2 different ways of connecting them (Shield and Dupont cables) Even if 2.2.0 starts OK the problem is that it for the Ethernet GW it fails to connect

    mysgw: Starting gateway...
    mysgw: Protocol version - 2.2.0-beta
    mysgw: MCO:BGN:INIT GW,CP=RNNGL---,VER=2.2.0-beta
    mysgw: TSF:LRT:OK
    mysgw: TSM:INIT
    mysgw: TSF:WUR:MS=0
    mysgw: TSM:INIT:TSP OK
    mysgw: TSM:INIT:GW MODE
    mysgw: TSM:READY:ID=0,PAR=0,DIS=0
    mysgw: MCO:REG:NOT NEEDED
    mysgw: connect: Connection refused
    mysgw: failed to connect
    mysgw: Eth: connect
    mysgw: connect: Connection refused
    mysgw: failed to connect
    mysgw: Eth: connect
    

    And for the Serial GW it gives the following error in Domoticz

    2017-10-10 18:43:07.538 MySensors: Using serial port: /dev/ttyUSB020
    2017-10-10 18:43:07.538 Error: Serial Port closed!... Error: End of file
    2017-10-10 18:43:08.538 MySensors: retrying in 30 seconds...
    

    None of them picks up sensor reports


  • Mod

    Do you have a spare microsd and try a clean install ?



  • @gohan I have tried a clean install both with Rapbian Stretch and Raspbian Jessie but the results are the same


  • Mod

    Did you check if spi is enabled in configuration? Sorry for stupid questions, but I need to broaden the search for the issue



  • @gohan, I can only speak for me but I have done the following on my RPi 2 B:
    Changed out radios
    Used shield for radio or just straight wiring to radio
    New flash of latest minimal Raspbian
    Enabled SPI

    And various combinations of those. Maybe something broke in an update to Raspbian or some other change to the mysensors repo?



  • @gohan Yes, otherwise it fails already during build



  • This post is deleted!


  • With 2.1.1 I have the exact same problems.

    However, everything seems to be fine with 2.2.0 Beta:

    git clone https://github.com/mysensors/MySensors.git --branch development
    cd MySensors
    ./configure --my-transport=nrf24 --my-gateway=ethernet --my-port=5003 --my-rf24-pa-level=RF24_PA_MAX
    make
    

    In domoticz:
    0_1508010294046_Udklip.PNG

    The result:

    pi@raspberrypi:~/MySensors $ sudo ./bin/mysgw -d
    mysgw: Starting gateway...
    mysgw: Protocol version - 2.2.0-beta
    mysgw: MCO:BGN:INIT GW,CP=RNNGL---,VER=2.2.0-beta
    mysgw: TSF:LRT:OK
    mysgw: TSM:INIT
    mysgw: TSF:WUR:MS=0
    mysgw: TSM:INIT:TSP OK
    mysgw: TSM:INIT:GW MODE
    mysgw: TSM:READY:ID=0,PAR=0,DIS=0
    mysgw: MCO:REG:NOT NEEDED
    mysgw: Listening for connections on 0.0.0.0:5003
    mysgw: MCO:BGN:STP
    mysgw: MCO:BGN:INIT OK,TSP=1
    mysgw: TSF:MSG:READ,2-2-0,s=1,c=1,t=0,pt=7,l=5,sg=0:24.0
    mysgw: TSF:MSG:READ,2-2-0,s=2,c=1,t=1,pt=2,l=2,sg=0:58
    

    After success with 2.2.0 Beta I tried to go back to 2.1.1. However, it still does not work.

    I am on rpi3 and use a socket adapter board for the radio.



  • So, I did a lot of re-configuring and using 2.2.0 beta when a node sends a value payload (in my case a temp/humidity/battery value I get this while running my RPi ethernet gateway in debug:

    mysgw: TSF:MSG:READ,3-3-255,s=255,c=3,t=7,pt=0,l=0,sg=0:
    mysgw: TSF:MSG:BC
    mysgw: TSF:MSG:FPAR REQ,ID=3
    mysgw: TSF:CKU:OK,FCTRL
    mysgw: TSF:MSG:GWL OK
    mysgw: !TSF:MSG:SEND,0-0-3-3,s=255,c=3,t=8,pt=1,l=1,sg=0,ft=0,st=NACK:0
    mysgw: TSF:MSG:READ,3-3-255,s=255,c=3,t=7,pt=0,l=0,sg=0:
    mysgw: TSF:MSG:BC
    mysgw: TSF:MSG:FPAR REQ,ID=3
    mysgw: TSF:CKU:OK,FCTRL
    mysgw: TSF:MSG:GWL OK
    

    This continues until I kill the process. In the middle of all of these error messages though, it also reports client PING events:

    mysgw: Client 0: 0;0;3;0;18;PING
    

    Other interesting items of note:
    Domoticz says the values for temp have not been updated for 3+ hours for that node.
    Domoticz says that node only has a temp sensor.
    MYSController reports it having 2 sensors (temp and humidity) and it reports the values when i would expect them to be sent (ie, not 3+ hours old but updated continuously when temp changes).

    I am at my wits end here.


  • Mod

    NACK on the gateway usually means that the radio module is not powered correctly or there is a range issue (or you didn't set max tx power on the gateway)



  • This is getting odder and odder.
    I am running 2.2.1 beta on my RPi2B. It is running on channel 76, with power max, and using ethernet gateway config.
    I have MYSController running on separate laptop and it is seeing updates to temp/hum and/or battery level. However, neither Domoticz or OpenHab2 have seen a change since last night at 9pm.

    In Domoticz - Setup - Hardware - Mysensors 2.2.0 Gateway it shows 2 nodes. First node is the gateway, of course, and the second is the sensor node. The data and the last seen times are correct! But, the Domoticz - Setup - Device list only shows the Temp sesnor and a last seen date of last night at 9pm. There are not other mysensors devices available.
    So, what is different between MYSControler and Domoticz and OpenHab?



  • @gohan This doesnt really make sense to me. This happens after I get data from a sensor and the gateway gets stuck in a loop of those messages. MYSControler shows the correct value that triggered these messages while OpenHab and Domoticz do not.


  • Mod

    Do you have capacitors on the radio modules? If you move the node closer to the gateway (3/4 meters apart) , does it work better?



  • @gohan Yes, capacitors on both the node(s) and the gateway radios. Moving the nodes closer to gateway has no affect. The gateway is sending out udpates (per MYSControler at least) but Domoticz sees no new devices and OpenHab has not seen an update either. So frustrating.


  • Mod

    Try to stop the gateway and run it with debug from console and c'è if you see any NACK occurring, also on the node if you can, because probably the controller is not accepting messages with NACK. If you can, try to make another arduino based gateway and see if you still get same errors. Keep in mind that if radio modules are not genuine you have to consider they are the cause of your problems.



  • @gohan unable to run my node in debug with radio attached at the moment (no 3.3v FTDI or mosfets available right now).
    But, that being said - the MYSControler does get the updated values. Just not Domoticz or OpenHab. So, why does one client connecting to the gateway get data while the other two do not?


  • Mod

    Myscontroller doesn't see all debug messages. Get a ftdi adapter quickly 😁



  • @gohan Yea, I have one on order taking the slow boat from China. But, it bothers me that MYSControler "gets" the sensor node values and the other controlers do not. Same IP config. And the weird NACK errors. Something just seems screwy as this hardware was working up until about 3 months ago - no changes made.


  • Mod

    I have now purchased an extra Raspberry Pi to test the raspberry pi gw.

    2.1.1 fails with the most basic configure (without any parameters) while the same wiring and configure command works for development (I used commit 901258f16598)

    git checkout 2.1.1
    ./configure
    ...
    make
    ...
    sudo ./bin/mysgw -d
    mysgw: Starting gateway...
    mysgw: Protocol version - 2.1.1
    mysgw: MCO:BGN:INIT GW,CP=RNNG---,VER=2.1.1
    mysgw: TSM:INIT
    mysgw: TSF:WUR:MS=0
    mysgw: !TSM:INIT:TSP FAIL
    mysgw: TSM:FAIL:CNT=1
    mysgw: TSM:FAIL:PDT
    
    git checkout development
    ./configure
    ...
    make
    ...
    mysgw: Starting gateway...
    mysgw: Protocol version - 2.2.0-beta
    mysgw: MCO:BGN:INIT GW,CP=RNNGL---,VER=2.2.0-beta
    mysgw: TSF:LRT:OK
    mysgw: TSM:INIT
    mysgw: TSF:WUR:MS=0
    mysgw: TSM:INIT:TSP OK
    mysgw: TSM:INIT:GW MODE
    mysgw: TSM:READY:ID=0,PAR=0,DIS=0
    mysgw: MCO:REG:NOT NEEDED
    mysgw: Listening for connections on 0.0.0.0:5003
    mysgw: MCO:BGN:STP
    mysgw: MCO:BGN:INIT OK,TSP=1
    

    I'm not sure how to proceed though. Is there anything you want me to try?


  • Mod

    This is the verbose rf24 output. Not sure if it helps.
    2.1.1:

    ./configure --extra-cxxflags="-DMY_DEBUG -DMY_DEBUG_VERBOSE_RF24" && make && sudo bin/mysgw -d
    mysgw: Starting gateway...
    mysgw: Protocol version - 2.1.1
    mysgw: MCO:BGN:INIT GW,CP=RNNG---,VER=2.1.1
    mysgw: TSM:INIT
    mysgw: TSF:WUR:MS=0
    mysgw: RF24:write register, reg=0, value=14
    mysgw: RF24:write register, reg=3, value=3
    mysgw: RF24:write register, reg=4, value=95
    mysgw: RF24:write register, reg=5, value=76
    mysgw: RF24:write register, reg=6, value=39
    mysgw: RF24:write register, reg=16, value=115
    mysgw: RF24:write register, reg=29, value=6
    mysgw: RF24:read register, reg=6, value=0
    mysgw: RF24:read register, reg=5, value=0
    mysgw: !RF24:INIT:SANCHK FAIL
    mysgw: !TSM:INIT:TSP FAIL
    
    

    development:

    ./configure --extra-cxxflags="-DMY_DEBUG -DMY_DEBUG_VERBOSE_RF24" && make && sudo bin/mysgw -d
    mysgw: Starting gateway...
    mysgw: Protocol version - 2.2.0-beta
    mysgw: MCO:BGN:INIT GW,CP=RNNGL---,VER=2.2.0-beta
    mysgw: TSF:LRT:OK
    mysgw: TSM:INIT
    mysgw: TSF:WUR:MS=0
    mysgw: RF24:INIT
    mysgw: RF24:INIT:PIN,CE=22,CS=24
    mysgw: RF24:WBR:REG=0,VAL=14
    mysgw: RF24:WBR:REG=3,VAL=3
    mysgw: RF24:WBR:REG=4,VAL=95
    mysgw: RF24:WBR:REG=5,VAL=76
    mysgw: RF24:WBR:REG=6,VAL=37
    mysgw: RF24:WBR:REG=16,VAL=115
    mysgw: RF24:WBR:REG=29,VAL=4
    mysgw: RF24:RBR:REG=6,VAL=37
    mysgw: RF24:RBR:REG=5,VAL=76
    mysgw: RF24:WBR:REG=2,VAL=2
    mysgw: RF24:WBR:REG=1,VAL=0
    mysgw: RF24:WBR:REG=28,VAL=3
    mysgw: RF24:FRX
    mysgw: RF24:FTX
    mysgw: RF24:WBR:REG=7,VAL=112
    mysgw: TSM:INIT:TSP OK
    mysgw: TSM:INIT:GW MODE
    mysgw: RF24:WBR:REG=2,VAL=3
    mysgw: RF24:WBR:REG=1,VAL=1
    mysgw: RF24:STL
    mysgw: RF24:WBR:REG=0,VAL=15
    mysgw: RF24:WBR:REG=10,VAL=0
    mysgw: TSM:READY:ID=0,PAR=0,DIS=0
    mysgw: MCO:REG:NOT NEEDED
    mysgw: RF24:RBR:REG=23,VAL=17
    mysgw: Listening for connections on 0.0.0.0:5003
    


  • @miljume Are you using modules with the genuine Nordic Devices mounted on them? How do you have it connected? Are you successful with any other "compatible" modules?


  • Mod

    @Jokgi to my knowledge, there is no way to know if devices are genuine, besides sending them to Nordic to have them checked. I have not done that, so I don't know whether they are genuine.

    The radio module is connected using a 2x4 pin jumper wire connector on the nrf24 end and a 2x5 jumper wire connector on the raspberry pi end. Wiring for the nrf end is according to https://www.mysensors.org/build/connect_radio and https://www.mysensors.org/build/raspberry for the raspberry pi end.

    I don't understand your third question. Could you clarify/rephrase?


  • Mod

    I think he is asking if you tried other modules from different manufacturer


  • Mod

    Thanks @gohan
    In that case, the answer is that I don't know. I have ordered through Aliexpress 3-4 times. I don't know which modules came from which order, or if the orders were sourced from different manufacturers.


  • Mod

    I have now tracked down the commit that makes the default raspberry pi gateway work: https://github.com/mysensors/MySensors/commit/4c31e22d6ff45c3a4f8aa70f915c5f10fe345f64

    When using the commit before this (26c237adadda9f79b07d862708d8471285a96905 ) the radio init fails.

    So now we at least know why development works and 2.1.1 does not.

    git checkout 26c237adadda9f79b07d862708d8471285a96905
    ...
    ./configure --extra-cxxflags="-DMY_DEBUG -DMY_DEBUG_VERBOSE_RF24" && make && sudo bin/mysgw -d
    ...
    mysgw: Starting gateway...
    mysgw: Protocol version - 2.2.0-beta
    mysgw: MCO:BGN:INIT GW,CP=RNNG----,VER=2.2.0-beta
    mysgw: TSF:LRT:OK
    mysgw: TSM:INIT
    mysgw: TSF:WUR:MS=0
    mysgw: RF24:INIT
    mysgw: RF24:INIT:PIN,CE=9,CS=24
    mysgw: RF24:WBR:REG=0,VAL=14
    mysgw: RF24:WBR:REG=3,VAL=3
    mysgw: RF24:WBR:REG=4,VAL=95
    mysgw: RF24:WBR:REG=5,VAL=76
    mysgw: RF24:WBR:REG=6,VAL=37
    mysgw: RF24:WBR:REG=16,VAL=115
    mysgw: RF24:WBR:REG=29,VAL=6
    mysgw: RF24:RBR:REG=6,VAL=0
    mysgw: RF24:RBR:REG=5,VAL=0
    mysgw: !RF24:INIT:SANCHK FAIL
    mysgw: !TSM:INIT:TSP FAIL
    
    git checkout 4c31e22d6ff45c3a4f8aa70f915c5f10fe345f64 #68
    ...
    ./configure --extra-cxxflags="-DMY_DEBUG -DMY_DEBUG_VERBOSE_RF24" && make && sudo bin/mysgw -d
    ...
    mysgw: Starting gateway...
    mysgw: Protocol version - 2.2.0-beta
    mysgw: MCO:BGN:INIT GW,CP=RNNG----,VER=2.2.0-beta
    mysgw: TSF:LRT:OK
    mysgw: TSM:INIT
    mysgw: TSF:WUR:MS=0
    mysgw: RF24:INIT
    mysgw: RF24:INIT:PIN,CE=22,CS=24
    mysgw: RF24:WBR:REG=0,VAL=14
    mysgw: RF24:WBR:REG=3,VAL=3
    mysgw: RF24:WBR:REG=4,VAL=95
    mysgw: RF24:WBR:REG=5,VAL=76
    mysgw: RF24:WBR:REG=6,VAL=37
    mysgw: RF24:WBR:REG=16,VAL=115
    mysgw: RF24:WBR:REG=29,VAL=6
    mysgw: RF24:RBR:REG=6,VAL=37
    mysgw: RF24:RBR:REG=5,VAL=76
    mysgw: RF24:WBR:REG=2,VAL=2
    mysgw: RF24:WBR:REG=1,VAL=0
    mysgw: RF24:WBR:REG=28,VAL=3
    mysgw: RF24:FRX
    mysgw: RF24:FTX
    mysgw: RF24:WBR:REG=7,VAL=112
    mysgw: TSM:INIT:TSP OK
    mysgw: TSM:INIT:GW MODE
    mysgw: RF24:WBR:REG=2,VAL=3
    mysgw: RF24:WBR:REG=1,VAL=1
    mysgw: RF24:STL
    mysgw: RF24:WBR:REG=0,VAL=15
    mysgw: RF24:WBR:REG=10,VAL=0
    mysgw: TSM:READY:ID=0,PAR=0,DIS=0
    mysgw: MCO:REG:NOT NEEDED
    mysgw: RF24:RBR:REG=23,VAL=17
    mysgw: Listening for connections on 0.0.0.0:5003
    
    
    


  • I am glad I'm not the only one having this issue (but hope it will be resolved soon).
    I had a RPi3 with the MQTT gateway working well for the past year, until I decided to upgrade to the latest version of Raspbian (and MySensors). I've now tried with a fresh install on both the RPi3 and a RPi2; with the same NRF24 as before (working well in the previous build); I also tried with a different radio using a socket and capacitor.
    Looking forward to your progress!

    mysgw: Starting gateway...
    mysgw: Protocol version - 2.1.1
    mysgw: MCO:BGN:INIT GW,CP=RNNG---,VER=2.1.1
    mysgw: TSM:INIT
    mysgw: TSF:WUR:MS=0
    mysgw: !TSM:INIT:TSP FAIL
    mysgw: TSM:FAIL:CNT=1
    mysgw: TSM:FAIL:PDT
    mysgw: TSM:FAIL:RE-INIT
    mysgw: TSM:INIT
    mysgw: !TSM:INIT:TSP FAIL
    mysgw: TSM:FAIL:CNT=2
    mysgw: TSM:FAIL:PDT
    
    


  • @Jokgi Mots probably they are not genuine (bought from Aliexpress) but these devices themselves have not caused me any issues before. It started when I upgraded to 2.1.1. Although, after a clean install with 2.2.0 Beta it started working again so I am 100% sure that it's not the modules



  • @mfalkvidd Good! I have now succeded in getting 2.2.0 Beta up and running with Ethernet GW



  • @mfalkvidd said in NRF24L01+ problems in 2.1.1 and 2.2.0 Beta:

    git checkout 4c31e22d6ff45c3a4f8aa70f915c5f10fe345f64

    Okay, this works for me now as well. However, Domoticz still doesn't report any updated data beyond the first seen measurement for the temp portion of the sensors....I am about to see how far these slim nodes can fly...



  • I had the same problem with 2.1.1 on a Raspberry Pi Zero W.

    Changing to the development version fixed it.



  • I'm trying to connect Domoticz to a virtual serial.

    ./configure --my-transport=nrf24 --my-rf24-irq-pin=15 --my-rf24-pa-level=RF24_PA_LOW --my-gateway=serial --my-serial-is-pty --my-serial-pty=/dev/serial2

    But while Domoticz sees the serial port, it does not seem to connect. I also see the "end of file" error in the Domoticz logs.

    What baudrate should be set in Domoticz?


  • Mod

    Compile as ethernet GW, much less problems 😄



  • Tried that, still having problems.

    Syslog says a lot of: "mysgw: Client 0: 0:0:3:0:18:PING
    with an occasional "rsyslogd-2007: action 'action 17' suspended, which is probanly about the log being spammed by MySensors.

    • It uses a 3.3v stabiliser board.
    • Tried different power levels in settings (usually use low power because it works better for the cheap Chinese knock-offs)
    • Tried external 5v power supply.

    My nodes are saying 'FPAR: NO REPLY'


 

256
Online

7.8k
Users

8.7k
Topics

93.0k
Posts