Need volunteer: MyController 1.2.0-SNAPSHOT version with major provider changes and supports for ack


  • Plugin Developer

    Need volunteers to test 1.2.0-SNAPSHOT version. This version has major changes on the provider side.
    Now it supports ack.

    Report your issues here

    CAUTION: This version might have major bugs, do not use it in your production environment.
    Do backup your existing version and move to this version.

    Steps to do backup/restore

    Changes: https://github.com/mycontroller-org/mycontroller/commit/67b4f148ea36cd37d917d7560ffaed35871d2b6a

    Remove following directory, if you do the dirty upgrade:

    # rm mycontroller/conf/persistent_stores/mc/* -rf
    

    To enable ack, edit gateway and,
    0_1517923759284_aee5649c-7b34-4a58-aa16-b9c220385d20-image.png

    To see gateway Statistics go to gateway details:
    0_1517923734621_7eac658c-40b1-47c9-a6a8-13f2718fe295-image.png


  • Mod

    If you want I can test the FOTA too


  • Plugin Developer

    @gohan Yes, please report your experience on this version


  • Mod

    Preliminary test: if ACK enabled on gateway, OTA transfer is terribly slow.
    I am getting also quite some WRONG FWB on the node (they are 2 meters apart)
    I noticed that when SmartSleep option is enabled in node configuration the OTA process starts pretty much all the time
    I am still encountering problems when assigning the FW to node: in the beginning it works but after a few tests it stops working and I had to delete node from mycontroller and after that I was able to start OTA again.


  • Plugin Developer

    @gohan

    Preliminary test: if ACK enabled on gateway, OTA transfer is terribly slow.

    What type of gateway are you using? MQTT? Whatever type. When we enable ack it will double the data rate. If we feel ack not required only for OTA, I can add some option to control ACK on OTA.

    I am getting also quite some WRONG FWB on the node (they are 2 meters apart)

    Could you please elaborate this issue?

    I noticed that when SmartSleep option is enabled in node configuration the OTA process starts pretty much all the time
    sending OTA all the time? on all the walkup?

    I am still encountering problems when assigning the FW to node: in the beginning it works but after a few tests it stops working and I had to delete node from mycontroller and after that I was able to start OTA again.

    I will check this. Can you please explain your set-up?

    Thank you for all the tests!

    In the gateway details page you can see time taken to process messages,
    0_1518371160915_0828af14-3ec6-40cd-8a68-1116681e803a-image.png


  • Mod

    I have a raspberry pi 3 as test bench, it is running dietpi with Mysensors ethernet gateway and RFM69 radio on RPI GPIO, MyController is running on sam,e RPI3.
    WRONG FWB are Firmware Blocks that gets corrupted during OTA transfer and need to be resent. I am getting inconsistent results as there are times the OTA fails because of too many errors and other times it goes quite smooth and fast: node and gateway are kept in same position but I don't think it is related to MyController.


  • Mod

    I don't know why but now OTA works better; I still get quite some NACKs on the gateway but at least most of the times the OTA is successful even with signing enabled. With ACK enabled the transfer speed is at least 4/5 times slower


 

295
Online

7.8k
Users

8.7k
Topics

93.0k
Posts