It seems I have similar problems as others.



  • Help! I have similar issues that I see others have. But for the life of me, I cannot seem to fix the issues by reading the forum posts.

    Controller: raspberry pi 2
    Gateway: Arduino Pro Micro (connected to USB port of Pi)
    Gateway Radio: nRF24+ (connected to Micro)

    Temperature Node: Arduino Pro Micro
    Temperature Node Radio: nRF24+ (connected to Micro)

    When I turn on the Temp. Node I see the following.

    upload-31d336e5-0ac9-4479-9ff0-27446a7c22c6

    I then Set the Address. Using 1. I've also tried 10. I'm a noob so I don't quite know exactly if I am mapping Node-ID and Pidome correctly. I only have 1 Node.

    upload-c84b9fe3-7ae9-42b5-a8b5-311217f4abec

    This is what I see under Drivers.
    upload-5d2d5386-65c8-44d9-accb-947c42189d46

    I've read, this is a problem, because the gateway is not able to talk to the Node.

    This is what I have programmed on the Arudino - Temperature Node.
    upload-16e7e065-b18f-4a72-8e24-9876879b817f

    Here is my Custom Device Setup
    upload-90597525-8656-417d-83d7-a4a7d9ee9dfc
    upload-e2bce70b-cac9-4493-adeb-8a6d24093f30
    upload-a5561729-a9da-44c6-a459-f95072c9ef7e
    upload-4b8c2a31-4c45-48c4-a5f1-cd383f0599a7


  • Plugin Developer

    @den2k
    Could you elaborate more on "I have similar issues that I see others have" ?

    All your configurations look correct. It does not seem to correctly read the the gateway version number. This could possibly cause the problem the node id is not send correctly.

    Could you remove the Arduino pro micro from the usb port, wait a couple of seconds, re-connect it, and copy/paste the "Last known messages" list after refreshing the driver page?

    [EDIT]
    P.S. The description for the address is shown when you would manually add this device skeleton as a device to the server. Changing it to something like a reminder of what to enter could be handy (unless this is just used as a kind of note field).

    In the future it is possible to share your created devices with others, if you would publish this device to this they will see what you have entered here.
    [/EDIT]



  • The problem i have is while Pidome seems to know when a new Node Sensor is on the network (ie: Discovered drvices Orange notification) I cannot go any further. I try to set the Address. And it just stays unconfigured.

    Here is some additional info.
    After unplugging the Pro Micro Gateway and plugging it back in. The Peripheral reset, so this is what I used as settings. This was also the same settings I used before.
    upload-91ca9872-773b-4579-b82e-30c89be38346

    This is what i see in the Drivers screen. Same as before. Pidome seems unable to configure/communicate any further with the added Sensor Node.
    upload-0b3e4422-e18d-4863-adda-8c74f2782302



  • I also have this issue every time I reload the Dashboard. I don't believe it has any issue with Node Discovery, but I figure I add it here.

    upload-17de0499-3165-425c-bbf3-3e4e3405d683

    I think I saw this fixed somewhere on the forum, so I'll look at up when I get a chance.


  • Plugin Developer

    @den2k

    I am not seeing a gateway ready nor a mysensors version number in the last known messages. When you attach the gateway to your pc and open the Arduino monitor (setting the baud rate to 115200) could you post what you see?

    I'm currently not able to test the 1.5 version of mysensors so i'm not sure if the gateway ready message is still being printed by the gateway.

    Yes the popup should have been fixed. The default dashboard does a request to check if there is a weather plugin active and if there is one show the weather info (Unless you have modified the dashboard then let me know which change you made). I made an error in checking a correct field (as in time of creating i had a weather plugin active and forgot to test without having one active). If it is still there let me know as i then have to check my local development branch. (Make sure to clear your browser cache).



  • I see nothing.

    I reprogrammed a new Serial Gateway using a new Arduino Pro Micro and nRF+ radio. Thought it might be hardware related.

    I plugged in the Serial.Gateway into the Pi. Pidome "sees" it under Peripherals. I set it up like above, but under Driver Settings/Gateway info it still says "Waiting for gateway" like the above pictures.

    I plug the Arduino back into the PC. I pulled up the Serial Monitor. 115200 baud. I see nothing on the monitor.


  • Plugin Developer

    Do you information from nodes appearing when you leave the gateway connected?

    Maybe @hek can enlighten this a bit if the gateway still sends out a gateway ready message. Which version of mysensors are you using and have you turned on/off debug message logging?

    Try to make sure that you get information in the serial monitor, when it does plug it info the pi.


  • Admin

    @John said:

    Maybe @hek can enlighten this a bit if the gateway still sends out a gateway ready message. Which version of mysensors are you using and have you turned on/off debug message logging?

    Yes, it does:
    https://github.com/mysensors/Arduino/blob/master/libraries/MySensors/examples/SerialGateway/SerialGateway.ino#L107


  • Plugin Developer

    @hek thanks!

    @den2k PiDome really needs the gateway ready message. It then knows when the arduino is ready to handle data (as different arduino's have different serial available times (for example with the pro mini it is advised to wait a second before sending anything)).

    So when you see the gateway ready message appearing in your serial monitor you are ready to go on the pi.



  • Thanks. This is helpful. Not really sure why I don't have a gateway ready message on the monitor. I'll try the double reset and see if the issue is the Micro not getting programmed correctly. The weird thing is I have one 16Mhz Pro Micro and a bunch of 3.3v Micros. The 16mhz micro say Arduino Leonardo, while the 8mhz micros say Sparkfun Pro Micro. I only use the 8mhz micros and I've been assuming the firmware on the SF ones are with the 8 sec wait time. Given with other RF24 examples and even mesh was working on the same hardware....

    I'll update if I get further.


  • Plugin Developer

    @den2k

    As you say that one of the micro's is being displayed as a leonardo is because the server has a vendor and product id mapping (the usb vid/pid).
    I have checked my database with vid/pid combinations and the leonardo has id 0x8036. When i check the Arduino application boards.txt file it also says that 0x8036 belongs to an Arduino leonardo. This is in this file:

    leonardo.build.mcu=atmega32u4
    leonardo.build.f_cpu=16000000L
    leonardo.build.vid=0x2341
    leonardo.build.pid=0x8036
    leonardo.build.usb_product="Arduino Leonardo"
    leonardo.build.board=AVR_LEONARDO
    leonardo.build.core=arduino
    leonardo.build.variant=leonardo
    leonardo.build.extra_flags={build.usb_flags}

    As you can see, this usb pid belongs to the leonardo. Are you sure you are not using a clone an/or have you selected the correct board in the Arduino IDE while uploading your sketch? If you bought originals, check the last one.



  • I am using cheap Pro Micros bought on Ebay. I'm really not sure what the issue is. I have other sketches that work on the Pro Micro. Even RF24 sketechs passing info between radios. I have several and have swapped out the Micro and the nRF radio. Not thinking it is hardware.

    upload-32d1b52f-993c-4fad-93d9-7358389c4f3c

    As you can see, in the Device Manager. I have the SparkFun Pro Micro drivers installed on the PC and it detects the board as I plug it in.

    I believe it recognizes it as a Pro Micro. I also installed the Pro Micro Arduino plug in, which is shown on the Pull down Menu. Nothing shows up when I upload the standard library/SerialGateway sketch in the Serial Monitor.

    I am pulling out my hair with this. I have other threads going on other topics, but it all now boils down it seems to not being able to properly program the Serial Gateway on the Pro Micro.

    Others have done it, but I cannot get it to work?


  • Plugin Developer

    Try to put a delay of 2 seconds in the setup part of the sketch before anything is initialized. I have encountered a "spakerFun" ebay clone board someone used (which could be identified as a leonardo pro micro from the usb descriptors). It was with a complete different project but there sketch he used just printed out the first serial output too early.



  • I did a few things.

    1. Added 2 sec delay to Setup loop for the Pro Micro. Nope. Still didn't work.
    2. Went off and used an official Uno. Was able to finally see the Gateway Statup
      upload-03609f24-91ae-44db-8116-b2a9709326c6
    3. Went back to Pidome. Now cannot see new Nodes. Added. With a non working Gateway, I was at least able to see when I added a new Node, even though Pidome did not see the gateway. Now I cannot see a node....


  • Finally getting somewhere.

    upload-6373c65b-9f13-457e-b3e5-1d30ce13789e

    At least with the new Pro Mini's I am now using with PiDome, it is detecting the Pro Mini Serial Gateway that is plugged into the USB port on the Pi.

    Now I just have to figure out what Device Discovery doesn't see the Node I powered up, but the Driver section under messages as you can see above can see the Node.

    This is all for today. Now have to figure what's next given it is not completely working yet.


  • Plugin Developer

    Have you turned on device discovery? Currently by default everything that can do device discovery should be enabled to do so.
    It is one of the security measurements taken in the server so discovery is not enabled without user knowledge.

    If it is turned on, detach and attach your pro mini (give it a second of two minimal between this) and post a part of the log where you can see the driver ask the the gateway for the version number.



  • This is what I get when I first plug in the Serial gateway (Pro Mini) into the Pi USB port.

    upload-adf125e8-2f0b-48b3-9391-a5d508845e3f

    I then turn on Enable Device Discovery on Pidome and set this to Single Device (I've also tried 10 minutes). After that I turned on the sensor Node (Pro Mini).

    The Node IS NOT discovered. This is what it shows under Drivers. All the radios attached to the Pro Mini's are nRF24+ radios.

    upload-db5a7ee8-f739-48ae-9bbc-95ad5f7a220b

    Any clues?


  • Plugin Developer

    The server is able to do debug logging. Could you please turn this logging on by going to: "system" > "server" > "debug logging" and switch the toggle button.

    After this re-connect the serial device, turn no discovery and let the log list be filled as your screenshot shows. After a couple of minutes turn on debug logging and send me the following file "logs/system/appLog.txt" to support@pidome.org (as it may contain sensitive information so you do not want to post it online) and include a link to this thread so i know it is yours.

    Cheers!


 

392
Online

8.1k
Users

9.0k
Topics

95.3k
Posts