MYSBootloader 1.4 testing

  • Admin

    Hi all,

    I'm about to finalize the development of MYSBootloader 1.4 with loads of changes and improvements under the hood. If you have some spare time and willingness to test, please reply here with your node config (frequency, channel, csn pin, ce pin).

    This testing is only intended for Atmega328/nRF24L01+ nodes and should not be used in a productive environment.


  • Plugin Developer

    @tekka I would like to test with controller.
    I'm using all default settings,
    Board: Arduino Pro Mini
    RF: nRF24L01+, Channel: 76, CSN:10, CE:9

  • happy to test as well.
    using all default settings v1.5 mysensors libs.

  • count me in!
    i'll be happy putting in some effort to help MYSController!

    arduino pro mini + nRF24L01+ @ 3.5v

  • Happy to test here. ATmega328 @ 1Mhz.

    Channel: 76 / 250kbps
    CSN: 7
    CE: 8

    On-board LED on D9 (not 13)

  • Hardware Contributor

    Just starting to tinker with custom bootloaders, so available for testing.
    All default settings from v1.5 mysensors libs too with pro mini 3.3V 8MHz.

  • Admin

    @jkandasa, @mvader, @diamantmatch , @pdey, @emc2 You received a PM with instructions. Thanks for testing & feedback.

  • @tekka I was able to get a nano setup with radio and sketch.
    make sure it works (saw it on the controller)
    i then burned the new bootloader and re-uploaded the sketch.
    that worked.
    i was able to then also see it back in the controller.
    however i was not able to upload an OTA
    every time i reboot the device it goes into an infinite loop.
    only way to stop it is to pull the power.
    but if you don't reboot, just let it power up, it works fine.
    only upon a reboot, or a re-id does it go into this loop.
    however, it did this before. so i don't think it's related to the new bootloader
    but until i can resolve that, i don't know that i can send OTA's (but i'm close)
    it did work in the past. it seems it worked in 1.4 libs, but when i moved everything over, it started.
    but still strange, i know i've done OTA with 1.5 lib.
    hard to say.
    have a look at the logs see what you think.

  • Admin

    @mvader I do not see MYSBootloader msgs in the log, but DualOptiboot msgs - can you please double-check that you really burnt MYSBootloader?

     [2015-11-25 17:10:57.728 Info] RX	4;255;4;0;0;FFFFFFFFFFFFFFFF0300

    This is a Dualoptiboot message...

  • interesting. i will double check everything.

  • so i checked and it appears it's correct.. have a look at my SSsettings.jpg

    does a nano come default with dual opti? the IDE says it is burning, i see the lights blinking.
    and then says done, lights stop blinking.
    seems like it's working

  • Admin

    @mvader ok, the settings are fine BUT you cannot upload a sketch directly with the Arduino IDE and MYSBootloader, hence, you have the wrong bootloader...In addition, you have MY_OTA_FIRMWARE defined in your MyConfig.h? Please comment it out since this feature may only be used with Dualoptiboot but not MYSBootloader. Can you also make sure that the MYSBootlader.hex file is the one from the PM link?

  • ahh i did still have OTA enabled in myconfig.
    I'll get that changed and tested.

  • @tekka so it took a few tries, but it did work.
    so looking good.
    and at least now i know what is wrong with my other node that goes crazy when i reboot it.
    ha ha.
    here are my logs for the OTA session

  • Can I get in on the test too?

  • Plugin Developer

    @tekka Thank you for the pre release hex file. I tested with controller. It's working good. But I see error messages on the mycontroller.log,

    2015-11-30 23:17:59,371 DEBUG [Thread-5] [org.mycontroller.standalone.gateway.ethernet.EthernetGatewayListener:55] Message Received: 1;255;3;0;15;0
    2015-11-30 23:17:59,378 WARN [Thread-3] [org.mycontroller.standalone.mysensors.ProcessRawMessage:294] Internal Message[type:I_REQUEST_SIGNING,payload:0], This type may not be supported (or) not implemented yet
    2015-11-30 23:18:02,176 DEBUG [Thread-5] [org.mycontroller.standalone.gateway.ethernet.EthernetGatewayListener:55] Message Received: 1;255;3;0;22;0102A00048F7FFFEDAD51FDD001E950F01
    2015-11-30 23:18:02,177 ERROR [Thread-3] [org.mycontroller.standalone.mysensors.MessageMonitorThread:68] RawMessage[NodeId:1,ChildSensorId:255,MessageType:3,Ack:0,SubType:22,Payload:0102A00048F7FFFEDAD51FDD001E950F01] throws exception while processing!, 
    java.lang.IllegalArgumentException: 22
    	at org.mycontroller.standalone.mysensors.MyMessages$MESSAGE_TYPE_INTERNAL.get( ~[mycontroller-standalone-0.0.2-alpha6-SNAPSHOT-single.jar:na]
    	at org.mycontroller.standalone.mysensors.ProcessRawMessage.internalSubMessageTypeSelector( ~[mycontroller-standalone-0.0.2-alpha6-SNAPSHOT-single.jar:na]
    	at org.mycontroller.standalone.mysensors.ProcessRawMessage.messageTypeSelector( ~[mycontroller-standalone-0.0.2-alpha6-SNAPSHOT-single.jar:na]
    	at org.mycontroller.standalone.mysensors.MessageMonitorThread.processRawMessage( [mycontroller-standalone-0.0.2-alpha6-SNAPSHOT-single.jar:na]
    	at [mycontroller-standalone-0.0.2-alpha6-SNAPSHOT-single.jar:na]
    	at [na:1.8.0_65]

    I have few queries,

    • Have you change message format in MYSBootloader 1.4?
    • Is the source code available somewhere for the community?
    • I see a message 1;255;3;0;22;0108A00048F7FFFEDAC71FDD001E950F01 as per the source code in Internal messages we have only 0 to 21 types, Here I received the type 22. What is this?
    • I see 1;255;3;0;15;0 I_REQUEST_SIGNING also, My setup is not configured for signing. Why I'm receiving this message?

  • Admin

    @jkandasa I_INTERNAL/22 is an internal diagnostic message, will be removed in the final 1.4 release.
    I_REQUEST_SIGNING is currently forwarded to the controller if GW has signing disabled.

  • Hi,

    If u still seeking beta tester, I'm here :).

    Arduino Pro Mini 328p 3,3@8 + 5@16, Channel: 108, CSN:10, CE:9

  • Hi,
    Will you update the SampleController for the new bootloader or the protocol unchanged?
    I need a solution to push firmware updates from a Linux machine through a serialgateway to all nodes.

    I'm happy to test and share my experiences.

    Arduino Pro Mini 8/16MHz
    RF: nRF24L01+, Channel: 76, CSN:10, CE:9

  • @tekka
    Hi Tekka, just to understand, the new release of MYSBOOTLOADER you are working on is 1.3 or 1.4?
    Are source of one release available, even in beta?

    I have a setup with ~20 nodes ready to start, but I need an OTA Bootloader, no signing required.
    If you already worked on that, it's a pitty to develop my own Bootloader.

    Thank for all your time spend on that project and hope we can enjoy using your MYSBOOTLOADER


  • Admin

    @Lorenzo 1.3 and 1.4 are variants with different optimizations.I suggest using MYSBootloader 1.1 (MySensorsBootloaderRF24) if you need a bootloader right now.
    The source code / and .HEX can be found here: Adjustments to channel and/or CE/CSN pins require you to recompile the code.

  • @tekka

    Quickly checked the code on 1.1 and it doesn't seem to support normal serial upload?
    It would be great if you could publish 1.3 or 1.4 so people can make use of your efforts until you find the time to finalize it?


  • @tekka
    Thank for your answer. But actually my setup use Mysensor library 2.0.1. So what about MYSBootloader 1.1 and Gateway using Mysensor 2.0.1?
    And as Rickard say, the serial Bootloading is also a must.


  • Hi
    I would like to test too.
    On atmega 328p au 8mhz internal board.

Log in to reply

Suggested Topics

  • 6
  • 3
  • 482
  • 6
  • 3
  • 2
  • 198