Error Sending switch command

  • Hi.

    Im new to Domiticz.

    I have a problem with sending commands to my sensors.

    I have made 1 with one relay and 1 with 4 relay and a scenecontroller.

    Skærmbillede 2015-12-19 kl. 12.32.41.png

    All of them is refreshing "last seen" when im turning the sensor on and off

    Skærmbillede 2015-12-19 kl. 12.41.18.png

    Regads Nikolaj

  • Hardware Contributor

    Hi! Is it a standard MySensors relay you got?
    When i reboot Domoticz for some reason i need to present the relays again or i get this message.

  • @sundberg84 Yes standard relay. Present=reset (turn on and off.)?

  • Hardware Contributor

    Yea 😊 reset.

  • @sundberg84 No change. Still samme massage.

  • Hardware Contributor

    @NBM What Domoticz version do you run? The lastes beta feel more stable than the stable version... or atleast mysensors was pretty new in that version so it might be a good idea to upgrade.

  • @sundberg84 My version on domoticz and i have newst version on mysensor.
    Skærmbillede 2015-12-19 kl. 20.23.48.png

  • Hardware Contributor

    Ok sorry then im out of ideas - do you have any logs we can look at?

  • @sundberg84 Where du i find the logs on domoticz?

  • Hardware Contributor

    The log in Domoticz is by default quite little info, but Setup -> Log
    But if you se anything in the gw when you trigger perhaps?

  • Skærmbillede 2015-12-19 kl. 23.08.39.png
    It shows everytime when im reset the sensor.

  • Hardware Contributor

    And when you switch it looks like this:

    But what about the gateway?

  • Only this is showing when i switch the sensor.
    Skærmbillede 2015-12-19 kl. 23.14.23.png
    Where do i find the log on gateway? GW log?

  • Hardware Contributor

    Yea, the serial log from your arduino - connect the gateway to your computer and open the serial monitor in the arduino IDE.
    Another thing that you can try is to remove the device completley from domoticz, reset the node and add it again in Domoticz.

  • @sundberg84 said:

    Another thing that you can try is to remove the device completely from domoticz, reset the node and add it again in Domoticz.


    I'm having exactly the same problems as NBM.

    I've tried doing as suggested by soundberg84.

    It worked for one Node(relay) but another one does not seam to get up and working. Using the serial gateway it's working.

    I find odd that (Motion Sensor) Nodes are always good and working. It seems to be something concerning relays. Because when the problem occurs it affects all the relays simultaneously.

    My setup is a Raspberry Pi with a serial Gateway. I've had the same problem with the stable version and the beta version.

    Another thing that I've noticed, if there are two Raspberry Pi with the same setup, and with out having the " Accept new Hardware Devices Allow for 5 Minutes " turned on, without resetting the a (Motion Sensor), Domoticz recognizes them on the devices panel.


  • Hardware Contributor

    @hugo_pn If you are using the default relay sketch you need ack back from the gw to switch it. Is the problem in Domoticz (Error sending switch command) or it doesnt get switched?

  • Hi,

    I am using the default relay sketch with button.
    Ack back = acknowledge?

    The message I receive from Domoticz is (Error sending switch command...)
    when the message doesn't appear it switches.

  • Hardware Contributor

    In new Domoticz beta there is so you can enable/disable ack. Havent tried that myself but maybe you can try to change that.
    Also what does your gw serial log say? Maybe we can find some clues there...

  • I'm having the same issue, running Version: 2.3530 Build Hash: 9eef872

    The sensor is number 1, and as soon as i try to change the state i get the "Error sending switch command, check device/hardware !"

    This is what the domoticz is sending:
    0;0;3;0;9;send: 0-0-1-1 s=35,c=1,t=2,pt=0,l=1,sg=0,st=fail:1

    It seems that the problems is that the sensor does not reply correctly, how do i parse the message and reply?


  • @jlaraujo said:

    0;0;3;0;9;send: 0-0-1-1 s=35,c=1,t=2,pt=0,l=1,sg=0,st=fail:

    st=fail means that the message was not received. So this is a hardware issue

Log in to reply





Looks like your connection to MySensors Forum was lost, please wait while we try to reconnect.